On Tue, 4 Feb 2025 12:59:39 GMT, Kevin Rushforth <k...@openjdk.org> wrote:
>> It's a bit more than just a generic handler, it basically encapsulates the >> entire behavior of a window button (including setting its visibility and >> disabled states). > > We generally use "Behavior" in the context of controls. Although not wrong, I > also think another name might be better. Maybe "Controller"? Or "Manager"? Or > ... After contemplating for a while, I still think that "Behavior" is the best name. Not that it matters all that much, since it isn't public API. ------------- PR Review Comment: https://git.openjdk.org/jfx/pull/1605#discussion_r2009052415