> This PR is an audit of several snapping-related methods in `Region`, along > with some bug fixes. > > I've added a helper method `snapAligned()`, which does the exact same thing > as `snapSpace()`, but clearly states that the author knows that the value is > already pixel-aligned. In addition, I've renamed several local variables > around a "rawFoo" and "snappedFoo" naming scheme, so as to make it easier to > see what's what. > > This PR should probably be integrated before the other layout container PRs, > because those use the `Region` layout methods. > > --------- > - [x] I confirm that I make this contribution in accordance with the [OpenJDK > Interim AI Policy](https://openjdk.org/legal/ai).
Michael Strauß has updated the pull request incrementally with two additional commits since the last revision: - revert - review comments ------------- Changes: - all: https://git.openjdk.org/jfx/pull/2278/files - new: https://git.openjdk.org/jfx/pull/2278/files/4f253a31..04332802 Webrevs: - full: https://webrevs.openjdk.org/?repo=jfx&pr=2278&range=04 - incr: https://webrevs.openjdk.org/?repo=jfx&pr=2278&range=03-04 Stats: 77 lines in 2 files changed: 31 ins; 19 del; 27 mod Patch: https://git.openjdk.org/jfx/pull/2278.diff Fetch: git fetch https://git.openjdk.org/jfx.git pull/2278/head:pull/2278 PR: https://git.openjdk.org/jfx/pull/2278
