On Fri, 11 Sep 2026 11:21:20 GMT, Marius Hanl <[email protected]> wrote:

>> modules/javafx.graphics/src/main/java/com/sun/javafx/css/InterpolatorConverter.java
>>  line 102:
>> 
>>> 100:             return switch (funcName) {
>>> 101:                 case "cubic-bezier(" -> CACHE.computeIfAbsent(value, 
>>> key -> {
>>> 102:                     return Interpolator.ofSpline(
>> 
>> This now can be an expression lambda if you like
>
> Also the `key` is unused now here and below. So you could use `_` instead as 
> name.

I've removed the unused variable name here and in other places. However, I've 
kept the braces, as it gives a bit more structure to the code. Usually I use 
expression-style lambdas where possible, but in this case we'd have two nested 
expression lambdas, which I find hard to read.

-------------

PR Review Comment: https://git.openjdk.org/jfx/pull/2303#discussion_r3989704785

Reply via email to