On Tue, 8 Sep 2026 18:43:43 GMT, Marius Hanl <[email protected]> wrote:

> > oof, I don't like the last commit:
> > 
> > 1. too many changes which will give us a lot of merging conflicts
> > 2. I like isWindows() and the like in the base.  I think it's a mistake to 
> > move it to graphics
> 
> I pushed it to show how such a move into `javafx.graphics` would look like. 
> So I can easily revert the commit once we've decided. As written above, I 
> could imagine that we move the class in a follow-up.

In addition to it being more intrusive it will break our closed tests and make 
backporting system tests more difficult (a clean backport of a new test that 
adds an OS check will fail to compile).

When I suggested looking at moving the graphics-related properties to 
`javafx.graphics` I was envisioning that the platform checks would stay where 
they are. So +1 for reverting it.

What I'd like to end up with is:

javafx.base: PlatformUtil - OS check that are not related to graphics (no Glass 
or Prism related calls or properties)
javafx.graphics: (need a good name here) - Glass / Prism related platform checks

I'm OK with the idea of moving the parts that make sense in a follow-up if you 
prefer.

-------------

PR Comment: https://git.openjdk.org/jfx/pull/2299#issuecomment-5647858264

Reply via email to