In message <> 
on Wed, 5 Dec 2018 19:27:32 +0100, Tim Hudson <> said:

> The function has been there for a long time (since then beginning) and it is 
> all about version
> related information - so both names aren't exactly clearly descriptive.
> OpenSSL_version_information() would be a better name.

Considering most of the information is build data, I have a hard time
understanding how it's related to the version per se, except in a
fairly abstract manner (like Matt said, "the info related to this
version")...  Ah well.

> It would also argue that the "version" program should be renamed
> "info" as the same argument would equally apply.

Yeah, except its default response is to give the version string.

> However I do not think we should rename a function and deprecate a
> function that is very widely used.

... ok
> And the function should also cover everything that the current
> "version" application covers (like seeding source etc). The ifdefs
> there are not something we should expect applications to repeat.

THAT I agree on...  but that should probably be in a different PR,
this one is already plenty as it is.

> Tim.
> On Wed, 5 Dec. 2018, 5:50 pm Matt Caswell < wrote:
>  Richard and I are discussing whether OpenSSL_version() should be deprecated 
> or
>  not in favour of a new function OPENSSL_info() which does more or less the 
> same
>  thing. See:
>  Richard's motivation for doing so is that he finds the old name "strongly
>  misleading". I disagree and prefer not to deprecate functions like this just
>  because we don't like the name (which eventually will lead to breakage when 
> we
>  remove the deprecated functions in some future major version (not 3.0.0))
>  I'd appreciate more input on the discussion.
>  Matt
>  _______________________________________________
>  openssl-project mailing list
openssl-project mailing list

Reply via email to