Looking at PR#8287 I think we need to get some naming schemes written down and documented and followed consistently. The naming used in this PR seems to be somewhat inconsistent.
For me, I think the naming convention most often used is return_type SOMETHING_whatever(SOMETHING *,...) as a general rule for how we are naming things. There are lots of exceptions to this in the code base - but this is also pretty much consistent. And we use typedef names in all capitals for what we expect users to work with. We avoid the use of pure lowercase in naming functions or typedefs that are in the public API that we expect users to work with - all lowercase means this is "internal" only usage. And we reserve OSSL and OPENSSL as prefixes that we feel are safe to place all new names under. Tim.