I'm still struggling with this problem, but I have a little more
information. I learned from a close reading of `INSTALL.W32` and `.W64`
that support for 64-bit Windows is not stable, but support for 32-bit
Windows is okay, and that cross-compilation from Linux is possible. An
example given in `INSTALL.W32` seems to confirm that my environment
variables are close to correct, except for the 32/64-bit differences.

I made another attempt, this time targetting 32-bit Windows. Everything
is the same as my first message, except the environment variables:

export SYSTEM="mingw"
export CROSS_COMPILE="i686-w64-mingw32-"
export HOSTCC="gcc"
export FIPS_SIG="${FIPS_HOME}/src/util/msincore"

The FOM build completes as expected, but I encountered [this
problem][0] having to do with multiple definitions. I applied the fix
that the OP describes there (i.e. renaming the offending symbols), and
the build continued. Unfortunately, it seems like nothing has changed,
because I still get the same error as before:

no fipstx section at ${FIPS_HOME}/src/util/msincore line 132.

If anyone has any information at all about this problem, I would
appreciate it if you sent it along.

Thank you,



Attachment: signature.asc
Description: This is a digitally signed message part

Reply via email to