We are thrilled to announce the release of:

python-tripleoclient 5.1.0: TripleO client

This release is part of the newton stable release series.

For more details, please see below.

Changes in python-tripleoclient 5.0.0..5.1.0
--------------------------------------------

bf4daea Migrate to using osc-lib
98d0c64 Add `overcloud parameters set` to set Heat params in a plan
60b5ac9 Remove the rest of a removed path
03ebdb2 Do not include epel element when building overcloud images
1d5137a Update .gitreview for stable/newton
dc6bfa3 Generate Keystone credentials for overcloud
d5cdbfb Use heatclient poll_for_events in wait_for_stack_ready
c282108 Re-enable keystone init deprecation message
a2c8c9d Add libffi-dev to bindep.txt
22c325a Replace agent elements with package python-heat-agent-puppet
98656b5 [squash] Required backports for stable/newton


Diffstat (except docs and test files)
-------------------------------------

.gitreview                                         |   1 +
bindep.txt                                         |   7 +
other-requirements.txt                             |   5 -
requirements.txt                                   |   6 +-
setup.cfg                                          |   2 +
test-requirements.txt                              |   1 +
tripleoclient/plugin.py                            |  30 +-
.../v1/overcloud_deploy/test_overcloud_deploy.py   | 502 ++++++++++++++++-----
.../test_overcloud_deploy_validators.py            |   2 +-
.../v1/overcloud_image/test_overcloud_image.py     |  24 +-
tripleoclient/utils.py                             |  61 +--
tripleoclient/v1/baremetal.py                      |   9 +-
tripleoclient/v1/overcloud_deploy.py               | 227 +++++++---
tripleoclient/v1/overcloud_execute.py              |   2 +-
tripleoclient/v1/overcloud_image.py                |  22 +-
tripleoclient/v1/overcloud_netenv_validate.py      |   4 +-
tripleoclient/v1/overcloud_node.py                 |   6 +-
tripleoclient/v1/overcloud_parameters.py           |  64 +++
tripleoclient/v1/overcloud_plan.py                 |  45 +-
tripleoclient/v1/overcloud_profiles.py             |   7 +-
tripleoclient/v1/overcloud_update.py               |   8 +-
tripleoclient/v1/overcloud_upgrade.py              |   6 +-
tripleoclient/v1/undercloud.py                     |   2 +-
tripleoclient/workflows/base.py                    |  21 +
tripleoclient/workflows/deployment.py              |  30 ++
tripleoclient/workflows/parameters.py              |  23 +
tripleoclient/workflows/plan_management.py         | 123 +++++
40 files changed, 1248 insertions(+), 295 deletions(-)


Requirements updates
--------------------

diff --git a/requirements.txt b/requirements.txt
index 8923978..b51193f 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -7 +6,0 @@ Babel>=2.3.4 # BSD
-cliff!=1.16.0,!=1.17.0,>=1.15.0 # Apache-2.0
@@ -11 +10 @@ python-ironic-inspector-client>=1.5.0 # Apache-2.0
-python-heatclient>=1.1.0 # Apache-2.0
+python-heatclient>=1.4.0 # Apache-2.0
@@ -16,0 +16 @@ os-cloud-config # Apache-2.0
+osc-lib>=1.0.2  # Apache-2.0
@@ -19 +19 @@ websocket-client>=0.32.0 # LGPLv2+
-# tripleo-common lib is not yet on PyPi
+# tripleoclient is tied to tripleo-common and expects to use the latest code.
diff --git a/test-requirements.txt b/test-requirements.txt
index 984b41e..3433fea 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -12,0 +13 @@ testtools>=1.4.0 # MIT
+requests-mock>=1.0 # Apache-2.0



_______________________________________________
OpenStack-announce mailing list
OpenStack-announce@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-announce

Reply via email to