Thanks. Maybe this would be a good opportunity to just have people start
putting everything in neutron.conf if they want to switch to wsgi.

On Mon, Jun 19, 2017 at 12:21 AM, Matthew Treinish <mtrein...@kortar.org>
wrote:

> On Mon, Jun 19, 2017 at 12:09:12AM -0700, Kevin Benton wrote:
> > I've been working on Victor's patch a bit. One thing that isn't clear to
> me
> > is how we can get the neutron.conf options loaded when using WSGI. How
> are
> > other projects doing this?
>
> Most projects are using a default location, for example:
>
> https://review.openstack.org/#/c/459450/11/glance/common/wsgi_app.py
>
> Which IIRC I just looked at how other project's wsgi entrypoints were
> doing it
> when I wrote that. The issue I think we'll hit with Neutron is that by
> default
> we tell everyone to do that annoying multi-file config setup, which makes
> doing
> a default like this difficult. Personally I think we need to change that,
> because it's not needed and makes it generally confusing, but even if we
> did
> it wouldn't solve the upgrade path from non-wsgi to wsgi.
>
> -Matt Treinish
>
> >
> > On Fri, Jun 2, 2017 at 7:44 AM, Emilien Macchi <emil...@redhat.com>
> wrote:
> >
> > > On Thu, Jun 1, 2017 at 10:28 PM, Morales, Victor
> > > <victor.mora...@intel.com> wrote:
> > > > Hi Emilien,
> > > >
> > > > I noticed that the configuration file was created using puppet.  I
> > > submitted a patch[1] that was targeting to include the changes in
> Devstack.
> > > My major concern is with the value of WSGIScriptAlias which should be
> > > pointing to WSGI script.
> > >
> > > Thanks for looking, the script that is used is from
> > > /usr/bin/neutron-api which is I think correct. If you look at logs,
> > > you can see that API actually works but some tempest tests fail
> > > though...
> > >
> > > > Regards/Saludos
> > > > Victor Morales
> > > >
> > > > [1] https://review.openstack.org/#/c/439191
> > > >
> > > > On 5/31/17, 4:40 AM, "Emilien Macchi" <emil...@redhat.com> wrote:
> > > >
> > > >     Hey folks,
> > > >
> > > >     I've been playing with deploying Neutron in WSGI with Apache and
> > > >     Tempest tests fail on spawning Nova server when creating Neutron
> > > >     ports:
> > > >     http://logs.openstack.org/89/459489/4/check/gate-puppet-
> > > openstack-integration-4-scenario001-tempest-centos-7/
> > > f2ee8bf/console.html#_2017-05-30_13_09_22_715400
> > > >
> > > >     I haven't found anything useful in neutron-server logs:
> > > >     http://logs.openstack.org/89/459489/4/check/gate-puppet-
> > > openstack-integration-4-scenario001-tempest-centos-7/
> > > f2ee8bf/logs/apache/neutron_wsgi_access_ssl.txt.gz
> > > >
> > > >     Before I file a bug in neutron, can anyone look at the logs with
> me
> > > >     and see if I missed something in the config:
> > > >     http://logs.openstack.org/89/459489/4/check/gate-puppet-
> > > openstack-integration-4-scenario001-tempest-centos-7/
> > > f2ee8bf/logs/apache_config/10-neutron_wsgi.conf.txt.gz
> > > >
> > > >     Thanks for the help,
> > > >     --
> > > >     Emilien Macchi
> > > >
> > > >     ____________________________________________________________
> > > ______________
> > > >     OpenStack Development Mailing List (not for usage questions)
> > > >     Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:
> > > unsubscribe
> > > >     http://lists.openstack.org/cgi-bin/mailman/listinfo/
> openstack-dev
> > > >
> > > >
> > > > ____________________________________________________________
> > > ______________
> > > > OpenStack Development Mailing List (not for usage questions)
> > > > Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:
> > > unsubscribe
> > > > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> > >
> > >
> > >
> > > --
> > > Emilien Macchi
> > >
> > > ____________________________________________________________
> ______________
> > > OpenStack Development Mailing List (not for usage questions)
> > > Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:
> unsubscribe
> > > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
> > >
>
> > ____________________________________________________________
> ______________
> > OpenStack Development Mailing List (not for usage questions)
> > Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:
> unsubscribe
> > http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
>
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
>
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to