As far as I can tell, bumping min version to 1.7.0 would not be a problem
for Congress.

Eric Kao

On 8/3/17, 4:39 AM, "witold.be...@est.fujitsu.com"
<witold.be...@est.fujitsu.com> wrote:

>Hello everyone,
>
>I would like to ask for the FFE for python-monascaclient version in
>global requirements.
>
>The current version in Pike (1.7.0) is not fully backward compatible. The
>monasca exception classes were replaced with keystoneauth exceptions,
>which affects heat and watcher projects if they use current upper
>constraints. The fixes for these projects have been submitted [1, 2].
>
>Also, monasca projects (monasca-agent, monasca-ui, monasca-api) rely on
>python-monascaclient 1.7.0 and don't work with older versions.
>
>The change for bumping the minimum version of python-monascaclient is
>here:
>
>https://review.openstack.org/489173
>
>
>Best greetings
>Witek Bedyk
>
>
>[1] https://review.openstack.org/490016
>[2] https://review.openstack.org/490018
>
>__________________________________________________________________________
>OpenStack Development Mailing List (not for usage questions)
>Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to