On 2018-03-07 00:08:39 +0200 (+0200), Ivan Kolodyazhny wrote:
> - we agreed to make go forward with Eventlet by default and make it
>    configurable to allow native Python threads which are used now
>    - let's ask the community about their experience with Eventlet
>    - Eventlet is not the best option for Python 3 at the moment

There was a discussion[*] during TC office hours three weeks ago
wherein we rehashed a general desire to see eventlet usage decline
within OpenStack services (we recognize that the volunteer workforce
needed to rearchitect existing eventlet-using services simply
doesn't exist, though it was suggested in jest as a potential
community goal). At a minimum, there seemed to be some consensus
that we should strongly discourage new uses of eventlet because its
stdlib monkey-patching has created all manner of incompatibilities
with other libraries in the past. Most recently it seems to be
hampering etcd adoption, which we had as a community previously
agreed on using to provide a consistent DLM implementation across


Jeremy Stanley

Attachment: signature.asc
Description: PGP signature

OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe

Reply via email to