On 04/19/2018 08:33 AM, Jay Pipes wrote:
On 04/19/2018 09:15 AM, Matthew Booth wrote:
We've had inconsistent naming of recreate/evacuate in Nova for a long
time, and it will persist in a couple of places for a while more.
However, I've proposed the following to rename 'recreate' to
'evacuate' everywhere with no rpc/api impact here:
One of the things which is renamed is the driver 'supports_recreate'
capability, which I've renamed to 'supports_evacuate'. The above
change updates this for in-tree drivers, but as noted in review this
would impact out-of-tree drivers. If this might affect you, please
follow the above in case it merges.
I have to admit, Matt, I'm a bit confused by this. I was under the impression
that we were trying to *remove* uses of the term "evacuate" as much as possible
because that term is not adequately descriptive of the operation and terms like
"recreate" were more descriptive?
This is a good point.
Personally I'd prefer to see it go the other way and convert everything to the
"recreate" terminology, including the external API.
From the CLI perspective, it makes no sense that "nova evacuate" operates after
a host is already down, but "nova evacuate-live" operates on a running host.
OpenStack Development Mailing List (not for usage questions)