Hi Goutham!

There are 2 issues which can result in such error:

1) You did not read change log for Rally (see
https://github.com/openstack/rally/blob/master/CHANGELOG.rst, all versions
are included there). We do not provide in-tree OpenStack plugins started
from Rally 1.0.0 .You need to install rally-openstack package (
https://pypi.python.org/pypi/rally-openstack) . It has Rally as a
dependency, so if you are preparing the environment from the scratch ->
just install rally-openstack package.

2) There are one or many conflicts in package requirements. Run `rally
plugin show Dummy.openstack` and see the logging messages. It should point
out the errors of loading plugins if there is something.

чт, 9 авг. 2018 г. в 10:32, Goutham Pratapa <pratapagout...@gmail.com>:

> Hi Rally Team,
>
> I have been trying to setup rally version v1.1.0
>
> I could successfully install rally but when i try to create the deployment
> i am getting this error
>
>
>
> *ubuntu@ubuntu:~$  rally deployment create --file=existing.json
> --name=existing*
>
> *Env manager got invalid spec:*
>
>
> * ["There is no Platform plugin with name: 'existing@openstack'"]*
>
>
> *ubuntu@ubuntu:~$ rally version *
>
> *1.1.0*
>
> can any one help me  the issue and the fix ?
>
> Thanks in advance.
>
> --
> Cheers !!!
> Goutham Pratapa
> __________________________________________________________________________
> OpenStack Development Mailing List (not for usage questions)
> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>


-- 
Best regards,
Andrey Kurilin.
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to