On 7/30/2014 9:20 AM, Matt Riedemann wrote:

On 7/30/2014 6:43 AM, Daniel P. Berrange wrote:
On Wed, Jul 30, 2014 at 06:39:56AM -0700, Matt Riedemann wrote:
This change:


Tries to pull in libvirt-python >= 1.2.5 for testing.

I'm on Ubuntu Precise for development which has libvirt 0.9.8.

The latest libvirt-python appears to require libvirt >= 0.9.11.

So do I have to move to Trusty?

You can use the CloudArchive repository to get newer libvirt and
qemu packages for Precise, which is what anyone deploying the
Ubuntu provided OpenStack packages would be doing.


Can we be more specific because this would also need to be updated in
the devref docs for setting up your development environment with Ubuntu.

Sorry for being a newb but I went here:


And tried doing:

sudo add-apt-repository cloud-archive:icehouse

Which failed, I guess it doesn't know about what that means or something?

I added a repo to
manually but it's not finding any newer libvirt packages.

If I can get some help I can push a patch to update the docs since I'm
assuming I won't be the only one that hits this and it sounds like
minesweeper hit it recently too. [1]


Yay for docs team, I was missing this:

apt-get install python-software-properties

Found it here:


The devref env setup doc in nova should still probably be updated to say something like, 'hey if you're on juno using precise you need to enable cloud archive to update libvirt'.



Matt Riedemann

OpenStack-dev mailing list

Reply via email to