Alexei,

Thanks, that is what I was missing.

I hit one more error in case anyone is interested.  lxml couldn't
install because the compiler couldn't find libxml/xmlversion.h.  For
lack of interest on my part to figure out why this happened, I did the
following which allowed me to get past the problem.  (Ubuntu 12.04.1
LTS)

$ cd /usr/include && sudo ln -s libxml2/libxml

I seem to be back in operation now.  Thanks.

Carl

On Tue, Aug 5, 2014 at 2:08 PM, Alexei Kornienko
<alexei.kornie...@gmail.com> wrote:
> Hello Carl,
>
> You should try to update your virtualenv (pip install -U virtualenv).
> It fixed this problem for me.
>
> Regards,
> Alexei
>
>
> On 05/08/14 23:00, Carl Baldwin wrote:
>>
>> Hi,
>>
>> I noticed this yesterday afternoon.  I tried to run pep8 and unit
>> tests on a patch I was going to submit.  It failed with an error that
>> no package satisfying oslo.config could be found [1].  I went to pypi
>> and saw that the version appears to be available [2] but still
>> couldn't install it.
>>
>> I tried to activate the .tox/pep8 virtual environment and install the
>> version explicitly.  Interestingly, that worked in one gerrit repo for
>> Neutron [3] but not the other [4].  These two virtual envs are on the
>> same machine.  I ran "git clean -fdx" to start over and now neither
>> virtualenv can install it.
>>
>> Anyone have any idea what is going on?  It seems to be related to the
>> fact that oslo.config is now uploaded as .whl files, whatever those
>> are.  Why is it that my system cannot handle these?  I noticed that
>> oslo.config is now available only as .whl in the 1.4.0.0aN versions
>> but used to be available as .tar.gz files.
>>
>> Carl
>>
>> [1] http://paste.openstack.org/show/90651/
>> [2] https://pypi.python.org/pypi/oslo.config
>> [3] http://paste.openstack.org/show/90674/
>> [4] http://paste.openstack.org/show/90675/
>>
>> _______________________________________________
>> OpenStack-dev mailing list
>> OpenStack-dev@lists.openstack.org
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>
>
>
> _______________________________________________
> OpenStack-dev mailing list
> OpenStack-dev@lists.openstack.org
> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

_______________________________________________
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to