On 12/15/2014 12:01 PM, Jeremy Stanley wrote:
> On 2014-12-15 11:53:07 -0500 (-0500), Doug Hellmann wrote:
> [...]
>> This release is primarily meant to update the SQLAlchemy dependency
>> to resolve the issue with the new version of setuptools changing
>> how it evaluates version range specifications.
> [...]
> 
> However note that I'm in the middle of forcing a refresh on a couple
> of our PyPI mirror servers, so it may be a couple hours before we
> see the effects of this throughout all of our infrastructure.
> 

It looks like this change has broken the grenade jobs because now
oslo.db 1.3.0 ends up being installed in stable/juno environments, which
has incompatible requirements with the rest of stable juno.

http://logs.openstack.org/07/137307/1/gate//gate-grenade-dsvm/048ee63//logs/old/screen-s-proxy.txt.gz

pkg_resources.VersionConflict: SQLAlchemy 0.8.4 is installed but
SQLAlchemy>=0.9.7,<=0.9.99 is required by ['oslo.db']

        -Sean

-- 
Sean Dague
http://dague.net

_______________________________________________
OpenStack-dev mailing list
OpenStack-dev@lists.openstack.org
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to