On 1/13/2015 2:51 PM, Matt Riedemann wrote:


On 1/12/2015 7:53 PM, Matt Riedemann wrote:
0.9.2 was blocked because of a change that broke unit tests in some
projects, that is fixed in 0.9.4.

What happened to 0.9.3? Problems, don't ask - fixed in 0.9.4 (thanks
mordred).

Changes:

mriedem@ubuntu:~/git/sqlalchemy-migrate$ git log --no-merges --oneline
0.9.2..0.9.4
b011e6c Remove svn version tag setting
938757e Ignore transaction management statements in SQL scripts
74553f4 Use native sqlalchemy 0.9 quote attribute with ibmdb2
244c6c5 Don't add warnings filter on import
30f6aea pep8: mark all pep8 checks that currently fail as ignored
7bb74f7 Fix ibmdb2 unique constraint handling for sqlalchemy 0.9

Of special note is 244c6c5 which should remove a ton of the
DeprecationWarnings that show up in unit test runs for other projects,
like Nova.

Also thanks to clarkb for helping me do my first release, you were so
gentle. :)


Looks like the new release is causing problems with glance:

https://bugs.launchpad.net/glance/+bug/1410494


The plan right now is to fix glance on master [1] and then pin sqlalchemy-migrate < 0.9.2 on the stable branches.

[1] https://review.openstack.org/#/c/121033/

--

Thanks,

Matt Riedemann


__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to