No, it's too new. Devstack in master is fixed to address those issues.

Supporting instructions that include out of tree patches in the
instructions are beyond what should be expected of from the development
list. The Intel folks that built these instructions and patches are the
ones you should be asking for support.

        -Sean

On 02/05/2015 05:26 PM, Roman Mashak wrote:
> Thanks for response.
> I have pip 6.0.8, is it too old? What version should I install to move
> on with installation?
> 
> 2015-02-05 16:44 GMT-05:00 Sean Dague <s...@dague.net>:
>> On 02/05/2015 04:05 PM, Roman Mashak wrote:
>>> Hello,
>>>
>>> OS - Fedora 20.
>>>
>>> I'm in the process of integrating DPDK-accelerated Open vSwitch with
>>> OpenStack, according to the following document
>>> https://01.org/sites/default/files/page/accelerating_openstack_networking_with_intel_architecture_rev008.pdf
>>>
>>> % git clone https://github.com/openstack-dev/devstack.git
>>> % cd devstack
>>> % git checkout 7eac0c927ca95fe3f6457b52d701a010a7e65123
>>> % git clone https://github.com/openstack/nova.git
>>> % cd nova
>>> % git checkout b7738bfb6c2f271d047e8f20c0b74ef647367111
>>>
>>> Then both nova and devstack must be patched with patches to support DPDK.
>>
>> Any set of instructions that require specific git SHA then patch them of
>> both devstack and nova are fragile beyond all repair. Perhaps someone
>> from Intel can explain why that's the prefered install method.
>>
>> The issue you are hitting is due to pip upgrades that happened over
>> Christmas, you have to be on the latest code to get past them (there
>> were a number of fixes that had to be pulled together), which means the
>> Intel instructions are incompatible with a working installation at this
>> time.
>>
>>>
>>> However I'm getting the following error when running stack.sh:
>>>
>>> 2015-02-05 20:06:21.284 | Collecting
>>> SQLAlchemy<=0.8.99,<=0.9.99,>=0.8.4,>=0.9.7 (from
>>> nova===2014.2.1.dev1.gb7738bf)
>>> 2015-02-05 20:06:21.767 |   Could not find a version that satisfies
>>> the requirement SQLAlchemy<=0.8.99,<=0.9.99,>=0.8.4,>=0.9.7 (from
>>> nova===2014.2.1.dev1.gb7738bf) (from versions: 0.4.2p3, 0.4.7p1,
>>> 0.5.4p1, 0.5.4p2, 0.1.0, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 0.1.6,
>>> 0.1.7, 0.2.0, 0.2.1, 0.2.2, 0.2.3, 0.2.4, 0.2.5, 0.2.6, 0.2.7, 0.2.8,
>>> 0.3.0, 0.3.1, 0.3.2, 0.3.3, 0.3.4, 0.3.5, 0.3.6, 0.3.7, 0.3.8, 0.3.9,
>>> 0.3.10, 0.3.11, 0.4.0b1, 0.4.0b2, 0.4.0b3, 0.4.0b4, 0.4.0b5, 0.4.0b6,
>>> 0.4.0, 0.4.1, 0.4.2a0, 0.4.2b0, 0.4.2, 0.4.3, 0.4.4, 0.4.5, 0.4.6,
>>> 0.4.7, 0.4.8, 0.5.0b1, 0.5.0b2, 0.5.0b3, 0.5.0rc1, 0.5.0rc2, 0.5.0rc3,
>>> 0.5.0rc4, 0.5.0, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.5.5, 0.5.6, 0.5.7,
>>> 0.5.8, 0.6b1, 0.6b2, 0.6b3, 0.6.0, 0.6.1, 0.6.2, 0.6.3, 0.6.4, 0.6.5,
>>> 0.6.6, 0.6.7, 0.6.8, 0.6.9, 0.7.0, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5,
>>> 0.7.6, 0.7.7, 0.7.8, 0.7.9, 0.7.10, 0.8.0b2, 0.8.0, 0.8.1, 0.8.2,
>>> 0.8.3, 0.8.4, 0.8.5, 0.8.6, 0.8.7, 0.9.0, 0.9.1, 0.9.2, 0.9.3, 0.9.4,
>>> 0.9.5, 0.9.6, 0.9.7, 0.9.8)
>>> 2015-02-05 20:06:21.770 |   No distributions matching the version for
>>> SQLAlchemy<=0.8.99,<=0.9.99,>=0.8.4,>=0.9.7 (from
>>> nova===2014.2.1.dev1.gb7738bf)
>>>
>>> I tried manually remove sqlalchemy with 'pip uninstall', as well as
>>> remove SQLAlchemy RPM package that might conflict. This didn't help
>>> though.
>>>
>>> This is string from /opt/stack/requirements/global-requirements.txt:
>>>
>>> SQLAlchemy>=0.8.4,<=0.9.99,!=0.9.0,!=0.9.1,!=0.9.2,!=0.9.3,!=0.9.4,!=0.9.5,!=0.9.6
>>>
>>> I also completely removed /opt/stack/requirements/, then unstack.sh
>>> and stack.sh again -- didn't help either.
>>>
>>> What else I'm missing?
>>> Thanks.
>>>
>>
>>
>> --
>> Sean Dague
>> http://dague.net
>>
>>
>> __________________________________________________________________________
>> OpenStack Development Mailing List (not for usage questions)
>> Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
>> http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev
>>
> 
> 
> 


-- 
Sean Dague
http://dague.net

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to