On Sat, Feb 7, 2015 at 5:09 AM, masoom alam <masoom.a...@wanclouds.net>
wrote:

> raise DistributionNotFound(req)\npkg_resources.DistributionNotFound:
> alembic<0.6.4,>=0.4.1\n'
>

It looks like your system is failing to find a version of alembic that
satisfies those requirements.

In your last post on this issue you said you had alembic 0.7.4 installed
already. That doesn't satisfy the requirement for a version <0.6.4. Perhaps
you need to uninstall that version, or downgrade to something that meets
the requirements?

Alternatively - it seems as though you may have a very old version of
neutron-rootwrap. I don't know much about Neutron so maybe I'm reading this
wrong, but "require(\'neutron==2013.2.4.dev32\')" suggests old age to me.
Perhaps it would be possible to upgrade your version?

FWIW, I tested in a virtualenv; with just alembic==0.7.4 installed, "pip
install -r requirements.txt" on a file that contained "alembic<0.6.4,>=0.4.1"
was able to downgrade my environment from 0.7.4 to 0.6.3. It seems possible
that maybe you could be talking to a PyPi proxy that is missing the older
alembic packages, and that adding those packages to the proxy so they can
be downloaded might possibly resolve your issue
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to