Hi Steve, Xiexs,

Actually this issue hit us on Tuesday afternoon.
Root cause is not known still, but the workaround was an update to nodepool to 
allow the project-name setting as stated below.
I updated the sample nodepool.yaml.erb as well. See this post I sent for the 
full details of the issue [1]

It would still be nice to know what the root cause is.

Thanks,
Ramy
[1] http://lists.openstack.org/pipermail/openstack-dev/2015-August/072556.html

P.S. Xiexs, in the future, it’s helpful to include the [third-party] and/or 
[infra] tags as well to get better attention since this issue impacts nodepool 
users, which is used by both of these teams.

From: Xie, Xianshan [mailto:xi...@cn.fujitsu.com]
Sent: Thursday, August 20, 2015 11:30 PM
To: OpenStack Development Mailing List (not for usage questions) 
<openstack-dev@lists.openstack.org>
Subject: Re: [openstack-dev] [keystone] Can`t find Project ID

Hi Steve,
   Thanks for your reply.

It`s a stupid mistake.
I have made an invalid configuration for the provider`s project-id in the 
nodepool.yaml as follows:
{ project-id: 'admin' }
But the correct setting should be:
{ Project-name: 'admin'}  or { project-id: '<%= id of project admin %>' }

To be honest, I was misled by the  sample file 
os-ext-testing-data/etc/nodepool/nodepool.yaml.erb,
in which the project-id is also configured with admin.


Xiexs

From: Steve Martinelli [mailto:steve...@ca.ibm.com]
Sent: Friday, August 21, 2015 1:48 PM
To: OpenStack Development Mailing List (not for usage questions)
Subject: Re: [openstack-dev] [keystone] Can`t find Project ID


For the rest of the mailing list, how was it resolved? :)

Thanks,

Steve Martinelli
OpenStack Keystone Core

[Inactive hide details for "Xie, Xianshan" ---2015/08/21 01:43:35 AM---Hi all,  
  This issue has already been resolved.]"Xie, Xianshan" ---2015/08/21 01:43:35 
AM---Hi all, This issue has already been resolved.

From: "Xie, Xianshan" <xi...@cn.fujitsu.com<mailto:xi...@cn.fujitsu.com>>
To: "OpenStack Development Mailing List (not for usage questions)" 
<openstack-dev@lists.openstack.org<mailto:openstack-dev@lists.openstack.org>>
Date: 2015/08/21 01:43 AM
Subject: Re: [openstack-dev] [keystone] Can`t find Project ID

________________________________



Hi all,
This issue has already been resolved.
Thanks.


Xiexs

From: Xie, Xianshan [mailto:xi...@cn.fujitsu.com]
Sent: Friday, August 21, 2015 9:51 AM
To: OpenStack Development Mailing List (not for usage questions)
Subject: [openstack-dev] [keystone] Can`t find Project ID

Hi, all,

I got following error message while running nodepoold:

--------
2015-08-21 20:18:00,336 ERROR nodepool.NodePool: Exception cleaning up leaked 
nodes
Traceback (most recent call last):
File "/home/nodepool/nodepool/nodepool.py", line 2399, in periodicCleanup
self.cleanupLeakedInstances()
File "/home/nodepool/nodepool/nodepool.py", line 2410, in cleanupLeakedInstances
servers = manager.listServers()
File "/home/nodepool/nodepool/provider_manager.py", line 570, in listServers
self._servers = self.submitTask(ListServersTask())
File "/home/nodepool/nodepool/task_manager.py", line 119, in submitTask
return task.wait()
File "/home/nodepool/nodepool/task_manager.py", line 57, in run
self.done(self.main(client))
File "/home/nodepool/nodepool/provider_manager.py", line 136, in main
servers = client.nova_client.servers.list()
File "/usr/local/lib/python2.7/dist-packages/shade/__init__.py", line 318, in 
nova_client
self.get_session_endpoint('compute')
File "/usr/local/lib/python2.7/dist-packages/shade/__init__.py", line 811, in 
get_session_endpoint
"Error getting %s endpoint: %s" % (service_key, str(e)))
OpenStackCloudException: Error getting compute endpoint: Project ID not found: 
admin (Disable debug mode to suppress these details.) (HTTP 401) (Request-ID: 
req-fb986bff-3cad-48e1-9da9-915ac9ef5927)
-------

And in my case, the output info with cli listed as follows:
$ openstack service list
| ID | Name | Type |
+----------------------------------+----------+------------+
| 213a7ba8f0564523a3d2769f77621fde | nova | compute |

$ openstack project list
+----------------------------------+--------------------+
| ID | Name |
+----------------------------------+--------------------+
| 0a765fdfa79a438aae56202bdd5824e2 | admin |

$ keystone endpoint-list
+----------------------------------+-----------+-----------------------------------------+-----------------------------------------+-----------------------------------------+----------------------------------+
| id | region | publicurl | internalurl | adminurl | service_id |
+----------------------------------+-----------+-----------------------------------------+-----------------------------------------+-----------------------------------------+----------------------------------+
| d89b009e81f04a17a26fd07ffbf83efb | regionOne | 
http://controller:8774/v2/%(tenant_id)s<http://controller:8774/v2/%25(tenant_id)s>
 | 
http://controller:8774/v2/%(tenant_id)s<http://controller:8774/v2/%25(tenant_id)s>
 | 
http://controller:8774/v2/%(tenant_id)s<http://controller:8774/v2/%25(tenant_id)s>
 | 213a7ba8f0564523a3d2769f77621fde |
+----------------------------------+-----------+-----------------------------------------+-----------------------------------------+-----------------------------------------+----------------------------------+


Have you ever seen this error? And could you give me any advice to solve it?
Thanks in advance.


Xiexs__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: 
openstack-dev-requ...@lists.openstack.org?subject:unsubscribe<mailto:openstack-dev-requ...@lists.openstack.org?subject:unsubscribe>
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to