Hi Abhi,

First, using DIB is generally easier. However to use the scripts, you configure 
nodepool to do so.

You should already have the scripts directory set [1]
Then you configure the script as the starting point for the image-build via 
setup: prepare_node.sh [2]
Be sure to correctly configure the credentials, ssh keys, etc. as well.

You can use nodepool image-update command to manually invoke it image builds 
using this option.

Ramy

[1] http://docs.openstack.org/infra/nodepool/configuration.html#script-dir
[2] http://docs.openstack.org/infra/nodepool/configuration.html#images




From: Abhishek Shrivastava [mailto:abhis...@cloudbyte.com]
Sent: Tuesday, August 25, 2015 7:51 AM
To: OpenStack Development Mailing List (not for usage questions)
Subject: Re: [openstack-dev] [third-party] Timeout waiting for ssh access

Hi Ramy,

Can you mention the steps for glance & scripts?

On Tue, Aug 25, 2015 at 7:49 PM, Asselin, Ramy 
<ramy.asse...@hp.com<mailto:ramy.asse...@hp.com>> wrote:
Hi Tang,

I haven’t seen this issue. Which approach are you using to build the image? DIB 
or via glance & scripts?
Do you get the same result when using both approaches?
If using DIB, what is the OS used to build the image?

Ramy

From: Tang Chen [mailto:tangc...@cn.fujitsu.com<mailto:tangc...@cn.fujitsu.com>]
Sent: Tuesday, August 25, 2015 5:02 AM
To: openstack-dev@lists.openstack.org<mailto:openstack-dev@lists.openstack.org>
Subject: Re: [openstack-dev] [third-party] Timeout waiting for ssh access

Hi all,

Does anybody have any idea about this problem ?

Since ubuntu does not have /etc/sysconfig/network-scripts/ifcfg-*,
obviously it is a fedora like fs structure, we have tried to use centos,
but we still got the same error.

Thanks.
On 08/24/2015 09:19 PM, Xie, Xianshan wrote:
Hi, All
  I`m still strugling to setup nodepool env, and i got following error messages:
------------------------------------------
ERROR nodepool.NodeLauncher: Exception launching node id: 13 in provider: 
local_01 error:
      Traceback (most recent call last):
        File "/home/fujitsu/xiexs/nodepool/nodepool/nodepool.py", line 405, in 
_run
          dt = self.launchNode(session)
        File "/home/fujitsu/xiexs/nodepool/nodepool/nodepool.py", line 503, in 
launchNode
          timeout=self.timeout):
        File "/home/fujitsu/xiexs/nodepool/nodepool/nodeutils.py", line 50, in 
ssh_connect
          for count in iterate_timeout(timeout, "ssh access"):
        File "/home/fujitsu/xiexs/nodepool/nodepool/nodeutils.py", line 42, in 
iterate_timeout
          raise Exception("Timeout waiting for %s" % purpose)
      Exception: Timeout waiting for ssh access
     WARNING nodepool.NodePool: Deleting leaked instance d-p-c-local_01-12 
(aa6f58d9-f691-4a72-98db-6add9d0edc1f) in local_01 for node id: 12
------------------------------------------

And meanwhile, in the console.log which records the info for launching this 
instance,
there is also an error as follows:
------------------------------------------
+ sed -i -e s/^\(DNS[0-9]*=[.0-9]\+\)/#\1/g 
/etc/sysconfig/network-scripts/ifcfg-*^M
sed: can't read /etc/sysconfig/network-scripts/ifcfg-*: No such file or 
directory^M
...
cloud-init-nonet[26.16]: waiting 120 seconds for network device
------------------------------------------

I have tried to figure out what`s causing this error:
1. mounted image.qcow2 and then checked the configuration for the network about 
this instance:
$ cat etc/network/interfaces.d/eth0.cfg
   auto eth0
   iface eth0 inet dhcp

$ cat etc/network/interfaces
   auto lo
   iface lo inet loopback
   source /etc/network/interfaces.d/*.cfg

It seems good.

2. But indeed, the directory named /etc/sysconfig/network-scripts/ifcfg-* does 
not exist.
And i dont understand why it attempts to check this configuration file?
Because my instance is specified to ubuntu not rhel.

So,could you give me some tips to work this out?
Thanks in advance.

Xiexs



__________________________________________________________________________

OpenStack Development Mailing List (not for usage questions)

Unsubscribe: 
openstack-dev-requ...@lists.openstack.org?subject:unsubscribe<mailto:openstack-dev-requ...@lists.openstack.org?subject:unsubscribe>

http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev


__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: 
openstack-dev-requ...@lists.openstack.org?subject:unsubscribe<http://openstack-dev-requ...@lists.openstack.org?subject:unsubscribe>
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev



--
[https://docs.google.com/uc?export=download&id=0Byq0j7ZjFlFKV3ZCWnlMRXBCcU0&revid=0Byq0j7ZjFlFKa2V5VjdBSjIwUGx6bUROS2IrenNwc0kzd2IwPQ]
Thanks & Regards,
Abhishek
Cloudbyte Inc.<http://www.cloudbyte.com>
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to