We are frolicsome to announce the release of:

oslo.privsep 1.14.0: OpenStack library for privilege separation

This release is part of the ocata release series.

The source is available from:

    http://git.openstack.org/cgit/openstack/oslo.privsep

Download the package from:

    https://pypi.python.org/pypi/oslo.privsep

Please report issues through launchpad:

    http://bugs.launchpad.net/oslo.privsep

For more details, please see below.

Changes in oslo.privsep 1.13.0..1.14.0
--------------------------------------

9dab411 Enable release notes translation
b5b56db Updated from global requirements
e891746 Updated from global requirements
42e81fd modify the home-page info with the developer documentation
3b53619 Ignore timeout error when receiving message from sockect
af91d7a Update reno for stable/newton
1666d91 Deal with CONF.config_dir correctly
f22a6a1 Report underlying integer for unknown capabilities
21c3007 Add Python 3.5 classifier and venv


Diffstat (except docs and test files)
-------------------------------------

oslo_privsep/comm.py                    | 11 +++++++----
oslo_privsep/daemon.py                  |  2 +-
oslo_privsep/priv_context.py            |  3 ++-
releasenotes/source/conf.py             |  3 +++
releasenotes/source/index.rst           |  5 +++--
releasenotes/source/newton.rst          |  6 ++++++
requirements.txt                        |  2 +-
setup.cfg                               |  3 ++-
test-requirements.txt                   |  4 ++--
tox.ini                                 |  2 +-
11 files changed, 29 insertions(+), 14 deletions(-)


Requirements updates
--------------------

diff --git a/requirements.txt b/requirements.txt
index eb977e3..bb53246 100644
--- a/requirements.txt
+++ b/requirements.txt
@@ -5 +5 @@
-oslo.log>=1.14.0 # Apache-2.0
+oslo.log>=3.11.0 # Apache-2.0
diff --git a/test-requirements.txt b/test-requirements.txt
index c79d4ef..4bf99a5 100644
--- a/test-requirements.txt
+++ b/test-requirements.txt
@@ -11,2 +11,2 @@ fixtures>=3.0.0 # Apache-2.0/BSD
-oslosphinx!=3.4.0,>=2.5.0 # Apache-2.0
-sphinx!=1.3b1,<1.3,>=1.2.1 # BSD
+oslosphinx>=4.7.0 # Apache-2.0
+sphinx!=1.3b1,<1.4,>=1.2.1 # BSD



__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to