Hi folks!

Today devstack team decided to switch to keystone v3 by default[0].
Imo, it is important thing, but it was made in silent, so other project was
unable to prepare to that change. Also, proposed way to select Keystone API
version via devstack configuration doesn't work(IDENTITY_API_VERSION
variable doesn't work [1] ).

Switching to keystone v3 broke at least Rally and Magnum(based on comment
to [0])  gates. Also, python-novaclient has two separate jobs for checking
compatibility with keystone V2 and V3. One of these jobs became redundant.

That is why I submitted a revert [2] .

PS: Please, do not make such changes in silent!

[0] - https://review.openstack.org/#/c/386183
[1] -
https://github.com/openstack-infra/project-config/blob/master/jenkins/jobs/rally.yaml#L70-L74
[2] - https://review.openstack.org/405264

-- 
Best regards,
Andrey Kurilin.
__________________________________________________________________________
OpenStack Development Mailing List (not for usage questions)
Unsubscribe: openstack-dev-requ...@lists.openstack.org?subject:unsubscribe
http://lists.openstack.org/cgi-bin/mailman/listinfo/openstack-dev

Reply via email to