Hello community,

here is the log from the commit of package rubygem-ruby_dep for 
openSUSE:Factory checked in at 2016-10-18 10:40:29
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-ruby_dep (Old)
 and      /work/SRC/openSUSE:Factory/.rubygem-ruby_dep.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-ruby_dep"

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-ruby_dep/rubygem-ruby_dep.changes        
2016-08-25 09:55:24.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-ruby_dep.new/rubygem-ruby_dep.changes   
2016-10-18 10:40:28.000000000 +0200
@@ -1,0 +2,6 @@
+Mon Oct 10 04:36:17 UTC 2016 - co...@suse.com
+
+- updated to version 1.5.0
+  no changelog found
+
+-------------------------------------------------------------------

Old:
----
  ruby_dep-1.4.0.gem

New:
----
  ruby_dep-1.5.0.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-ruby_dep.spec ++++++
--- /var/tmp/diff_new_pack.4XK8kt/_old  2016-10-18 10:40:29.000000000 +0200
+++ /var/tmp/diff_new_pack.4XK8kt/_new  2016-10-18 10:40:29.000000000 +0200
@@ -24,7 +24,7 @@
 #
 
 Name:           rubygem-ruby_dep
-Version:        1.4.0
+Version:        1.5.0
 Release:        0
 %define mod_name ruby_dep
 %define mod_full_name %{mod_name}-%{version}

++++++ ruby_dep-1.4.0.gem -> ruby_dep-1.5.0.gem ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/README.md new/README.md
--- old/README.md       2016-08-03 03:11:54.000000000 +0200
+++ new/README.md       2016-10-10 00:00:35.000000000 +0200
@@ -2,6 +2,52 @@
 
 [![Gem 
Version](https://img.shields.io/gem/v/ruby_dep.svg?style=flat)](https://rubygems.org/gems/ruby_dep)
 [![Build 
Status](https://travis-ci.org/e2/ruby_dep.svg)](https://travis-ci.org/e2/ruby_dep)
 
+Avoid incompatible, slower, buggier and insecure Ruby versions.
+
+## IMPORTANT!! : HOW TO CORRECTLY SOLVE ISSUES
+
+If you're here because you're having issues, try the following:
+
+## 1. Upgrade Ruby.
+
+Ideally to the latest stable possible. It may be a little (or very!) 
inconvenient, but it helps everyone in the long run. 
+
+Show the awesome Ruby Core Team your support for their work by letting them 
focus on newer and better Rubies.
+
+## 2. Upgrade Ruby anyway.
+
+If you can't upgrade Ruby because of the environment, work out how to do so 
anyway.
+
+E.g. if you can't install Ruby 2.2.5 on OSX due to RVM issues (even though 
Ruby 2.2.5 has been released over 5 months ago), then obviously the RVM project 
may need help or support of some kind. Help the RVM maintainers out - they're 
awesome! Or, fork the project and heroically take things into your own hands.
+
+If Apple (or Amazon or whatever hosting service or company) doesn't provide 
the latest recommended, supported version of Ruby, use Homebrew (or build from 
sources) or complain to those companies to provide support. It's unfair for 
them to prevent users from getting better/faster Rubies.
+
+## 3. Upgrade Bundler (but even the most recent Bundler may not be enough!)
+
+Upgrade to a Bundler version that can automatically downgrade the gems for 
you. If that doesn't help, try this workaround: 
https://github.com/guard/listen/wiki/Ruby-version-requirements
+
+Work on this "downgrading" feature in Bundler is ongoing, so the best version 
of Bundler for the job may still be an unreleased version (beta, release 
candidate, etc.). 
+
+Help the Bundler team out if you can - they're awesome!
+
+## 4. If all else fails, learn SemVer and USE IT!
+
+Often, there are older versions of gems that support the Ruby version you 
need. See http://semver.org/ on how to set version constraints. Then, check out 
the release notes of the gems you need to know what you're getting (or missing 
out on).
+
+E.g. You can downgrade to RubyDep 1.3.1 (`gem 'ruby_dep', '~> 1.3.1'`) which 
allows using Ruby 2.2.4
+E.g. Or, You can use Listen 3.0.x (`gem 'listen', '~> 3.0.8'`) to avoid 
dealing with RubyDep and Listen.
+
+If those gem versions are lacking for any reason (e.g. bugs in Listen 3.0.x 
fixed in 3.1.x), then e.g. open a request for backporting changes to the 3.0.x 
branch.
+
+The idea: if you don't need the latest Ruby ... then you probably don't need 
the latest of every gem either.
+
+## 5. If all that isn't possible or it doesn't work ...
+
+Let me know about it (open an issue), because I'm likely confused about how 
all the above steps failed.
+
+Or it's a bug I don't know about. Please report it - just in case...
+
+
 ## Description
 
 RubyDep does 2 things right now:
Files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/ruby_dep/logger.rb new/lib/ruby_dep/logger.rb
--- old/lib/ruby_dep/logger.rb  2016-08-03 03:11:54.000000000 +0200
+++ new/lib/ruby_dep/logger.rb  2016-10-10 00:00:35.000000000 +0200
@@ -1,8 +1,40 @@
+require 'logger'
+
 module RubyDep
+  def self.logger
+    @logger ||= stderr_logger
+  end
+
+  def self.logger=(new_logger)
+    @logger = new_logger.nil? ? NullLogger.new : new_logger
+  end
+
+  def self.stderr_logger
+    ::Logger.new(STDERR).tap do |logger|
+      logger.formatter = proc { |_,_,_,msg| "#{msg}\n" }
+    end
+  end
+
+  # Shamelessly stolen from https://github.com/karafka/null-logger
+  class NullLogger
+    LOG_LEVELS = %w(unknown fatal error warn info debug).freeze
+
+    def respond_to_missing?(method_name, include_private = false)
+      LOG_LEVELS.include?(method_name.to_s) || super
+    end
+
+    def method_missing(method_name, *args, &block)
+      LOG_LEVELS.include?(method_name.to_s) ? nil : super
+    end
+  end
+
+  # TODO: not used, but kept for the sake of SemVer
+  # TODO: remove in next major version
   class Logger
     def initialize(device, prefix)
       @device = device
       @prefix = prefix
+      ::RubyDep.logger.warn("The RubyDep::Logger class is deprecated")
     end
 
     def warning(msg)
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/ruby_dep/version.rb new/lib/ruby_dep/version.rb
--- old/lib/ruby_dep/version.rb 2016-08-03 03:11:54.000000000 +0200
+++ new/lib/ruby_dep/version.rb 2016-10-10 00:00:35.000000000 +0200
@@ -1,3 +1,3 @@
 module RubyDep
-  VERSION = '1.4.0'.freeze
+  VERSION = '1.5.0'.freeze
 end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/ruby_dep/warning.rb new/lib/ruby_dep/warning.rb
--- old/lib/ruby_dep/warning.rb 2016-08-03 03:11:54.000000000 +0200
+++ new/lib/ruby_dep/warning.rb 2016-10-10 00:00:35.000000000 +0200
@@ -27,7 +27,6 @@
 
     def initialize
       @version = RubyVersion.new(RUBY_VERSION, RUBY_ENGINE)
-      @logger = Logger.new(STDERR, PREFIX)
     end
 
     def show_warnings
@@ -53,9 +52,11 @@
     end
 
     def warn_ruby(msg)
-      @logger.warning(msg)
-      @logger.notice(recommendation)
-      @logger.notice(NOTICE_HOW_TO_DISABLE)
+      RubyDep.logger.tap do |logger|
+        logger.warn(PREFIX + msg)
+        logger.info(PREFIX + recommendation)
+        logger.info(PREFIX + NOTICE_HOW_TO_DISABLE)
+      end
     end
 
     def recommendation
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata        2016-08-03 03:11:54.000000000 +0200
+++ new/metadata        2016-10-10 00:00:35.000000000 +0200
@@ -1,14 +1,14 @@
 --- !ruby/object:Gem::Specification
 name: ruby_dep
 version: !ruby/object:Gem::Version
-  version: 1.4.0
+  version: 1.5.0
 platform: ruby
 authors:
 - Cezary Baginski
 autorequire: 
 bindir: exe
 cert_chain: []
-date: 2016-08-03 00:00:00.000000000 Z
+date: 2016-10-09 00:00:00.000000000 Z
 dependencies:
 - !ruby/object:Gem::Dependency
   name: bundler


Reply via email to