Hello community,

here is the log from the commit of package p11-kit for openSUSE:Factory checked 
in at 2016-12-01 10:20:19
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/p11-kit (Old)
 and      /work/SRC/openSUSE:Factory/.p11-kit.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "p11-kit"

Changes:
--------
--- /work/SRC/openSUSE:Factory/p11-kit/p11-kit.changes  2016-02-17 
12:17:13.000000000 +0100
+++ /work/SRC/openSUSE:Factory/.p11-kit.new/p11-kit.changes     2016-12-01 
10:20:20.000000000 +0100
@@ -1,0 +2,9 @@
+Tue Nov 22 14:57:50 CET 2016 - sbra...@suse.com
+
+- 32-bit compatibility fixes:
+  * Add PKCS11 module to p11-kit-32bit (bsc#996047#c39)
+  * Add p11-kit-nss-trust-32bit NSS module
+  * Fix potential bi-arch issue with private binaries
+    (fdo#98817, p11-kit-biarch.patch)
+
+-------------------------------------------------------------------

New:
----
  p11-kit-biarch.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ p11-kit.spec ++++++
--- /var/tmp/diff_new_pack.8D044T/_old  2016-12-01 10:20:21.000000000 +0100
+++ /var/tmp/diff_new_pack.8D044T/_new  2016-12-01 10:20:21.000000000 +0100
@@ -32,10 +32,15 @@
 Source1:        
http://p11-glue.freedesktop.org/releases/%{name}-%{version}.tar.gz.sig
 Source98:       p11-kit.keyring
 Source99:       baselibs.conf
+Patch:          p11-kit-biarch.patch
 BuildRequires:  gtk-doc
 BuildRequires:  pkg-config
 BuildRequires:  pkgconfig(libffi) >= 3.0.0
 BuildRequires:  pkgconfig(libtasn1) >= 2.3
+# autotools are needed for p11-kit-biarch.patch
+BuildRequires:  autoconf
+BuildRequires:  automake
+BuildRequires:  libtool
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
@@ -88,8 +93,11 @@
 
 %prep
 %setup -q
+%patch -p1
 
 %build
+# autoreconf needed for p11-kit-biarch.patch
+autoreconf -f -i
 %configure --with-trust-paths=%{trustdir_cfg}:%{trustdir_static}
 make %{?_smp_mflags} V=1
 
@@ -120,8 +128,8 @@
 ln -s %{_libdir}/pkcs11/p11-kit-trust.so %{buildroot}%{_libdir}/libnssckbi.so
 #
 # call update-ca-certificates when trust changes
-rm %{buildroot}%{_libdir}/%{name}/trust-extract-compat
-ln -s ../../sbin/update-ca-certificates 
%{buildroot}%{_libdir}/%{name}/p11-kit-extract-trust
+rm %{buildroot}%{_libexecdir}/%{name}/trust-extract-compat
+ln -s ../../sbin/update-ca-certificates 
%{buildroot}%{_libexecdir}/%{name}/p11-kit-extract-trust
 export NO_BRP_STALE_LINK_ERROR=yes # *grr*
 
 %check
@@ -146,9 +154,9 @@
 %dir %{trustdir_static}/blacklist
 %{_datadir}/%{name}/modules/p11-kit-trust.module
 %{_libdir}/pkcs11/p11-kit-trust.so
-%dir %{_libdir}/%{name}
-%{_libdir}/%{name}/p11-kit-remote
-%{_libdir}/%{name}/p11-kit-extract-trust
+%dir %{_libexecdir}/%{name}
+%{_libexecdir}/%{name}/p11-kit-remote
+%{_libexecdir}/%{name}/p11-kit-extract-trust
 
 %files -n libp11-kit0
 %defattr(-,root,root)

++++++ baselibs.conf ++++++
--- /var/tmp/diff_new_pack.8D044T/_old  2016-12-01 10:20:21.000000000 +0100
+++ /var/tmp/diff_new_pack.8D044T/_new  2016-12-01 10:20:21.000000000 +0100
@@ -1,2 +1,9 @@
 libp11-kit0
 p11-kit
+    +/usr/lib(64)?/pkcs11/*.so
+    requires "p11-kit = <version>"
+p11-kit-nss-trust
+    +/usr/lib(64)?/*.so
+    requires "p11-kit = <version>"
+    conflicts "mozilla-nss-certs-<targettype>"
+    provides "libnssckbi.so"


++++++ p11-kit-biarch.patch ++++++
>From c1b85c3a59ab7b809e9531e1fb4bf38d9476fefc Mon Sep 17 00:00:00 2001
From: Stanislav Brabec <sbra...@suse.com>
Date: Tue, 22 Nov 2016 14:44:21 +0100
Subject: [PATCH] move privatedir from libdir to libexecdir

According to the GNU Coding Standards[1], private executables should be
installed to libexecdir, not libdir.

Move privatedir to libexecdir.

[1] https://www.gnu.org/prep/standards/

https://bugs.freedesktop.org/show_bug.cgi?id=98817
---
 configure.ac | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 64f0b5a..5cb1f17 100644
--- a/configure.ac
+++ b/configure.ac
@@ -498,7 +498,7 @@ esac
 AC_DEFINE_UNQUOTED(SHLEXT, ["$SHLEXT"], [File extension for shared libraries])
 AC_SUBST(SHLEXT)
 
-privatedir='${libdir}/p11-kit'
+privatedir='${libexecdir}/p11-kit'
 AC_SUBST(privatedir)
 
 AC_CONFIG_FILES([Makefile
-- 
2.10.2



Reply via email to