Hello community,

here is the log from the commit of package kparts for openSUSE:Factory checked 
in at 2017-07-17 10:25:09
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kparts (Old)
 and      /work/SRC/openSUSE:Factory/.kparts.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kparts"

Mon Jul 17 10:25:09 2017 rev:42 rq:509925 version:5.36.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/kparts/kparts.changes    2017-07-05 
23:52:20.507759804 +0200
+++ /work/SRC/openSUSE:Factory/.kparts.new/kparts.changes       2017-07-17 
10:25:10.830240381 +0200
@@ -1,0 +2,10 @@
+Wed Jul 12 07:14:02 CEST 2017 - lbeltr...@kde.org
+
+- Update to 5.36.0
+  * New feature release
+  * For more details please see:
+  * https://www.kde.org/announcements/kde-frameworks-5.36.0.php
+- Changes since 5.35.0:
+  * [FEATURE] Option to build & install QCH file with the public API dox
+
+-------------------------------------------------------------------

Old:
----
  kparts-5.35.0.tar.xz

New:
----
  kparts-5.36.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kparts.spec ++++++
--- /var/tmp/diff_new_pack.VgRRdl/_old  2017-07-17 10:25:11.294174979 +0200
+++ /var/tmp/diff_new_pack.VgRRdl/_new  2017-07-17 10:25:11.294174979 +0200
@@ -18,9 +18,9 @@
 
 %bcond_without lang
 %define lname   libKF5Parts5
-%define _tar_path 5.35
+%define _tar_path 5.36
 Name:           kparts
-Version:        5.35.0
+Version:        5.36.0
 Release:        0
 %define kf5_version %{version}
 BuildRequires:  cmake >= 3.0

++++++ kparts-5.35.0.tar.xz -> kparts-5.36.0.tar.xz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.35.0/CMakeLists.txt 
new/kparts-5.36.0/CMakeLists.txt
--- old/kparts-5.35.0/CMakeLists.txt    2017-06-03 12:28:04.000000000 +0200
+++ new/kparts-5.36.0/CMakeLists.txt    2017-07-02 10:08:50.000000000 +0200
@@ -1,11 +1,11 @@
 cmake_minimum_required(VERSION 3.0)
 
-set(KF5_VERSION "5.35.0") # handled by release scripts
-set(KF5_DEP_VERSION "5.35.0") # handled by release scripts
+set(KF5_VERSION "5.36.0") # handled by release scripts
+set(KF5_DEP_VERSION "5.36.0") # handled by release scripts
 project(KParts VERSION ${KF5_VERSION})
 
 include(FeatureSummary)
-find_package(ECM 5.35.0  NO_MODULE)
+find_package(ECM 5.36.0  NO_MODULE)
 set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake 
Modules." URL 
"https://projects.kde.org/projects/kdesupport/extra-cmake-modules";)
 feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND 
FATAL_ON_MISSING_REQUIRED_PACKAGES)
 
@@ -17,12 +17,15 @@
 include(KDEInstallDirs)
 include(KDEFrameworkCompilerSettings NO_POLICY_SCOPE)
 include(KDECMakeSettings)
-
+include(ECMAddQch)
 
 include(GenerateExportHeader)
 
 include(ECMSetupVersion)
 
+option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt 
Assistant, Qt Creator & KDevelop)" OFF)
+add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. 
Qt Assistant, Qt Creator & KDevelop)")
+
 ecm_setup_version(PROJECT VARIABLE_PREFIX KPARTS
                         VERSION_HEADER 
"${CMAKE_CURRENT_BINARY_DIR}/kparts_version.h"
                         PACKAGE_VERSION_FILE 
"${CMAKE_CURRENT_BINARY_DIR}/KF5PartsConfigVersion.cmake"
@@ -55,6 +58,16 @@
 # create a Config.cmake and a ConfigVersion.cmake file and install them
 set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_CMAKEPACKAGEDIR}/KF5Parts")
 
+if (BUILD_QCH)
+    ecm_install_qch_export(
+        TARGETS KF5Parts_QCH
+        FILE KF5PartsQchTargets.cmake
+        DESTINATION "${CMAKECONFIG_INSTALL_DIR}"
+        COMPONENT Devel
+    )
+    set(PACKAGE_INCLUDE_QCHTARGETS 
"include(\"\${CMAKE_CURRENT_LIST_DIR}/KF5PartsQchTargets.cmake\")")
+endif()
+
 include(CMakePackageConfigHelpers)
 
 configure_package_config_file(
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.35.0/KF5PartsConfig.cmake.in 
new/kparts-5.36.0/KF5PartsConfig.cmake.in
--- old/kparts-5.35.0/KF5PartsConfig.cmake.in   2017-06-03 12:28:04.000000000 
+0200
+++ new/kparts-5.36.0/KF5PartsConfig.cmake.in   2017-07-02 10:08:50.000000000 
+0200
@@ -6,3 +6,4 @@
 find_dependency(KF5XmlGui "@KF5_DEP_VERSION@")
 
 include("${CMAKE_CURRENT_LIST_DIR}/KF5PartsTargets.cmake")
+@PACKAGE_INCLUDE_QCHTARGETS@
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kparts-5.35.0/src/CMakeLists.txt 
new/kparts-5.36.0/src/CMakeLists.txt
--- old/kparts-5.35.0/src/CMakeLists.txt        2017-06-03 12:28:04.000000000 
+0200
+++ new/kparts-5.36.0/src/CMakeLists.txt        2017-07-02 10:08:50.000000000 
+0200
@@ -114,6 +114,31 @@
 install(FILES kde_terminal_interface.h DESTINATION 
${KDE_INSTALL_INCLUDEDIR_KF5}/KParts )
 
 
+if(BUILD_QCH)
+    ecm_add_qch(
+        KF5Parts_QCH
+        NAME KParts
+        BASE_NAME KF5Parts
+        VERSION ${KF5_VERSION}
+        ORG_DOMAIN org.kde
+        SOURCES # using only public headers, to cover only public API
+            ${KParts_HEADERS}
+            kde_terminal_interface.h
+        MD_MAINPAGE "${CMAKE_SOURCE_DIR}/README.md"
+        LINK_QCHS
+            KF5KIO_QCH
+            KF5XmlGui_QCH
+            KF5TextWidgets_QCH
+        BLANK_MACROS
+            KPARTS_EXPORT
+            KPARTS_DEPRECATED
+            KPARTS_DEPRECATED_EXPORT
+        TAGFILE_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
+        QCH_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
+        COMPONENT Devel
+    )
+endif()
+
 include(ECMGeneratePriFile)
 ecm_generate_pri_file(BASE_NAME KParts LIB_NAME KF5Parts DEPS "KIOWidgets 
KXmlGui KTextWidgets" FILENAME_VAR PRI_FILENAME INCLUDE_INSTALL_DIR 
${KDE_INSTALL_INCLUDEDIR_KF5}/KParts)
 install(FILES ${PRI_FILENAME} DESTINATION ${ECM_MKSPECS_INSTALL_DIR})


Reply via email to