Hello community,

here is the log from the commit of package libKF5ModemManagerQt for 
openSUSE:Factory checked in at 2017-07-17 10:26:31
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libKF5ModemManagerQt (Old)
 and      /work/SRC/openSUSE:Factory/.libKF5ModemManagerQt.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libKF5ModemManagerQt"

Mon Jul 17 10:26:31 2017 rev:39 rq:509941 version:5.36.0

Changes:
--------
--- 
/work/SRC/openSUSE:Factory/libKF5ModemManagerQt/libKF5ModemManagerQt.changes    
    2017-07-05 23:53:57.098154288 +0200
+++ 
/work/SRC/openSUSE:Factory/.libKF5ModemManagerQt.new/libKF5ModemManagerQt.changes
   2017-07-17 10:26:32.314753169 +0200
@@ -1,0 +2,10 @@
+Wed Jul 12 07:14:03 CEST 2017 - lbeltr...@kde.org
+
+- Update to 5.36.0
+  * New feature release
+  * For more details please see:
+  * https://www.kde.org/announcements/kde-frameworks-5.36.0.php
+- Changes since 5.35.0:
+  * [FEATURE] Option to build & install QCH file with the public API dox
+
+-------------------------------------------------------------------

Old:
----
  modemmanager-qt-5.35.0.tar.xz

New:
----
  modemmanager-qt-5.36.0.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libKF5ModemManagerQt.spec ++++++
--- /var/tmp/diff_new_pack.XEJ4aW/_old  2017-07-17 10:26:32.882673106 +0200
+++ /var/tmp/diff_new_pack.XEJ4aW/_new  2017-07-17 10:26:32.886672542 +0200
@@ -17,9 +17,9 @@
 
 
 %define soversion 6
-%define _tar_path 5.35
+%define _tar_path 5.36
 Name:           libKF5ModemManagerQt
-Version:        5.35.0
+Version:        5.36.0
 Release:        0
 Summary:        Qt wrapper for ModemManager DBus API
 License:        LGPL-2.1 or LGPL-3.0

++++++ modemmanager-qt-5.35.0.tar.xz -> modemmanager-qt-5.36.0.tar.xz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/modemmanager-qt-5.35.0/CMakeLists.txt 
new/modemmanager-qt-5.36.0/CMakeLists.txt
--- old/modemmanager-qt-5.35.0/CMakeLists.txt   2017-06-03 11:19:23.000000000 
+0200
+++ new/modemmanager-qt-5.36.0/CMakeLists.txt   2017-06-30 12:51:31.000000000 
+0200
@@ -1,10 +1,10 @@
 cmake_minimum_required(VERSION 3.0)
 
-set(KF5_VERSION "5.35.0") # handled by release scripts
+set(KF5_VERSION "5.36.0") # handled by release scripts
 project(ModemManagerQt VERSION ${KF5_VERSION})
 
 include(FeatureSummary)
-find_package(ECM 5.35.0  NO_MODULE)
+find_package(ECM 5.36.0  NO_MODULE)
 set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake 
Modules." URL 
"https://projects.kde.org/projects/kdesupport/extra-cmake-modules";)
 feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND 
FATAL_ON_MISSING_REQUIRED_PACKAGES)
 
@@ -32,8 +32,12 @@
 
 include(ECMSetupVersion)
 include(ECMGenerateHeaders)
+include(ECMAddQch)
 
 
+option(BUILD_QCH "Build API documentation in QCH format (for e.g. Qt 
Assistant, Qt Creator & KDevelop)" OFF)
+add_feature_info(QCH ${BUILD_QCH} "API documentation in QCH format (for e.g. 
Qt Assistant, Qt Creator & KDevelop)")
+
 ecm_setup_version(PROJECT VARIABLE_PREFIX MODEMMANAGERQT
                         VERSION_HEADER 
"${CMAKE_CURRENT_BINARY_DIR}/modemmanagerqt_version.h"
                         PACKAGE_VERSION_FILE 
"${CMAKE_CURRENT_BINARY_DIR}/KF5ModemManagerQtConfigVersion.cmake"
@@ -56,6 +60,16 @@
 # create a Config.cmake and a ConfigVersion.cmake file and install them
 set(CMAKECONFIG_INSTALL_DIR "${CMAKECONFIG_INSTALL_PREFIX}/KF5ModemManagerQt")
 
+if (BUILD_QCH)
+    ecm_install_qch_export(
+        TARGETS KF5ModemManagerQt_QCH
+        FILE KF5ModemManagerQtQchTargets.cmake
+        DESTINATION "${CMAKECONFIG_INSTALL_DIR}"
+        COMPONENT Devel
+    )
+    set(PACKAGE_INCLUDE_QCHTARGETS 
"include(\"\${CMAKE_CURRENT_LIST_DIR}/KF5ModemManagerQtQchTargets.cmake\")")
+endif()
+
 include(CMakePackageConfigHelpers)
 
 configure_package_config_file(
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/modemmanager-qt-5.35.0/KF5ModemManagerQtConfig.cmake.in 
new/modemmanager-qt-5.36.0/KF5ModemManagerQtConfig.cmake.in
--- old/modemmanager-qt-5.35.0/KF5ModemManagerQtConfig.cmake.in 2017-06-03 
11:19:23.000000000 +0200
+++ new/modemmanager-qt-5.36.0/KF5ModemManagerQtConfig.cmake.in 2017-06-30 
12:51:31.000000000 +0200
@@ -5,5 +5,4 @@
 
 
 include("${CMAKE_CURRENT_LIST_DIR}/KF5ModemManagerQtTargets.cmake")
-
-
+@PACKAGE_INCLUDE_QCHTARGETS@
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/modemmanager-qt-5.35.0/src/CMakeLists.txt 
new/modemmanager-qt-5.36.0/src/CMakeLists.txt
--- old/modemmanager-qt-5.35.0/src/CMakeLists.txt       2017-06-03 
11:19:23.000000000 +0200
+++ new/modemmanager-qt-5.36.0/src/CMakeLists.txt       2017-06-30 
12:51:31.000000000 +0200
@@ -108,6 +108,30 @@
   DESTINATION ${KF5_INCLUDE_INSTALL_DIR}/ModemManagerQt COMPONENT Devel
 )
 
+if(BUILD_QCH)
+    ecm_add_qch(
+        KF5ModemManagerQt_QCH
+        NAME ModemManagerQt
+        BASE_NAME KF5ModemManagerQt
+        VERSION ${KF5_VERSION}
+        ORG_DOMAIN org.kde
+        SOURCES # using only public headers, to cover only public API
+            ${ModemManagerQt_HEADERS}
+        MD_MAINPAGE "${CMAKE_SOURCE_DIR}/README.md"
+        LINK_QCHS
+            Qt5Core_QCH
+            Qt5DBus_QCH
+            Qt5Xml_QCH
+        BLANK_MACROS
+            MODEMMANAGERQT_EXPORT
+            MODEMMANAGERQT_DEPRECATED
+            MODEMMANAGERQT_DEPRECATED_EXPORT
+        TAGFILE_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
+        QCH_INSTALL_DESTINATION ${KDE_INSTALL_QTQCHDIR}
+        COMPONENT Devel
+    )
+endif()
+
 include(ECMGeneratePriFile)
 ecm_generate_pri_file(BASE_NAME ModemManagerQt LIB_NAME KF5ModemManagerQt DEPS 
"core" FILENAME_VAR PRI_FILENAME INCLUDE_INSTALL_DIR 
${KDE_INSTALL_INCLUDEDIR_KF5}/ModemManagerQt)
 install(FILES ${PRI_FILENAME} DESTINATION ${ECM_MKSPECS_INSTALL_DIR})


Reply via email to