Hello community,

here is the log from the commit of package rsyslog for openSUSE:Factory checked 
in at 2017-08-06 11:23:07
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rsyslog (Old)
 and      /work/SRC/openSUSE:Factory/.rsyslog.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rsyslog"

Sun Aug  6 11:23:07 2017 rev:128 rq:513800 version:8.28.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/rsyslog/rsyslog.changes  2017-06-20 
11:00:52.119546639 +0200
+++ /work/SRC/openSUSE:Factory/.rsyslog.new/rsyslog.changes     2017-08-06 
11:23:09.313852065 +0200
@@ -1,0 +2,34 @@
+Sun Jul 30 14:19:10 UTC 2017 - mich...@stroeder.com
+
+Version 8.28.0 [v8-stable] 2017-06-27
+  * omfwd: add parameter "tcp_frameDelimiter"
+  * omkafka: large refactor of kafka subsystem
+  * imfile: improved handling of atomically renamed file (w/ wildcards)
+  * imfile: add capability to truncate oversize messages or split into multiple
+  * mmdblookup fixes and extensions
+  * bugfix: fixed multiple memory leaks
+  * imptcp: add new parameter "flowControl"
+  * imrelp: add "maxDataSize" config parameter
+  * multiple modules: gtls: improve error if certificate file can't be opened
+  * omsnare: allow different tab escapes
+  * omelasticsearch: converted to use libfastjson instead of json-c
+  * imjournal: _PID fallback
+  * added fallback for _PID proprety when SYSLOG_PID is not available
+  * introduced new option "usepid" which sets which property should
+    rsyslog use, it has 3 states system|syslog|both, default is both
+  * deprecated "usepidfromsystem" option, still can be used
+    and override the "usepid"
+  * it is possible to revert previous default with usepid="syslog"
+  * multiple modules: add better error messages when regcomp is failing
+  * omhiredis: fix build warnings
+  * imfile bugfix: files mv-ed in into directory were not handled
+  * omprog bugfix: execve() incorrectly called
+  * imfile bugfix: multiline timeout did not work if state file exists
+  * lmsig_ksi-ls12 bugfix: build problems on some platforms
+  * core bugfix: invalid object type assertion
+  * regression fix: local hostname was not always detected properly...
+  * bugfix: format security issues in zmq3 modules (bsc#1051798)
+  * bugfix build system: add libksi only to those binaries that need it
+  * bugfix KSI ls12 components: invalid tree height calculation
+
+-------------------------------------------------------------------

Old:
----
  rsyslog-8.27.0.tar.gz
  rsyslog-doc-8.27.0.tar.gz

New:
----
  rsyslog-8.28.0.tar.gz
  rsyslog-doc-8.28.0.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rsyslog.spec ++++++
--- /var/tmp/diff_new_pack.vrOxj0/_old  2017-08-06 11:23:10.921625565 +0200
+++ /var/tmp/diff_new_pack.vrOxj0/_new  2017-08-06 11:23:10.941622748 +0200
@@ -20,7 +20,7 @@
 Summary:        The enhanced syslogd for Linux and Unix
 License:        (GPL-3.0+ and Apache-2.0)
 Group:          System/Daemons
-Version:        8.27.0
+Version:        8.28.0
 Release:        0
 %if 0%{?suse_version} >= 1210
 %bcond_without  systemd
@@ -170,9 +170,9 @@
 %if %{with relp}
 # RELP support
 %if %{with pkgconfig}
-BuildRequires:  pkgconfig(relp) >= 1.2.12
+BuildRequires:  pkgconfig(relp) >= 1.2.14
 %else
-BuildRequires:  librelp-devel >= 1.2.12
+BuildRequires:  librelp-devel >= 1.2.14
 %endif
 %endif
 %if %{with udpspoof}

++++++ rsyslog-8.27.0.tar.gz -> rsyslog-8.28.0.tar.gz ++++++
++++ 14015 lines of diff (skipped)

++++++ rsyslog-doc-8.27.0.tar.gz -> rsyslog-doc-8.28.0.tar.gz ++++++
++++ 12082 lines of diff (skipped)


Reply via email to