Hello community,

here is the log from the commit of package pulseaudio for openSUSE:Factory 
checked in at 2017-08-06 11:31:37
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/pulseaudio (Old)
 and      /work/SRC/openSUSE:Factory/.pulseaudio.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "pulseaudio"

Sun Aug  6 11:31:37 2017 rev:144 rq:512920 version:10.99.1

Changes:
--------
--- /work/SRC/openSUSE:Factory/pulseaudio/pulseaudio.changes    2017-03-22 
23:03:24.634190304 +0100
+++ /work/SRC/openSUSE:Factory/.pulseaudio.new/pulseaudio.changes       
2017-08-06 11:31:38.602102778 +0200
@@ -1,0 +2,33 @@
+Fri Jul 28 12:40:25 UTC 2017 - ohole...@suse.com
+
+- Fix Requires(post) and Requires(pre) mixup
+
+-------------------------------------------------------------------
+Tue Jul 25 10:48:02 UTC 2017 - ohole...@suse.com
+
+- Update to 11 RC1 (10.99.1)
+  * Support for newer AirPlay hardware
+  * USB and bluetooth devices preferred over internal sound cards
+  * Bluetooth HSP headset role implemented
+  * Bluetooth HFP audio gateway role implemented (requires oFono)
+  * Bluetooth HSP audio gateway and HFP hands-free unit roles can
+    be enabled simultaneously
+  * Upmixing can now be disabled without bad side effects
+  * Avoid having unavailable sinks or sources as the default
+  * Option to avoid resampling more often
+  * Option to automatically switch bluetooth profile to HSP more often
+  * Better latency control in module-loopback
+  * Changed module argument names in module-ladspa-sink and
+     module-virtual-surround-sink
+  * Fixed input device handling in module-waveout
+  * Improved bluetooth MTU configuration (warning! this causes some
+    hardware to not work any more, see the details below for how to fix it)
+  * Applications can request LADSPA or virtual surround filtering for
+    their streams
+  * Support for 32-bit applications on 64-bit systems in padsp
+- add --with-pulsedsp-location='/usr/\\$$LIB/pulseaudio' to enable
+  upstream padsp multiarch fix
+- remove patch4 padsp-biarch.patch, fixed upstream
+- remove patch5 pulseaudio-vala-0.36.patch, fixed upstream
+
+-------------------------------------------------------------------

Old:
----
  padsp-biarch.patch
  pulseaudio-10.0.tar.xz
  pulseaudio-vala-0.36.patch

New:
----
  pulseaudio-10.99.1.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ pulseaudio.spec ++++++
--- /var/tmp/diff_new_pack.KxN7a6/_old  2017-08-06 11:31:40.981767519 +0200
+++ /var/tmp/diff_new_pack.KxN7a6/_new  2017-08-06 11:31:40.989766392 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package pulseaudio
 #
-# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,7 +16,7 @@
 #
 
 
-%define drvver  10.0
+%define drvver  10.99
 %define soname  0
 %define _udevrulesdir %(pkg-config --variable=udevdir udev)/rules.d
 %define _fwdefdir %{_sysconfdir}/sysconfig/SuSEfirewall2.d/services
@@ -27,10 +27,10 @@
 %define _bluez5used 0%(echo "%{_bluezVersion}" | grep -q '^5' && echo 1)
 %define _bashcompletionsdir %{_datadir}/bash-completion/completions
 Name:           pulseaudio
-Version:        10.0
+Version:        10.99.1
 Release:        0
 Summary:        A Networked Sound Server
-License:        GPL-2.0+ and LGPL-2.1+
+License:        GPL-2.0+ AND LGPL-2.1+
 Group:          System/Sound Daemons
 Url:            http://pulseaudio.org
 Source:         
http://www.freedesktop.org/software/pulseaudio/releases/%{name}-%{version}.tar.xz
@@ -44,10 +44,6 @@
 Patch0:         disabled-start.diff
 Patch1:         suppress-socket-error-msg.diff
 Patch2:         pulseaudio-wrong-memset.patch
-# PATCH-FIX-OPENSUSE padsp-biarch.patch bnc#968568
-Patch4:         padsp-biarch.patch
-# PATCH-FIX-UPSTREAM pulseaudio-vala-0.36.patch dims...@opensuse.org -- 
Introduce compatibility with vala 0.36
-Patch5:         pulseaudio-vala-0.36.patch
 BuildRequires:  alsa-devel >= 1.0.19
 # require only minimal bluez, if we are on bluez 5 we will determine in build 
phase
 BuildRequires:  bluez-devel >= 4.99
@@ -67,6 +63,7 @@
 BuildRequires:  libwebrtc_audio_processing-devel >= 0.3
 BuildRequires:  lirc-devel
 BuildRequires:  orc >= 0.4.9
+BuildRequires:  pkgconfig
 BuildRequires:  systemd
 BuildRequires:  systemd-devel
 BuildRequires:  translation-update-upstream
@@ -90,10 +87,8 @@
 Requires:       udev >= 146
 ## needs the same liborc version which was used to build against
 %requires_eq    liborc-0_4-0
-# FIXME: use proper Requires(pre/post/preun/...)
-PreReq:         %fillup_prereq
-PreReq:         pwdutils
-Requires(pre):  group(audio)
+Requires(post): %fillup_prereq
+Requires(pre):  pwdutils
 Recommends:     %{name}-bash-completion
 Recommends:     %{name}-lang
 Recommends:     alsa-plugins-pulse
@@ -103,9 +98,9 @@
 Provides:       libpulsecore9 = 0.9.15
 Obsoletes:      libpulsecore7 < 0.9.13
 Provides:       libpulsecore7 = 0.9.13
-BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 %if 0%{?suse_version} > 1320
 BuildRequires:  speexdsp-devel
+Requires(pre):  group(audio)
 %else
 BuildRequires:  speex-devel
 %endif
@@ -288,12 +283,12 @@
 %package gdm-hooks
 Summary:        PulseAudio GDM integration
 Group:          Productivity/Multimedia/Other
+#avoid cycle
+#!BuildIgnore:  gdm
 Requires:       %{name} = %{version}
 Requires:       gdm >= 2.22
 #for the gdm user
 Requires(pre):  gdm
-#avoid cycle
-#!BuildIgnore: gdm
 
 %description gdm-hooks
 pulseaudio is a networked sound server for Linux and other Unix like
@@ -327,8 +322,6 @@
 %patch0
 %patch1 -p1
 %patch2
-%patch4 -p1
-%patch5 -p1
 
 %build
 ./bootstrap.sh
@@ -350,7 +343,9 @@
 %else
         --disable-bluez5 \
 %endif
-        --with-udev-rules-dir=%{_udevrulesdir}
+        --with-udev-rules-dir=%{_udevrulesdir} \
+        --with-pulsedsp-location='%{_prefix}/\\$$LIB/pulseaudio'
+
 make %{?_smp_mflags} V=1
 make %{?_smp_mflags} doxygen
 
@@ -393,7 +388,7 @@
 mkdir -p %{buildroot}%{_sysconfdir}/pulse/client.conf.d
 mkdir -p %{buildroot}%{_sysconfdir}/pulse/daemon.conf.d
 # Install disable_flat_volumes.conf
-install -m 0644 %{S:6} %{buildroot}%{_sysconfdir}/pulse/daemon.conf.d
+install -m 0644 %{SOURCE6} %{buildroot}%{_sysconfdir}/pulse/daemon.conf.d
 # created by setup-pulseaudio script
 touch %{buildroot}%{_sysconfdir}/pulse/client.conf.d/50-system.conf
 %fdupes doxygen/html
@@ -406,13 +401,9 @@
 exit 0
 
 %post   -n libpulse%{soname} -p /sbin/ldconfig
-
 %postun -n libpulse%{soname} -p /sbin/ldconfig
-
 %post   -n libpulse-mainloop-glib%{soname} -p /sbin/ldconfig
-
 %postun -n libpulse-mainloop-glib%{soname} -p /sbin/ldconfig
-
 %post
 /sbin/ldconfig
 %{fillup_only -an sound}
@@ -420,7 +411,6 @@
 setup-pulseaudio --auto > /dev/null
 
 %postun -p /sbin/ldconfig
-
 %pre system-wide
 %service_add_pre pulseaudio.service
 exit 0
@@ -438,7 +428,6 @@
 exit 0
 
 %files
-%defattr(-,root,root)
 %doc README LICENSE GPL LGPL
 %{_bindir}/pulseaudio
 %{_bindir}/setup-pulseaudio
@@ -559,19 +548,16 @@
 %ghost %{_sysconfdir}/pulse/client.conf.d/50-system.conf
 
 %files esound-compat
-%defattr(-,root,root)
 %{_bindir}/esdcompat
 %{_bindir}/esd
 %{_mandir}/man1/esdcompat.1*
 
 %files gdm-hooks
-%defattr(-,root,root)
 %attr(0750, gdm, gdm) %dir %{_localstatedir}/lib/gdm
 %attr(0700, gdm, gdm) %dir %{_localstatedir}/lib/gdm/.pulse
 %attr(0600, gdm, gdm) %{_localstatedir}/lib/gdm/.pulse/default.pa
 
 %files -n libpulse%{soname}
-%defattr(-,root,root)
 %doc README LICENSE GPL LGPL
 %dir %{_sysconfdir}/pulse/
 %dir %{_sysconfdir}/pulse/client.conf.d
@@ -583,7 +569,6 @@
 %{_libdir}/pulseaudio/libpulsecommon-%{drvver}.so
 
 %files -n libpulse-devel
-%defattr(-,root,root)
 %doc doxygen/html
 %{_includedir}/pulse/
 %{_libdir}/libpulse.so
@@ -596,12 +581,10 @@
 %{_datadir}/vala
 
 %files -n libpulse-mainloop-glib%{soname}
-%defattr(-,root,root)
 %{_libdir}/libpulse-mainloop-glib.so.%{soname}
 %{_libdir}/libpulse-mainloop-glib.so.%{soname}.*
 
 %files module-bluetooth
-%defattr(-,root,root)
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
 %{_libdir}/pulse-%{drvver}/modules/module-bluetooth-policy.so
@@ -617,7 +600,6 @@
 %endif
 
 %files module-gconf
-%defattr(-,root,root)
 %dir %{_libexecdir}/pulse
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
@@ -625,13 +607,11 @@
 %{_libexecdir}/pulse/gconf-helper
 
 %files module-lirc
-%defattr(-,root,root)
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
 %{_libdir}/pulse-%{drvver}/modules/module-lirc.so
 
 %files module-jack
-%defattr(-,root,root)
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
 %{_libdir}/pulse-%{drvver}/modules/module-jack-sink.so
@@ -639,7 +619,6 @@
 %{_libdir}/pulse-%{drvver}/modules/module-jackdbus-detect.so
 
 %files module-x11
-%defattr(-,root,root)
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
 %{_sysconfdir}/xdg/autostart/pulseaudio.desktop
@@ -651,7 +630,6 @@
 %{_mandir}/man1/start-pulseaudio-x11.1*
 
 %files module-zeroconf
-%defattr(-,root,root)
 %dir %{_libdir}/pulse-%{drvver}
 %dir %{_libdir}/pulse-%{drvver}/modules
 %{_libdir}/pulse-%{drvver}/modules/libavahi-wrap.so
@@ -662,7 +640,6 @@
 %{_libdir}/pulse-%{drvver}/modules/module-zeroconf-publish.so
 
 %files utils
-%defattr(-,root,root)
 %{_bindir}/pacat
 %{_bindir}/pacmd
 %{_bindir}/pactl
@@ -682,21 +659,18 @@
 %{_mandir}/man1/pasuspender.1*
 %{_mandir}/man1/padsp.1*
 %{_mandir}/man1/pax11publish.1*
-%{_mandir}/man1/pamon.1.gz
-%{_mandir}/man1/parec.1.gz
-%{_mandir}/man1/parecord.1.gz
+%{_mandir}/man1/pamon.1%{ext_man}
+%{_mandir}/man1/parec.1%{ext_man}
+%{_mandir}/man1/parecord.1%{ext_man}
 
 %files lang -f %{name}.lang
-%defattr(-,root,root)
 
 %files system-wide
-%defattr(-,root,root)
 %{_sbindir}/rc%{name}
 %dir %{_libexecdir}/systemd/system
 %{_libexecdir}/systemd/system/%{name}.service
 
 %files bash-completion
-%defattr(-,root,root)
 %dir %{_datadir}/bash-completion
 %dir %{_datadir}/bash-completion/completions
 %{_bashcompletionsdir}/pulseaudio
@@ -710,7 +684,6 @@
 %{_bashcompletionsdir}/pasuspender
 
 %files zsh-completion
-%defattr(-,root,root)
 %dir %{_datarootdir}/zsh
 %dir %{_datarootdir}/zsh/site-functions/
 %{_datarootdir}/zsh/site-functions/_pulseaudio

++++++ pulseaudio-10.0.tar.xz -> pulseaudio-10.99.1.tar.xz ++++++
++++ 40752 lines of diff (skipped)


Reply via email to