Hello community,

here is the log from the commit of package kmymoney for openSUSE:Factory 
checked in at 2017-08-28 15:17:35
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kmymoney (Old)
 and      /work/SRC/openSUSE:Factory/.kmymoney.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kmymoney"

Mon Aug 28 15:17:35 2017 rev:54 rq:518870 version:4.8.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/kmymoney/kmymoney.changes        2017-07-04 
09:11:52.382132615 +0200
+++ /work/SRC/openSUSE:Factory/.kmymoney.new/kmymoney.changes   2017-08-28 
15:18:53.134221468 +0200
@@ -1,0 +2,6 @@
+Sat Aug 26 08:15:10 UTC 2017 - wba...@tmo.at
+
+- Add fix-build-with-cmake-3.9.patch to fix build with latest
+  cmake in Factory (kde#383351)
+
+-------------------------------------------------------------------

New:
----
  fix-build-with-cmake-3.9.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kmymoney.spec ++++++
--- /var/tmp/diff_new_pack.eGZrG3/_old  2017-08-28 15:18:54.785989353 +0200
+++ /var/tmp/diff_new_pack.eGZrG3/_new  2017-08-28 15:18:54.789988790 +0200
@@ -30,6 +30,8 @@
 Patch2:         fix-build.patch
 # PATCH-FIX-OPENSUSE aqbanking-5.1-backward-compatibility.patch boo#1042760 -- 
allow to build the kbanking plugin on Leap 42
 Patch3:         aqbanking-5.1-backward-compatibility.patch
+# PATCH-FIX-UPSTREAM fix-build-with-cmake-3.9.patch kde#383351 -- fix build 
with latest cmake in Factory
+Patch4:         fix-build-with-cmake-3.9.patch
 BuildRequires:  aqbanking-devel
 %if 0%{?suse_version} > 1325
 BuildRequires:  libboost_headers-devel
@@ -95,6 +97,7 @@
 %if 0%{suse_version} <= 1320
 %patch3 -p1
 %endif
+%patch4 -p1
 
 %build
 %cmake_kde4 -d build

++++++ fix-build-with-cmake-3.9.patch ++++++
>From b0a68ca075928aa29ee1e0007bfb14d714f5a948 Mon Sep 17 00:00:00 2001
From: Ralf Habacker <ralf.habac...@freenet.de>
Date: Thu, 10 Aug 2017 13:45:04 +0200
Subject: Fix 'Compile error on Fedora 26'

CMake build system used some outdated variables which has been replaced
by cmake build in variables to fix the issue.

FIXED-IN:4.8.1
BUG:383351
---
 kmymoney/dialogs/settings/CMakeLists.txt | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

diff --git a/kmymoney/dialogs/settings/CMakeLists.txt 
b/kmymoney/dialogs/settings/CMakeLists.txt
index 5aacbea..b007dfb 100644
--- a/kmymoney/dialogs/settings/CMakeLists.txt
+++ b/kmymoney/dialogs/settings/CMakeLists.txt
@@ -1,12 +1,11 @@
 add_custom_command(
-  OUTPUT ${KMyMoney2_BINARY_DIR}/kmymoneysettings.h  
${KMyMoney2_BINARY_DIR}/kmymoneysettings.cpp
-  DEPENDS ${KMyMoney2_SOURCE_DIR}/kmymoney.kcfg 
${KMyMoney2_SOURCE_DIR}/kmymoneysettings.kcfgc
-  COMMAND ${KDE4_KCFGC_EXECUTABLE} -d ${KMyMoney2_BINARY_DIR}/ 
${KMyMoney2_SOURCE_DIR}/kmymoney.kcfg 
${KMyMoney2_SOURCE_DIR}/kmymoneysettings.kcfgc
+  OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/kmymoneysettings.h  
${CMAKE_CURRENT_BINARY_DIR}/kmymoneysettings.cpp
+  DEPENDS ${CMAKE_SOURCE_DIR}/kmymoney/kmymoney.kcfg 
${CMAKE_SOURCE_DIR}/kmymoney/kmymoneysettings.kcfgc
+  COMMAND ${KDE4_KCFGC_EXECUTABLE} -d ${CMAKE_CURRENT_BINARY_DIR}/ 
${CMAKE_SOURCE_DIR}/kmymoney/kmymoney.kcfg 
${CMAKE_SOURCE_DIR}/kmymoney/kmymoneysettings.kcfgc
   )
 
-
 set (libsettings_a_SOURCES
-  ${KMyMoney2_BINARY_DIR}/kmymoneysettings.h
+  ${CMAKE_CURRENT_BINARY_DIR}/kmymoneysettings.cpp
   ksettingscolors.cpp
   ksettingsfonts.cpp
   ksettingsforecast.cpp
-- 
cgit v0.11.2


Reply via email to