Hello community,

here is the log from the commit of package python-cinderclient for 
openSUSE:Factory checked in at 2018-01-24 15:30:47
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-cinderclient (Old)
 and      /work/SRC/openSUSE:Factory/.python-cinderclient.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-cinderclient"

Wed Jan 24 15:30:47 2018 rev:30 rq:568513 version:3.4.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/python-cinderclient/python-cinderclient.changes  
2017-08-28 15:29:56.392998669 +0200
+++ 
/work/SRC/openSUSE:Factory/.python-cinderclient.new/python-cinderclient.changes 
    2018-01-24 15:30:49.229475138 +0100
@@ -1,0 +2,59 @@
+Tue Jan 16 22:00:53 UTC 2018 - cloud-de...@suse.de
+
+- update to version 3.4.0
+  - Remove 'end_version' parameter in backup update
+  - Remove setting of version/release from releasenotes
+  - Removed unnecessary parameters from group and group_snapshots create APIs
+  - Follow the new PTI for document build
+  - Fix the way to get backup metadata
+  - Deprecate multiattach flag on volume create
+  - Backup create is not available from 3.0 to 3.42
+  - Updated from global requirements
+- Drop 0001-Fix-man-page-build.patch . Applied upstream.
+
+-------------------------------------------------------------------
+Wed Dec 20 09:33:57 UTC 2017 - cloud-de...@suse.de
+
+- update to version 3.3.0
+  - Implement metadata for backup create/update
+  - Support skip-validation for quota update
+  - Bump Max API version to 3.48
+  - Enable H306
+  - Avoid tox_install.sh for constraints support
+  - Enable F811, F821
+  - Remove unused attribute when updating quota_class
+  - Fix attachment_id returned by create and show volume
+  - Bump Max version to 3.46
+  - Bump MAX version of client to 3.45
+  - Update old url for cinderclient's document
+  - Add api_version_wraps to attachment-complete
+  - Let keystoneauth set the microversion header
+  - Support create volume from backup in client
+  - Explicitly set 'builder' option
+  - Added missing column 'Allocated'
+  - Fix method/module redefinition errors
+  - Revert "Bump MAX version of client to 3.45"
+  - cleanup test-requirements
+  - Migrate to Zuul v3
+  - Add cluster support in migration and manage
+  - Support list with 'with_count' in client
+  - Use generic user for both zuul v2 and v3
+  - Clean the redundant code in shell.py
+  - Fix man page build
+  - Add .stestr.conf configuration
+  - Add an attachment_complete API call
+  - doc: Remove cruft from conf.py
+  - Correct sphinx source code syntax
+  - Fix to use "." to source script files
+  - [Optimize] Adds interval and increase waiting time
+  - Remove run_tests.sh
+  - Update reno for stable/pike
+  - Fix wrong links
+  - Fix OS_AUTH_TYPE env var usage
+  - Fix get_highest_client_server_version with Cinder API + uWSGI
+  - Unsupported 'message' Exception attribute in PY3
+  - Updated from global requirements
+  - Use Sphinx 1.5 warning-is-error
+  - Implement UserID in snapshot list response
+
+-------------------------------------------------------------------

Old:
----
  0001-Fix-man-page-build.patch
  python-cinderclient-3.1.0.tar.gz

New:
----
  python-cinderclient-3.4.0.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-cinderclient.spec ++++++
--- /var/tmp/diff_new_pack.O5nSQH/_old  2018-01-24 15:30:50.009438660 +0100
+++ /var/tmp/diff_new_pack.O5nSQH/_new  2018-01-24 15:30:50.013438472 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package python-cinderclient
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -16,95 +16,128 @@
 #
 
 
-%global sname python-cinderclient
 Name:           python-cinderclient
-Version:        3.1.0
+Version:        3.4.0
 Release:        0
 Summary:        Python API and CLI for OpenStack Cinder
 License:        Apache-2.0
 Group:          Development/Languages/Python
-Url:            https://launchpad.net/%{sname}
-Source0:        
https://pypi.io/packages/source/p/%{sname}/%{sname}-%{version}.tar.gz
-# https://review.openstack.org/#/c/488924/
-Patch1:         0001-Fix-man-page-build.patch
+Url:            https://launchpad.net/python-cinderclient
+Source0:        
https://files.pythonhosted.org/packages/source/p/python-cinderclient/python-cinderclient-3.4.0.tar.gz
 BuildRequires:  openstack-macros
-BuildRequires:  python-PrettyTable >= 0.7.1
-BuildRequires:  python-ddt >= 1.0.1
 BuildRequires:  python-devel
-BuildRequires:  python-fixtures >= 3.0.0
-BuildRequires:  python-keystoneauth1 >= 2.21.0
-BuildRequires:  python-mock >= 2.0
-BuildRequires:  python-os-testr >= 0.8.0
-BuildRequires:  python-oslo.serialization >= 1.10.0
-BuildRequires:  python-oslo.utils >= 3.20.0
-BuildRequires:  python-pbr >= 2.0.0
-BuildRequires:  python-python-subunit >= 0.0.18
-BuildRequires:  python-requests >= 2.14.2
-BuildRequires:  python-requests-mock >= 1.1
-BuildRequires:  python-testrepository >= 0.0.18
-BuildRequires:  python-testscenarios >= 0.4
-BuildRequires:  python-testtools >= 1.4.0
+BuildRequires:  python2-PrettyTable >= 0.7.1
+BuildRequires:  python2-ddt >= 1.0.1
+BuildRequires:  python2-fixtures >= 3.0.0
+BuildRequires:  python2-keystoneauth1 >= 3.2.0
+BuildRequires:  python2-mock >= 2.0.0
+BuildRequires:  python2-os-testr >= 1.0.0
+BuildRequires:  python2-oslo.serialization >= 2.18.0
+BuildRequires:  python2-oslo.utils >= 3.31.0
+BuildRequires:  python2-pbr >= 2.0.0
+BuildRequires:  python2-python-subunit >= 1.0.0
+BuildRequires:  python2-requests >= 2.14.2
+BuildRequires:  python2-requests-mock >= 1.1.0
+BuildRequires:  python2-testrepository >= 0.0.18
+BuildRequires:  python2-testscenarios >= 0.4
+BuildRequires:  python2-testtools >= 2.2.0
+BuildRequires:  python3-PrettyTable >= 0.7.1
+BuildRequires:  python3-ddt >= 1.0.1
+BuildRequires:  python3-devel
+BuildRequires:  python3-fixtures >= 3.0.0
+BuildRequires:  python3-keystoneauth1 >= 3.2.0
+BuildRequires:  python3-mock >= 2.0.0
+BuildRequires:  python3-os-testr >= 1.0.0
+BuildRequires:  python3-oslo.serialization >= 2.18.0
+BuildRequires:  python3-oslo.utils >= 3.31.0
+BuildRequires:  python3-pbr >= 2.0.0
+BuildRequires:  python3-python-subunit >= 1.0.0
+BuildRequires:  python3-requests >= 2.14.2
+BuildRequires:  python3-requests-mock >= 1.1.0
+BuildRequires:  python3-testrepository >= 0.0.18
+BuildRequires:  python3-testscenarios >= 0.4
+BuildRequires:  python3-testtools >= 2.2.0
 Requires:       python-Babel >= 2.3.4
 Requires:       python-PrettyTable >= 0.7.1
-Requires:       python-keystoneauth1 >= 2.21.0
-Requires:       python-oslo.i18n >= 2.1.0
-Requires:       python-oslo.utils >= 3.20.0
+Requires:       python-keystoneauth1 >= 3.2.0
+Requires:       python-oslo.i18n >= 3.15.3
+Requires:       python-oslo.utils >= 3.31.0
 Requires:       python-requests >= 2.14.2
-Requires:       python-simplejson >= 2.2.0
-Requires:       python-six >= 1.9.0
+Requires:       python-simplejson >= 3.5.1
+Requires:       python-six >= 1.10.0
 BuildArch:      noarch
+%if 0%{?suse_version}
+Requires(post): update-alternatives
+Requires(postun): update-alternatives
+%else
+# on RDO, update-alternatives is in chkconfig
+Requires(post): chkconfig
+Requires(postun): chkconfig
+%endif
+%python_subpackages
 
 %description
 This is a client for the OpenStack Cinder API (Block Storage. There's a
 Python API (the cinderclient module), and a command-line script (cinder).
 Each implements 100% of the OpenStack Cinder API.
 
-%package doc
+%package -n python-cinderclient-doc
 Summary:        Documentation for OpenStack Cinder API Client
-Group:          Documentation
+Group:          Documentation/HTML
 BuildRequires:  python-Sphinx
-BuildRequires:  python-openstackdocstheme >= 1.11.0
-BuildRequires:  python-reno >= 1.8.0
+BuildRequires:  python-openstackdocstheme >= 1.17.0
+BuildRequires:  python-reno >= 2.5.0
 
-%description      doc
+%description -n python-cinderclient-doc
 This is a client for the OpenStack Cinder API (Block Storage. There's a
 Python API (the cinderclient module), and a command-line script (cinder).
 Each implements 100% of the OpenStack Cinder API.
 This package contains auto-generated documentation.
 
 %prep
-%autosetup -p1 -n %{sname}-%{version}
+%autosetup -p1 -n python-cinderclient-3.4.0
 %py_req_cleanup
 sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
 
 %build
-%{py2_build}
+%{python_build}
 
 %{__python2} setup.py build_sphinx --builder=html,man
 # remove the sphinx-build leftovers
 rm -rf doc/build/html/.{doctrees,buildinfo}
 
 %install
-%{py2_install}
+%{python_install}
 # man page
 install -p -D -m 644 doc/build/man/cinder.1 
%{buildroot}%{_mandir}/man1/cinder.1
 # bash completion
 install -p -D -m 644 tools/cinder.bash_completion 
%{buildroot}%{_sysconfdir}/bash_completion.d/cinder.bash_completion
+%python_clone -a %{buildroot}%{_bindir}/cinder
+%python_clone -a %{buildroot}%{_mandir}/man1/cinder.1
+%python_clone -a 
%{buildroot}%{_sysconfdir}/bash_completion.d/cinder.bash_completion
+
+%post
+%{python_install_alternative cinder cinder.1 
%{_sysconfdir}/bash_completion.d/cinder.bash_completion}
+
+%postun
+%python_uninstall_alternative cinder
 
 %check
 rm cinderclient/tests/unit/test_shell.py
-%{__python2} setup.py testr
+%{python_expand rm -rf .testrepository
+ostestr
+}
 
-%files
+%files %{python_files}
 %license LICENSE
 %doc README.rst ChangeLog
-%{python2_sitelib}/cinderclient
-%{python2_sitelib}/*.egg-info
-%{_bindir}/cinder
-%{_mandir}/man1/cinder.1*
-%{_sysconfdir}/bash_completion.d/cinder.bash_completion
+%{python_sitelib}/cinderclient
+%{python_sitelib}/*.egg-info
+%python_alternative %{_bindir}/cinder
+%python_alternative %{_mandir}/man1/cinder.1
+%python_alternative %{_sysconfdir}/bash_completion.d/cinder.bash_completion
 
-%files doc
+%files -n python-cinderclient-doc
 %license LICENSE
 %doc doc/build/html
 

++++++ _service ++++++
--- /var/tmp/diff_new_pack.O5nSQH/_old  2018-01-24 15:30:50.085435106 +0100
+++ /var/tmp/diff_new_pack.O5nSQH/_new  2018-01-24 15:30:50.105434170 +0100
@@ -1,8 +1,8 @@
 <services>
   <service mode="disabled" name="renderspec">
-    <param 
name="input-template">https://raw.githubusercontent.com/openstack/rpm-packaging/stable/pike/openstack/python-cinderclient/python-cinderclient.spec.j2</param>
+    <param 
name="input-template">https://raw.githubusercontent.com/openstack/rpm-packaging/master/openstack/python-cinderclient/python-cinderclient.spec.j2</param>
     <param name="output-name">python-cinderclient.spec</param>
-    <param 
name="requirements">https://raw.githubusercontent.com/openstack/rpm-packaging/stable/pike/global-requirements.txt</param>
+    <param 
name="requirements">https://raw.githubusercontent.com/openstack/rpm-packaging/master/requirements.txt</param>
     <param name="changelog-email">cloud-de...@suse.de</param>
     <param name="changelog-provider">gh,openstack,python-cinderclient</param>
   </service>

++++++ python-cinderclient-3.1.0.tar.gz -> python-cinderclient-3.4.0.tar.gz 
++++++
++++ 4613 lines of diff (skipped)


Reply via email to