Hello community,

here is the log from the commit of package velum for openSUSE:Factory checked 
in at 2018-02-02 22:22:55
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/velum (Old)
 and      /work/SRC/openSUSE:Factory/.velum.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "velum"

Fri Feb  2 22:22:55 2018 rev:4 rq:572010 
version:3.0.0+dev+git_r636_348aa62ece758fd9933ade7f585ec04e8d8d32a4

Changes:
--------
--- /work/SRC/openSUSE:Factory/velum/velum.changes      2018-02-01 
21:31:46.826359768 +0100
+++ /work/SRC/openSUSE:Factory/.velum.new/velum.changes 2018-02-02 
22:23:26.734616949 +0100
@@ -1,0 +2,19 @@
+Fri Feb  2 11:59:45 UTC 2018 - containers-bugow...@suse.de
+
+- Commit b58ccc8 by Maximilian Meister mmeis...@suse.de
+ relax gems
+ 
+ Signed-off-by: Maximilian Meister <mmeis...@suse.de>
+ 
+ Commit a02e6b9 by Maximilian Meister mmeis...@suse.de
+ use bundler dependency script from darix
+ 
+ also hardcode the native dependencies in the spec template as they likely
+ won't change that often
+ 
+ Signed-off-by: Maximilian Meister <mmeis...@suse.de>
+
+- patch modifications:
+  + 1_nodev.gem.patch
+
+-------------------------------------------------------------------

New:
----
  1_nodev.gem.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ velum.spec ++++++
--- /var/tmp/diff_new_pack.TjxSdz/_old  2018-02-02 22:23:27.322589503 +0100
+++ /var/tmp/diff_new_pack.TjxSdz/_new  2018-02-02 22:23:27.326589316 +0100
@@ -23,7 +23,7 @@
 # Version:      1.0.0
 # %%define branch 1.0.0
 
-Version:        3.0.0+dev+git_r633_b8e974fd577e29eb7be871a0cbb661bacb511dc7
+Version:        3.0.0+dev+git_r636_348aa62ece758fd9933ade7f585ec04e8d8d32a4
 Release:        0
 %define branch master
 Summary:        Dashboard for CaasP
@@ -35,6 +35,8 @@
 
 Patch0:         0_set_default_salt_events_alter_time_column_value.rpm.patch
 
+Patch1:         1_nodev.gem.patch
+
 %define velumdir /srv/velum
 
 Requires:       ruby >= 2.1
@@ -54,129 +56,11 @@
 BuildRequires:  %{rubydevel}
 BuildRequires:  %{rubygem bundler} >= 1.3.0
 BuildRequires:  %{rubygem gem2rpm}
+BuildRequires:  ruby-common-rails
 
-BuildRequires:  %{rubygem rake = 12.2.1}
-
-BuildRequires:  %{rubygem concurrent-ruby = 1.0.5}
-
-BuildRequires:  %{rubygem i18n = 0.9.1}
-
-BuildRequires:  %{rubygem minitest = 5.11.1}
-
-BuildRequires:  %{rubygem thread_safe = 0.3.6}
-
-BuildRequires:  %{rubygem tzinfo = 1.2.4}
-
-BuildRequires:  %{rubygem activesupport = 4.2.10}
-
-BuildRequires:  %{rubygem builder = 3.2.3}
-
-BuildRequires:  %{rubygem erubis = 2.7.0}
-
-BuildRequires:  %{rubygem mini_portile2 = 2.3.0}
-
-BuildRequires:  %{rubygem nokogiri = 1.8.1}
+# fixed gem dependent build requires
 BuildRequires:  libxml2-devel
 BuildRequires:  libxslt-devel
-
-BuildRequires:  %{rubygem rails-deprecated_sanitizer = 1.0.3}
-
-BuildRequires:  %{rubygem rails-dom-testing = 1.0.9}
-
-BuildRequires:  %{rubygem crass = 1.0.3}
-
-BuildRequires:  %{rubygem loofah = 2.1.1}
-
-BuildRequires:  %{rubygem rails-html-sanitizer = 1.0.3}
-
-BuildRequires:  %{rubygem actionview = 4.2.10}
-
-BuildRequires:  %{rubygem rack = 1.6.8}
-
-BuildRequires:  %{rubygem rack-test = 0.6.3}
-
-BuildRequires:  %{rubygem actionpack = 4.2.10}
-
-BuildRequires:  %{rubygem globalid = 0.4.1}
-
-BuildRequires:  %{rubygem activejob = 4.2.10}
-
-BuildRequires:  %{rubygem mini_mime = 1.0.0}
-
-BuildRequires:  %{rubygem mail = 2.7.0}
-
-BuildRequires:  %{rubygem actionmailer = 4.2.10}
-
-BuildRequires:  %{rubygem activemodel = 4.2.10}
-
-BuildRequires:  %{rubygem arel = 6.0.4}
-
-BuildRequires:  %{rubygem activerecord = 4.2.10}
-
-BuildRequires:  %{rubygem public_suffix = 3.0.1}
-
-BuildRequires:  %{rubygem addressable = 2.5.2}
-
-BuildRequires:  %{rubygem attr_required = 1.0.1}
-
-BuildRequires:  %{rubygem execjs = 2.7.0}
-
-BuildRequires:  %{rubygem autoprefixer-rails = 7.2.3}
-
-BuildRequires:  %{rubygem bcrypt = 3.1.11}
-
-BuildRequires:  %{rubygem bindata = 2.4.1}
-
-BuildRequires:  %{rubygem rb-fsevent = 0.10.2}
-
-BuildRequires:  %{rubygem ffi = 1.9.18}
-BuildRequires:  libffi-devel
-
-BuildRequires:  %{rubygem rb-inotify = 0.9.10}
-
-BuildRequires:  %{rubygem sass-listen = 4.0.0}
-
-BuildRequires:  %{rubygem sass = 3.5.3}
-
-BuildRequires:  %{rubygem bootstrap-sass = 3.3.7}
-
-BuildRequires:  %{rubygem orm_adapter = 0.5.0}
-
-BuildRequires:  %{rubygem thor = 0.20.0}
-
-BuildRequires:  %{rubygem railties = 4.2.10}
-
-BuildRequires:  %{rubygem responders = 2.4.0}
-
-BuildRequires:  %{rubygem warden = 1.2.7}
-
-BuildRequires:  %{rubygem devise = 4.4.0}
-
-BuildRequires:  %{rubygem net-ldap = 0.11}
-
-BuildRequires:  %{rubygem devise_ldap_authenticatable = 0.8.5}
-
-BuildRequires:  %{rubygem font-awesome-rails = 4.7.0.3}
-
-BuildRequires:  %{rubygem gravatar_image_tag = 1.2.0}
-
-BuildRequires:  %{rubygem httpclient = 2.8.3}
-
-BuildRequires:  %{rubygem multi_json = 1.12.2}
-
-BuildRequires:  %{rubygem jbuilder = 2.7.0}
-
-BuildRequires:  %{rubygem jquery-rails = 4.3.1}
-
-BuildRequires:  %{rubygem json = 2.1.0}
-
-BuildRequires:  %{rubygem securecompare = 1.0.0}
-
-BuildRequires:  %{rubygem url_safe_base64 = 0.2.2}
-
-BuildRequires:  %{rubygem json-jwt = 1.8.3}
-
-BuildRequires:  %{rubygem mysql2 = 0.4.10}
 %if 0%{?suse_version} > 1500
 BuildRequires:  libmariadb-devel
 Requires:       mariadb-client
@@ -185,52 +69,45 @@
 Requires:       libmysqlclient18 < 10.1
 %endif
 Recommends:     mariadb
+BuildRequires:  libffi-devel
 
-BuildRequires:  %{rubygem rack-oauth2 = 1.6.4}
-
-BuildRequires:  %{rubygem swd = 1.0.1}
-
-BuildRequires:  %{rubygem validate_email = 0.1.6}
-
-BuildRequires:  %{rubygem validate_url = 1.0.2}
-
-BuildRequires:  %{rubygem webfinger = 1.0.2}
-
-BuildRequires:  %{rubygem openid_connect = 1.1.3}
-
-BuildRequires:  %{rubygem puma = 3.11.0}
-
-BuildRequires:  %{rubygem sprockets = 3.7.1}
-
-BuildRequires:  %{rubygem sprockets-rails = 3.2.1}
-
-BuildRequires:  %{rubygem rails = 4.2.10}
-
-BuildRequires:  %{rubygem rails_stdout_logging = 0.0.5}
-
-BuildRequires:  %{rubygem tilt = 2.0.8}
-
-BuildRequires:  %{rubygem sass-rails = 5.0.7}
-
-BuildRequires:  %{rubygem temple = 0.8.0}
-
-BuildRequires:  %{rubygem slim = 3.0.9}
-
-BuildRequires:  %{rubygem uglifier = 4.1.5}
+BuildRequires:  %{rubygem bcrypt:3.1 >= 3.1.7}
+BuildRequires:  %{rubygem bootstrap-sass:3.3 >= 3.3.7}
+BuildRequires:  %{rubygem devise >= 4.3}
+BuildRequires:  %{rubygem devise_ldap_authenticatable:0 >= 0.8}
+BuildRequires:  %{rubygem font-awesome-rails:4 >= 4.7}
+BuildRequires:  %{rubygem gravatar_image_tag:1.2 >= 1.2.0}
+BuildRequires:  %{rubygem jbuilder:2 >= 2.5}
+BuildRequires:  %{rubygem jquery-rails:4 >= 4.3}
+BuildRequires:  %{rubygem minitest:5 >= 5.10}
+BuildRequires:  %{rubygem mysql2:0.4 >= 0.4.10}
+BuildRequires:  %{rubygem net-ldap:0 >= 0.11}
+BuildRequires:  %{rubygem openid_connect:1 >= 1.1}
+BuildRequires:  %{rubygem puma:3 >= 3.11}
+BuildRequires:  %{rubygem rails:4.2 >= 4.2.10}
+BuildRequires:  %{rubygem rails_stdout_logging:0.0 >= 0.0.5}
+BuildRequires:  %{rubygem rake:12 >= 12.2}
+BuildRequires:  %{rubygem sass-rails:5 >= 5.0}
+BuildRequires:  %{rubygem slim:3 >= 3.0}
+BuildRequires:  %{rubygem uglifier:4 >= 4.1}
 
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 
 %description
 velum is the dashboard for CaasP to manage and deploy kubernetes clusters on 
top of MicroOS
 
-This package has been built with commit 
b8e974fd577e29eb7be871a0cbb661bacb511dc7 from branch master on date Thu, 01 Feb 
2018 15:53:20 +0000
+This package has been built with commit 
348aa62ece758fd9933ade7f585ec04e8d8d32a4 from branch master on date Fri, 02 Feb 
2018 11:59:01 +0000
 
 %prep
 %setup -q -n velum-%{branch}
+%rails_save_gemfile
 
 %patch0 -p1
 
+%patch1 -p1
+
 %build
+%rails_regen_gemfile_lock
 
 install -d vendor/cache
 cp %{_libdir}/ruby/gems/%{rb_ver}/cache/*.gem vendor/cache

++++++ 1_nodev.gem.patch ++++++
diff --git a/Gemfile b/Gemfile
index cba1400..1d0c8d3 100644
--- a/Gemfile
+++ b/Gemfile
@@ -32,26 +32,26 @@ group :assets do
   gem "uglifier", "~> 4.1"
 end
 
-group :development, :test do
-  gem "rspec-rails"
-  gem "rubocop", "~> 0.51", require: false
-  gem "brakeman", require: false
-  gem "database_cleaner"
-  gem "pry"
-  gem "pry-nav"
-end
-
-group :test do
-  gem "shoulda"
-  gem "vcr"
-  gem "webmock", require: false
-  gem "simplecov", require: false
-  gem "capybara", "~> 2.14.3"
-  gem "poltergeist", "~> 1.15.0", require: false
-  gem "json-schema"
-  gem "timecop"
-  gem "codeclimate-test-reporter", "~> 1.0.0", require: nil
-  gem "factory_girl_rails"
-  gem "ffaker"
-  gem "rubocop-rspec"
-end
+#group :development, :test do
+#  gem "rspec-rails"
+#  gem "rubocop", "~> 0.51", require: false
+#  gem "brakeman", require: false
+#  gem "database_cleaner"
+#  gem "pry"
+#  gem "pry-nav"
+#end
+#
+#group :test do
+#  gem "shoulda"
+#  gem "vcr"
+#  gem "webmock", require: false
+#  gem "simplecov", require: false
+#  gem "capybara", "~> 2.14.3"
+#  gem "poltergeist", "~> 1.15.0", require: false
+#  gem "json-schema"
+#  gem "timecop"
+#  gem "codeclimate-test-reporter", "~> 1.0.0", require: nil
+#  gem "factory_girl_rails"
+#  gem "ffaker"
+#  gem "rubocop-rspec"
+#end
++++++ master.tar.gz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/Gemfile new/velum-master/Gemfile
--- old/velum-master/Gemfile    2018-02-01 16:54:49.000000000 +0100
+++ new/velum-master/Gemfile    2018-02-02 13:00:11.000000000 +0100
@@ -1,33 +1,35 @@
 source "https://rubygems.org";
 
-gem "puma"
-gem "rails", "4.2.10"
+gem "puma", "~> 3.11"
+gem "rails", "~> 4.2.10"
+
+gem "rake", "~> 12.2"
+gem "minitest", "~> 5.10"
 
 gem "jbuilder", "~> 2.5"
-gem "jquery-rails"
-gem "slim"
-gem "font-awesome-rails"
+gem "jquery-rails", "~> 4.3"
+gem "slim", "~> 3.0"
+gem "font-awesome-rails", "~> 4.7"
 
 # NOTE: this is no longer needed in Rails 5. See
 # https://github.com/heroku/rails_stdout_logging#rails-5 for instructions on 
how
 # to transition.
-gem "rails_stdout_logging", group: [:development, :staging, :production]
+gem "rails_stdout_logging", "~> 0.0.5", group: [:development, :staging, 
:production]
 
 gem "bcrypt", "~> 3.1.7"
-gem "mysql2"
+gem "mysql2", "~> 0.4.10"
 
-gem "gravatar_image_tag"
-gem "devise"
-gem "devise_ldap_authenticatable"
-gem "net-ldap", require: "net/ldap"
+gem "gravatar_image_tag", "~> 1.2.0"
+gem "devise", ">= 4.3"
+gem "devise_ldap_authenticatable", "~> 0.8"
+gem "net-ldap", "~> 0.11", require: "net/ldap"
 
-gem "openid_connect"
-gem "rake", "12.2.1"
+gem "openid_connect", "~> 1.1"
 
 group :assets do
   gem "sass-rails", "~> 5.0"
-  gem "bootstrap-sass"
-  gem "uglifier", ">= 1.3.0"
+  gem "bootstrap-sass", "~> 3.3.7"
+  gem "uglifier", "~> 4.1"
 end
 
 group :development, :test do
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/Gemfile.lock 
new/velum-master/Gemfile.lock
--- old/velum-master/Gemfile.lock       2018-02-01 16:54:49.000000000 +0100
+++ new/velum-master/Gemfile.lock       2018-02-02 13:00:11.000000000 +0100
@@ -190,7 +190,7 @@
       thor (>= 0.18.1, < 2.0)
     rainbow (2.2.2)
       rake
-    rake (12.2.1)
+    rake (12.3.0)
     rb-fsevent (0.10.2)
     rb-inotify (0.9.10)
       ffi (>= 0.5.0, < 2)
@@ -304,39 +304,40 @@
 
 DEPENDENCIES
   bcrypt (~> 3.1.7)
-  bootstrap-sass
+  bootstrap-sass (~> 3.3.7)
   brakeman
   capybara (~> 2.14.3)
   codeclimate-test-reporter (~> 1.0.0)
   database_cleaner
-  devise
-  devise_ldap_authenticatable
+  devise (>= 4.3)
+  devise_ldap_authenticatable (~> 0.8)
   factory_girl_rails
   ffaker
-  font-awesome-rails
-  gravatar_image_tag
+  font-awesome-rails (~> 4.7)
+  gravatar_image_tag (~> 1.2.0)
   jbuilder (~> 2.5)
-  jquery-rails
+  jquery-rails (~> 4.3)
   json-schema
-  mysql2
-  net-ldap
-  openid_connect
+  minitest (~> 5.10)
+  mysql2 (~> 0.4.10)
+  net-ldap (~> 0.11)
+  openid_connect (~> 1.1)
   poltergeist (~> 1.15.0)
   pry
   pry-nav
-  puma
-  rails (= 4.2.10)
-  rails_stdout_logging
-  rake (= 12.2.1)
+  puma (~> 3.11)
+  rails (~> 4.2.10)
+  rails_stdout_logging (~> 0.0.5)
+  rake (~> 12.2)
   rspec-rails
   rubocop (~> 0.51)
   rubocop-rspec
   sass-rails (~> 5.0)
   shoulda
   simplecov
-  slim
+  slim (~> 3.0)
   timecop
-  uglifier (>= 1.3.0)
+  uglifier (~> 4.1)
   vcr
   webmock
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/packaging/suse/bundler-dumpdeps 
new/velum-master/packaging/suse/bundler-dumpdeps
--- old/velum-master/packaging/suse/bundler-dumpdeps    1970-01-01 
01:00:00.000000000 +0100
+++ new/velum-master/packaging/suse/bundler-dumpdeps    2018-02-02 
13:00:11.000000000 +0100
@@ -0,0 +1,42 @@
+#!/usr/bin/ruby
+# rubocop:disable all
+# vim: set sw=2 sts=2 et tw=80 :
+require 'bundler'
+
+def expand_pessimistic(version)
+  splitted = version.to_s.split('.')
+  sub_version = splitted.slice(0,(splitted.length-1)).join('.')
+  ":#{sub_version} >= #{version}"
+end
+
+def rpmify(op, version)
+  case op
+    when '~>'
+      return expand_pessimistic(version)
+    when '>='
+      if version != Gem::Version.new(0)
+        return " #{op} #{version}"
+      end
+    when '!='
+      return " > #{version}"
+    when '='
+      return " #{op} #{version}"
+    else
+      STDERR.puts "Unknown operator '#{op}' called with version '#{version}'"
+      exit 1
+  end
+end
+#
+# TODO: have a commaldine option to specify those.
+# e.g. in mastodon you also want to skip the no_docker and heroku group
+#
+bad_groups = [:test, :development]
+bd=Bundler::Dsl.evaluate('Gemfile', 'Gemfile.lock', {})
+bd.dependencies.each do |dep|
+  next if (dep.groups - bad_groups).empty?
+  dep.requirement.requirements.each do |req|
+    req_str = rpmify(*req)
+    puts "BuildRequires:  %{rubygem #{dep.name}#{req_str}}"
+  end
+end
+# rubocop:enable all
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/packaging/suse/make_spec.sh 
new/velum-master/packaging/suse/make_spec.sh
--- old/velum-master/packaging/suse/make_spec.sh        2018-02-01 
16:54:49.000000000 +0100
+++ new/velum-master/packaging/suse/make_spec.sh        2018-02-02 
13:00:11.000000000 +0100
@@ -37,19 +37,6 @@
 # clean
 [ ! -d build ] || rm -rf build
 
-additional_native_build_requirements() {
-  if [ $1 == "nokogiri" ];then
-    echo "BuildRequires: libxml2-devel libxslt-devel\n"
-  elif [ $1 == "mysql2" ];then
-    # if Tumbleweed
-    echo "%if 0%{?suse_version} > 1500\nBuildRequires: 
libmariadb-devel\nRequires: mariadb-client\n%else\nBuildRequires: 
libmysqlclient-devel < 10.1\nRequires: libmysqlclient18 < 
10.1\n%endif\nRecommends: mariadb\n"
-  elif [ $1 == "ethon" ];then
-    echo "BuildRequires: libcurl-devel\nRequires: libcurl4\n"
-  elif [ $1 == "ffi" ];then
-    echo "BuildRequires: libffi-devel\n"
-  fi
-}
-
 mkdir -p build/$packagename-$safe_branch
 cp -v ../../Gemfile* build/$packagename-$safe_branch
 cp -v patches/*.patch build/$packagename-$safe_branch
@@ -78,14 +65,15 @@
     diff Gemfile.lock Gemfile.lock.orig
     exit -1
   fi
-  extracted_requires=$(ruby -rbundler -e 
'Bundler.definition.specs_for([:default, :production, :assets]).any? { |s| puts 
"BuildRequires:  %{rubygem #{s.name} = #{s.version}}" unless s.name == 
"bundler" }')
-  echo "get requirements from Gemfile.lock"
+
+  echo "get requirements from bundler"
+  extracted_requires=$(../../bundler-dumpdeps)
+
   IFS=$'\n' # do not split on spaces
   build_requires=""
   for build_require in $extracted_requires; do
-    gem_name=$(echo $build_require | cut -d" " -f4)
+    gem_name=$(echo $build_require | cut -d" " -f4 | sed 's/}//g' | sed 
's/:.*//g')
     build_requires="$build_requires\n$build_require"
-    build_requires="$build_requires\n$(additional_native_build_requirements 
$gem_name)"
   done
 popd
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/velum-master/packaging/suse/patches/1_nodev.gem.patch 
new/velum-master/packaging/suse/patches/1_nodev.gem.patch
--- old/velum-master/packaging/suse/patches/1_nodev.gem.patch   1970-01-01 
01:00:00.000000000 +0100
+++ new/velum-master/packaging/suse/patches/1_nodev.gem.patch   2018-02-02 
13:00:11.000000000 +0100
@@ -0,0 +1,54 @@
+diff --git a/Gemfile b/Gemfile
+index cba1400..1d0c8d3 100644
+--- a/Gemfile
++++ b/Gemfile
+@@ -32,26 +32,26 @@ group :assets do
+   gem "uglifier", "~> 4.1"
+ end
+ 
+-group :development, :test do
+-  gem "rspec-rails"
+-  gem "rubocop", "~> 0.51", require: false
+-  gem "brakeman", require: false
+-  gem "database_cleaner"
+-  gem "pry"
+-  gem "pry-nav"
+-end
+-
+-group :test do
+-  gem "shoulda"
+-  gem "vcr"
+-  gem "webmock", require: false
+-  gem "simplecov", require: false
+-  gem "capybara", "~> 2.14.3"
+-  gem "poltergeist", "~> 1.15.0", require: false
+-  gem "json-schema"
+-  gem "timecop"
+-  gem "codeclimate-test-reporter", "~> 1.0.0", require: nil
+-  gem "factory_girl_rails"
+-  gem "ffaker"
+-  gem "rubocop-rspec"
+-end
++#group :development, :test do
++#  gem "rspec-rails"
++#  gem "rubocop", "~> 0.51", require: false
++#  gem "brakeman", require: false
++#  gem "database_cleaner"
++#  gem "pry"
++#  gem "pry-nav"
++#end
++#
++#group :test do
++#  gem "shoulda"
++#  gem "vcr"
++#  gem "webmock", require: false
++#  gem "simplecov", require: false
++#  gem "capybara", "~> 2.14.3"
++#  gem "poltergeist", "~> 1.15.0", require: false
++#  gem "json-schema"
++#  gem "timecop"
++#  gem "codeclimate-test-reporter", "~> 1.0.0", require: nil
++#  gem "factory_girl_rails"
++#  gem "ffaker"
++#  gem "rubocop-rspec"
++#end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/velum-master/packaging/suse/velum.spec.in 
new/velum-master/packaging/suse/velum.spec.in
--- old/velum-master/packaging/suse/velum.spec.in       2018-02-01 
16:54:49.000000000 +0100
+++ new/velum-master/packaging/suse/velum.spec.in       2018-02-02 
13:00:11.000000000 +0100
@@ -49,10 +49,23 @@
 BuildRequires:  nodejs
 
 %define rb_build_versions %{rb_default_ruby}
+BuildRequires:  ruby-common-rails
 BuildRequires:  %{rubydevel}
 BuildRequires:  %{rubygem gem2rpm}
 BuildRequires:  %{rubygem bundler} >= 1.3.0
 
+# fixed gem dependent build requires
+BuildRequires: libxml2-devel libxslt-devel
+%if 0%{?suse_version} > 1500
+BuildRequires: libmariadb-devel
+Requires: mariadb-client
+%else
+BuildRequires: libmysqlclient-devel < 10.1
+Requires: libmysqlclient18 < 10.1
+%endif
+Recommends: mariadb
+BuildRequires: libffi-devel
+
 __RUBYGEMS_BUILD_REQUIRES__
 
 
@@ -65,9 +78,11 @@
 
 %prep
 %setup -q -n velum-%{branch}
+%rails_save_gemfile
 __PATCHEXECS__
 
 %build
+%rails_regen_gemfile_lock
 
 install -d vendor/cache
 cp %{_libdir}/ruby/gems/%{rb_ver}/cache/*.gem vendor/cache


Reply via email to