Hello community,

here is the log from the commit of package python-osc-lib for openSUSE:Factory 
checked in at 2018-02-14 10:50:46
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-osc-lib (Old)
 and      /work/SRC/openSUSE:Factory/.python-osc-lib.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-osc-lib"

Wed Feb 14 10:50:46 2018 rev:5 rq:575944 version:1.9.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/python-osc-lib/python-osc-lib.changes    
2018-01-17 21:56:31.540233488 +0100
+++ /work/SRC/openSUSE:Factory/.python-osc-lib.new/python-osc-lib.changes       
2018-02-14 10:50:47.627472252 +0100
@@ -1,0 +2,30 @@
+Mon Feb 12 10:03:38 UTC 2018 - cloud-de...@suse.de
+
+- update to version 1.9.0 (bsc#1078607)
+  - Updated from global requirements
+  - Fix find() interface when attr is not specified
+  - Fix sorting in Python 3
+  - Relocate utils tests to match the main code
+
+-------------------------------------------------------------------
+Tue Jan 30 15:13:22 UTC 2018 - cloud-de...@suse.de
+
+- update to version 1.8.0
+  - Emit warnings to encourage cliff FormattableColumn
+  - Remove -U from pip install
+  - Add CLI/ENV options and documentation for keystone-to-keystone
+  - --os-profile option suddenly causes trouble in unit tests
+  - Update reno for stable/pike
+  - Remove setting of version/release from releasenotes
+  - Use converged SDK insead of os-client-config
+  - Migrade legacy jobs into the repo
+  - Make -tips job non-voting
+  - Update the documentation link for doc migration
+  - Util to calculate header and attr names based on parsed_args.columns
+  - Updates for stestr
+  - Consume the devstack functional jobs from OSC
+  - Updated from global requirements
+  - Add utils for better column handling
+  - Avoid tox_install.sh for constraints support
+
+-------------------------------------------------------------------

Old:
----
  osc-lib-1.7.0.tar.gz

New:
----
  osc-lib-1.9.0.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-osc-lib.spec ++++++
--- /var/tmp/diff_new_pack.mHUYwb/_old  2018-02-14 10:50:48.239450228 +0100
+++ /var/tmp/diff_new_pack.mHUYwb/_new  2018-02-14 10:50:48.243450084 +0100
@@ -17,25 +17,26 @@
 
 
 Name:           python-osc-lib
-Version:        1.7.0
+Version:        1.9.0
 Release:        0
 Summary:        OpenStackClient Library
 License:        Apache-2.0
 Group:          Development/Languages/Python
 Url:            http://docs.openstack.org/developer/osc-lib
-Source0:        
https://files.pythonhosted.org/packages/source/o/osc-lib/osc-lib-1.7.0.tar.gz
+Source0:        
https://files.pythonhosted.org/packages/source/o/osc-lib/osc-lib-1.9.0.tar.gz
 BuildRequires:  openstack-macros
 BuildRequires:  python-devel
 BuildRequires:  python2-Babel >= 2.3.4
 BuildRequires:  python2-cliff >= 2.8.0
 BuildRequires:  python2-fixtures >= 3.0.0
-BuildRequires:  python2-keystoneauth1 >= 3.2.0
+BuildRequires:  python2-keystoneauth1 >= 3.3.0
 BuildRequires:  python2-mock >= 2.0.0
+BuildRequires:  python2-openstacksdk >= 0.9.19
 BuildRequires:  python2-os-client-config >= 1.28.0
 BuildRequires:  python2-os-testr >= 1.0.0
 BuildRequires:  python2-oslo.i18n >= 3.15.3
-BuildRequires:  python2-oslo.utils >= 3.31.0
-BuildRequires:  python2-oslotest >= 1.10.0
+BuildRequires:  python2-oslo.utils >= 3.33.0
+BuildRequires:  python2-oslotest >= 3.2.0
 BuildRequires:  python2-osprofiler >= 1.4.0
 BuildRequires:  python2-pbr >= 2.0.0
 BuildRequires:  python2-reno >= 2.5.0
@@ -49,13 +50,14 @@
 BuildRequires:  python3-cliff >= 2.8.0
 BuildRequires:  python3-devel
 BuildRequires:  python3-fixtures >= 3.0.0
-BuildRequires:  python3-keystoneauth1 >= 3.2.0
+BuildRequires:  python3-keystoneauth1 >= 3.3.0
 BuildRequires:  python3-mock >= 2.0.0
+BuildRequires:  python3-openstacksdk >= 0.9.19
 BuildRequires:  python3-os-client-config >= 1.28.0
 BuildRequires:  python3-os-testr >= 1.0.0
 BuildRequires:  python3-oslo.i18n >= 3.15.3
-BuildRequires:  python3-oslo.utils >= 3.31.0
-BuildRequires:  python3-oslotest >= 1.10.0
+BuildRequires:  python3-oslo.utils >= 3.33.0
+BuildRequires:  python3-oslotest >= 3.2.0
 BuildRequires:  python3-osprofiler >= 1.4.0
 BuildRequires:  python3-pbr >= 2.0.0
 BuildRequires:  python3-reno >= 2.5.0
@@ -67,10 +69,11 @@
 BuildRequires:  python3-testtools >= 2.2.0
 Requires:       python-Babel >= 2.3.4
 Requires:       python-cliff >= 2.8.0
-Requires:       python-keystoneauth1 >= 3.2.0
+Requires:       python-keystoneauth1 >= 3.3.0
+Requires:       python-openstacksdk >= 0.9.19
 Requires:       python-os-client-config >= 1.28.0
 Requires:       python-oslo.i18n >= 3.15.3
-Requires:       python-oslo.utils >= 3.31.0
+Requires:       python-oslo.utils >= 3.33.0
 Requires:       python-pbr >= 2.0.0
 Requires:       python-simplejson >= 3.5.1
 Requires:       python-six >= 1.10.0
@@ -92,7 +95,7 @@
 Documentation for the OpenStack client library.
 
 %prep
-%autosetup -p1 -n osc-lib-1.7.0
+%autosetup -p1 -n osc-lib-1.9.0
 %py_req_cleanup
 sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
 

++++++ osc-lib-1.7.0.tar.gz -> osc-lib-1.9.0.tar.gz ++++++
++++ 4596 lines of diff (skipped)


Reply via email to