Hello community,

here is the log from the commit of package python-oslo.middleware for 
openSUSE:Factory checked in at 2018-02-14 10:50:50
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/python-oslo.middleware (Old)
 and      /work/SRC/openSUSE:Factory/.python-oslo.middleware.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "python-oslo.middleware"

Wed Feb 14 10:50:50 2018 rev:9 rq:575946 version:3.34.0

Changes:
--------
--- 
/work/SRC/openSUSE:Factory/python-oslo.middleware/python-oslo.middleware.changes
    2018-01-24 15:27:50.929814298 +0100
+++ 
/work/SRC/openSUSE:Factory/.python-oslo.middleware.new/python-oslo.middleware.changes
       2018-02-14 10:50:51.571330320 +0100
@@ -1,0 +2,8 @@
+Tue Jan 30 15:14:33 UTC 2018 - cloud-de...@suse.de
+
+- update to version 3.34.0
+  - Updated from global requirements
+  - Avoid tox_install.sh for constraints support
+  - add bandit to pep8 job
+
+-------------------------------------------------------------------

Old:
----
  oslo.middleware-3.33.0.tar.gz

New:
----
  oslo.middleware-3.34.0.tar.gz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ python-oslo.middleware.spec ++++++
--- /var/tmp/diff_new_pack.kxWf8p/_old  2018-02-14 10:50:52.087311751 +0100
+++ /var/tmp/diff_new_pack.kxWf8p/_new  2018-02-14 10:50:52.091311607 +0100
@@ -17,13 +17,13 @@
 
 
 Name:           python-oslo.middleware
-Version:        3.33.0
+Version:        3.34.0
 Release:        0
 Summary:        OpenStack oslo.middleware library
 License:        Apache-2.0
 Group:          Development/Languages/Python
 Url:            https://launchpad.net/oslo.middleware
-Source0:        
https://files.pythonhosted.org/packages/source/o/oslo.middleware/oslo.middleware-3.33.0.tar.gz
+Source0:        
https://files.pythonhosted.org/packages/source/o/oslo.middleware/oslo.middleware-3.34.0.tar.gz
 BuildRequires:  openstack-macros
 BuildRequires:  python-Jinja2 >= 2.8
 BuildRequires:  python-WebOb >= 1.7.1
@@ -76,7 +76,7 @@
 This package contains the documentation.
 
 %prep
-%autosetup -p1 -n oslo.middleware-3.33.0
+%autosetup -p1 -n oslo.middleware-3.34.0
 %py_req_cleanup
 sed -i 's/^warning-is-error.*/warning-is-error = 0/g' setup.cfg
 

++++++ oslo.middleware-3.33.0.tar.gz -> oslo.middleware-3.34.0.tar.gz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/ChangeLog 
new/oslo.middleware-3.34.0/ChangeLog
--- old/oslo.middleware-3.33.0/ChangeLog        2017-12-04 11:35:25.000000000 
+0100
+++ new/oslo.middleware-3.34.0/ChangeLog        2018-01-15 21:28:51.000000000 
+0100
@@ -1,6 +1,13 @@
 CHANGES
 =======
 
+3.34.0
+------
+
+* Avoid tox\_install.sh for constraints support
+* Updated from global requirements
+* add bandit to pep8 job
+
 3.33.0
 ------
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/PKG-INFO 
new/oslo.middleware-3.34.0/PKG-INFO
--- old/oslo.middleware-3.33.0/PKG-INFO 2017-12-04 11:35:25.000000000 +0100
+++ new/oslo.middleware-3.34.0/PKG-INFO 2018-01-15 21:28:52.000000000 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: oslo.middleware
-Version: 3.33.0
+Version: 3.34.0
 Summary: Oslo Middleware library
 Home-page: https://docs.openstack.org/oslo.middleware/latest/
 Author: OpenStack
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.middleware-3.33.0/oslo.middleware.egg-info/PKG-INFO 
new/oslo.middleware-3.34.0/oslo.middleware.egg-info/PKG-INFO
--- old/oslo.middleware-3.33.0/oslo.middleware.egg-info/PKG-INFO        
2017-12-04 11:35:25.000000000 +0100
+++ new/oslo.middleware-3.34.0/oslo.middleware.egg-info/PKG-INFO        
2018-01-15 21:28:51.000000000 +0100
@@ -1,6 +1,6 @@
 Metadata-Version: 1.1
 Name: oslo.middleware
-Version: 3.33.0
+Version: 3.34.0
 Summary: Oslo Middleware library
 Home-page: https://docs.openstack.org/oslo.middleware/latest/
 Author: OpenStack
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.middleware-3.33.0/oslo.middleware.egg-info/SOURCES.txt 
new/oslo.middleware-3.34.0/oslo.middleware.egg-info/SOURCES.txt
--- old/oslo.middleware-3.33.0/oslo.middleware.egg-info/SOURCES.txt     
2017-12-04 11:35:25.000000000 +0100
+++ new/oslo.middleware-3.34.0/oslo.middleware.egg-info/SOURCES.txt     
2018-01-15 21:28:52.000000000 +0100
@@ -82,5 +82,4 @@
 releasenotes/source/_static/.placeholder
 releasenotes/source/_templates/.placeholder
 releasenotes/source/locale/en_GB/LC_MESSAGES/releasenotes.po
-releasenotes/source/locale/fr/LC_MESSAGES/releasenotes.po
-tools/tox_install.sh
\ No newline at end of file
+releasenotes/source/locale/fr/LC_MESSAGES/releasenotes.po
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.middleware-3.33.0/oslo.middleware.egg-info/pbr.json 
new/oslo.middleware-3.34.0/oslo.middleware.egg-info/pbr.json
--- old/oslo.middleware-3.33.0/oslo.middleware.egg-info/pbr.json        
2017-12-04 11:35:25.000000000 +0100
+++ new/oslo.middleware-3.34.0/oslo.middleware.egg-info/pbr.json        
2018-01-15 21:28:51.000000000 +0100
@@ -1 +1 @@
-{"git_version": "9d75e6c", "is_release": true}
\ No newline at end of file
+{"git_version": "abfd726", "is_release": true}
\ No newline at end of file
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' 
old/oslo.middleware-3.33.0/oslo.middleware.egg-info/requires.txt 
new/oslo.middleware-3.34.0/oslo.middleware.egg-info/requires.txt
--- old/oslo.middleware-3.33.0/oslo.middleware.egg-info/requires.txt    
2017-12-04 11:35:25.000000000 +0100
+++ new/oslo.middleware-3.34.0/oslo.middleware.egg-info/requires.txt    
2018-01-15 21:28:51.000000000 +0100
@@ -3,7 +3,7 @@
 oslo.config>=5.1.0
 oslo.context>=2.19.2
 oslo.i18n>=3.15.3
-oslo.utils>=3.31.0
+oslo.utils>=3.33.0
 six>=1.10.0
 stevedore>=1.20.0
 WebOb>=1.7.1
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/requirements.txt 
new/oslo.middleware-3.34.0/requirements.txt
--- old/oslo.middleware-3.33.0/requirements.txt 2017-12-04 11:32:38.000000000 
+0100
+++ new/oslo.middleware-3.34.0/requirements.txt 2018-01-15 21:25:55.000000000 
+0100
@@ -7,7 +7,7 @@
 oslo.config>=5.1.0 # Apache-2.0
 oslo.context>=2.19.2 # Apache-2.0
 oslo.i18n>=3.15.3 # Apache-2.0
-oslo.utils>=3.31.0 # Apache-2.0
+oslo.utils>=3.33.0 # Apache-2.0
 six>=1.10.0 # MIT
 stevedore>=1.20.0 # Apache-2.0
 WebOb>=1.7.1 # MIT
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/test-requirements.txt 
new/oslo.middleware-3.34.0/test-requirements.txt
--- old/oslo.middleware-3.33.0/test-requirements.txt    2017-12-04 
11:32:16.000000000 +0100
+++ new/oslo.middleware-3.34.0/test-requirements.txt    2018-01-15 
21:25:55.000000000 +0100
@@ -12,3 +12,5 @@
 coverage!=4.4,>=4.0 # Apache-2.0
 reno>=2.5.0 # Apache-2.0
 oslo.serialization!=2.19.1,>=2.18.0 # Apache-2.0
+# Bandit security code scanner
+bandit>=1.1.0 # Apache-2.0
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/tools/tox_install.sh 
new/oslo.middleware-3.34.0/tools/tox_install.sh
--- old/oslo.middleware-3.33.0/tools/tox_install.sh     2017-12-04 
11:32:16.000000000 +0100
+++ new/oslo.middleware-3.34.0/tools/tox_install.sh     1970-01-01 
01:00:00.000000000 +0100
@@ -1,30 +0,0 @@
-#!/usr/bin/env bash
-
-# Client constraint file contains this client version pin that is in conflict
-# with installing the client from source. We should remove the version pin in
-# the constraints file before applying it for from-source installation.
-
-CONSTRAINTS_FILE="$1"
-shift 1
-
-set -e
-
-# NOTE(tonyb): Place this in the tox enviroment's log dir so it will get
-# published to logs.openstack.org for easy debugging.
-localfile="$VIRTUAL_ENV/log/upper-constraints.txt"
-
-if [[ "$CONSTRAINTS_FILE" != http* ]]; then
-    CONSTRAINTS_FILE="file://$CONSTRAINTS_FILE"
-fi
-# NOTE(tonyb): need to add curl to bindep.txt if the project supports bindep
-curl "$CONSTRAINTS_FILE" --insecure --progress-bar --output "$localfile"
-
-pip install -c"$localfile" openstack-requirements
-
-# This is the main purpose of the script: Allow local installation of
-# the current repo. It is listed in constraints file and thus any
-# install will be constrained and we need to unconstrain it.
-edit-constraints "$localfile" -- "$CLIENT_NAME"
-
-pip install -c"$localfile" -U "$@"
-exit $?
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/oslo.middleware-3.33.0/tox.ini 
new/oslo.middleware-3.34.0/tox.ini
--- old/oslo.middleware-3.33.0/tox.ini  2017-12-04 11:32:16.000000000 +0100
+++ new/oslo.middleware-3.34.0/tox.ini  2018-01-15 21:25:55.000000000 +0100
@@ -5,14 +5,17 @@
 [testenv]
 setenv =
     VIRTUAL_ENV={envdir}
-    BRANCH_NAME=master
-    CLIENT_NAME=oslo.middleware
-install_command = {toxinidir}/tools/tox_install.sh 
{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
 {opts} {packages}
-deps = -r{toxinidir}/test-requirements.txt
+install_command = pip install {opts} {packages}
+deps =
+    
-c{env:UPPER_CONSTRAINTS_FILE:https://git.openstack.org/cgit/openstack/requirements/plain/upper-constraints.txt}
+    -r{toxinidir}/test-requirements.txt
 commands = python setup.py testr --slowest --testr-args='{posargs}'
 
 [testenv:pep8]
-commands = flake8
+commands =
+  flake8
+  # Run security linter
+  bandit -r oslo_middleware -x tests -n5
 
 [testenv:venv]
 commands = {posargs}


Reply via email to