Hello community,

here is the log from the commit of package libunwind for openSUSE:Factory 
checked in at 2018-02-23 15:27:46
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libunwind (Old)
 and      /work/SRC/openSUSE:Factory/.libunwind.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libunwind"

Fri Feb 23 15:27:46 2018 rev:38 rq:577961 version:1.2.1

Changes:
--------
--- /work/SRC/openSUSE:Factory/libunwind/libunwind.changes      2018-02-09 
15:41:40.996021481 +0100
+++ /work/SRC/openSUSE:Factory/.libunwind.new/libunwind.changes 2018-02-23 
15:27:47.666865836 +0100
@@ -1,0 +2,9 @@
+Sun Feb 18 18:29:20 UTC 2018 - roni...@gmail.com
+
+- Add patch `fix_versioning_libunwind_1.2.1.patch`.
+  * This patch fixes the upstream bug gh#libunwind/libunwind#30.
+    This bug was causing the julia build process to fail.
+    NOTE: This patch shall be removed in the next version of
+    libunwind.
+
+-------------------------------------------------------------------

New:
----
  fix_versioning_libunwind_1.2.1.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libunwind.spec ++++++
--- /var/tmp/diff_new_pack.QUpj0Y/_old  2018-02-23 15:27:48.402839248 +0100
+++ /var/tmp/diff_new_pack.QUpj0Y/_new  2018-02-23 15:27:48.406839103 +0100
@@ -28,6 +28,8 @@
 Source1:        
http://download.savannah.gnu.org/releases/%{name}/%{name}-%{realver}.tar.gz.sig
 Source2:        %{name}.keyring
 Source3:        baselibs.conf
+# PATCH-FIX-UPSTREAM fix_versioning_libunwind_1.2.1.patch 
gh#libunwind/libunwind#30 roni...@gmail.com -- libunwind 1.2.1 
UNW_VERSION_MINOR is not an integer.
+Patch0:         fix_versioning_libunwind_1.2.1.patch
 BuildRequires:  gcc-c++
 BuildRequires:  lzma-devel
 BuildRequires:  pkgconfig
@@ -49,6 +51,7 @@
 
 %prep
 %setup -q -n %{name}-%{realver}
+%patch0 -p1
 
 %build
 %configure \

++++++ fix_versioning_libunwind_1.2.1.patch ++++++
Index: libunwind-1.2.1/configure.ac
===================================================================
--- libunwind-1.2.1.orig/configure.ac
+++ libunwind-1.2.1/configure.ac
@@ -1,6 +1,6 @@
 define(pkg_major, 1)
-define(pkg_minor, 2.1)
-define(pkg_extra, )
+define(pkg_minor, 2)
+define(pkg_extra, 1)
 define(pkg_maintainer, libunwind-de...@nongnu.org)
 define(mkvers, $1.$2$3)
 dnl Process this file with autoconf to produce a configure script.
Index: libunwind-1.2.1/configure
===================================================================
--- libunwind-1.2.1.orig/configure
+++ libunwind-1.2.1/configure
@@ -17376,8 +17376,8 @@ arch="$target_arch"
 ARCH=`echo $target_arch | tr a-z A-Z`
 
 PKG_MAJOR=1
-PKG_MINOR=2.1
-PKG_EXTRA=
+PKG_MINOR=2
+PKG_EXTRA=1
 PKG_MAINTAINER=libunwind-de...@nongnu.org
 
 old_LIBS="$LIBS"


Reply via email to