Hello community,

here is the log from the commit of package kst for openSUSE:Factory checked in 
at 2018-02-23 15:31:18
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kst (Old)
 and      /work/SRC/openSUSE:Factory/.kst.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kst"

Fri Feb 23 15:31:18 2018 rev:45 rq:579260 version:2.0.8

Changes:
--------
--- /work/SRC/openSUSE:Factory/kst/kst.changes  2016-08-11 18:53:36.000000000 
+0200
+++ /work/SRC/openSUSE:Factory/.kst.new/kst.changes     2018-02-23 
15:31:32.686736060 +0100
@@ -1,0 +2,5 @@
+Thu Feb 22 08:29:11 UTC 2018 - aloi...@gmx.com
+
+- Switched build to Qt5 for TW and Leap 15
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kst.spec ++++++
--- /var/tmp/diff_new_pack.3dW0g3/_old  2018-02-23 15:31:34.694663512 +0100
+++ /var/tmp/diff_new_pack.3dW0g3/_new  2018-02-23 15:31:34.694663512 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package kst
 #
-# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 # Copyright (c) 2011 Christian Trippe ctri...@opensuse.org
 #
 # All modifications and additions to the file contributed by third parties
@@ -35,14 +35,25 @@
 BuildRequires:  gsl-devel
 BuildRequires:  libcfitsio-devel
 BuildRequires:  libmatio-devel
+BuildRequires:  libnetcdf
 BuildRequires:  libnetcdf_c++-devel
-BuildRequires:  libqt4-devel
 BuildRequires:  netcdf-devel
-BuildRequires:  libnetcdf
 BuildRequires:  readline-devel
 BuildRequires:  update-desktop-files
 Requires:       libnetcdf
 Obsoletes:      python-kst < %{version}
+%if 0%{?suse_version} >= 1500
+BuildRequires:  libqt5-linguist
+BuildRequires:  pkgconfig
+BuildRequires:  pkgconfig(Qt5Concurrent)
+BuildRequires:  pkgconfig(Qt5Core)
+BuildRequires:  pkgconfig(Qt5Network)
+BuildRequires:  pkgconfig(Qt5PrintSupport)
+BuildRequires:  pkgconfig(Qt5Widgets)
+BuildRequires:  pkgconfig(Qt5Xml)
+%else
+BuildRequires:  libqt4-devel
+%endif
 
 %description
 Kst is a data plotting and viewing program. Some of the features include:
@@ -62,7 +73,16 @@
 Summary:        Development files for %{name}
 Group:          Development/Libraries/KDE
 Requires:       %{name} = %{version}
+%if 0%{?suse_version} >= 1500
+Requires:       pkgconfig(Qt5Concurrent)
+Requires:       pkgconfig(Qt5Core)
+Requires:       pkgconfig(Qt5Network)
+Requires:       pkgconfig(Qt5PrintSupport)
+Requires:       pkgconfig(Qt5Widgets)
+Requires:       pkgconfig(Qt5Xml)
+%else
 Requires:       libqt4-devel
+%endif
 
 %description devel
 Development libraries and headers needed to build software
@@ -78,7 +98,12 @@
              -Dkst_install_libdir=%{_lib} \
              -Dkst_release=1 \
              -Dkst_dbgsym=1 \
-             -Dkst_python=0"
+             -Dkst_python=0 \
+%if 0%{?suse_version} >= 1500
+             -Dkst_qt5=1"
+%else
+             -Dkst_qt4=1"
+%endif
 
 cmake $EXTRA_FLAGS
 make %{?_smp_mflags}


Reply via email to