Hello community,

here is the log from the commit of package rubygem-swd for openSUSE:Factory 
checked in at 2018-03-06 10:46:11
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-swd (Old)
 and      /work/SRC/openSUSE:Factory/.rubygem-swd.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-swd"

Tue Mar  6 10:46:11 2018 rev:2 rq:581506 version:1.1.2

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-swd/rubygem-swd.changes  2018-01-10 
23:31:13.319133779 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-swd.new/rubygem-swd.changes     
2018-03-06 10:46:13.922572788 +0100
@@ -1,0 +2,6 @@
+Tue Feb 27 05:36:23 UTC 2018 - factory-a...@kulow.org
+
+- updated to version 1.1.2
+  no changelog found
+
+-------------------------------------------------------------------

Old:
----
  swd-1.0.1.gem

New:
----
  swd-1.1.2.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-swd.spec ++++++
--- /var/tmp/diff_new_pack.tCW3Tg/_old  2018-03-06 10:46:14.658546202 +0100
+++ /var/tmp/diff_new_pack.tCW3Tg/_new  2018-03-06 10:46:14.662546057 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-swd
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -24,14 +24,14 @@
 #
 
 Name:           rubygem-swd
-Version:        1.0.1
+Version:        1.1.2
 Release:        0
 %define mod_name swd
 %define mod_full_name %{mod_name}-%{version}
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  ruby-macros >= 5
-BuildRequires:  %{ruby}
 BuildRequires:  %{rubygem gem2rpm}
+BuildRequires:  %{ruby}
+BuildRequires:  ruby-macros >= 5
 Url:            https://github.com/nov/swd
 Source:         https://rubygems.org/gems/%{mod_full_name}.gem
 Source1:        gem2rpm.yml

++++++ swd-1.0.1.gem -> swd-1.1.2.gem ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/.travis.yml new/.travis.yml
--- old/.travis.yml     2016-01-26 06:30:00.000000000 +0100
+++ new/.travis.yml     2017-12-20 00:27:55.000000000 +0100
@@ -2,7 +2,5 @@
   - gem install bundler
 
 rvm:
-  - 2.0
-  - 2.1
-  - 2.2
-  - 2.3.0
\ No newline at end of file
+  - 2.3.5
+  - 2.4.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/VERSION new/VERSION
--- old/VERSION 2016-01-26 06:30:00.000000000 +0100
+++ new/VERSION 2017-12-20 00:27:55.000000000 +0100
@@ -1 +1 @@
-1.0.1
\ No newline at end of file
+1.1.2
\ No newline at end of file
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/swd/resource.rb new/lib/swd/resource.rb
--- old/lib/swd/resource.rb     2016-01-26 06:30:00.000000000 +0100
+++ new/lib/swd/resource.rb     2017-12-20 00:27:55.000000000 +0100
@@ -71,7 +71,7 @@
     end
 
     def cache_key
-      md5 = Digest::MD5.hexdigest [
+      md5 = OpenSSL::Digest::MD5.hexdigest [
         principal,
         service,
         host
@@ -79,4 +79,4 @@
       "swd:resource:#{md5}"
     end
   end
-end
\ No newline at end of file
+end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/swd.rb new/lib/swd.rb
--- old/lib/swd.rb      2016-01-26 06:30:00.000000000 +0100
+++ new/lib/swd.rb      2017-12-20 00:27:55.000000000 +0100
@@ -1,6 +1,6 @@
-require 'logger'
-require 'digest/md5'
 require 'json'
+require 'logger'
+require 'openssl'
 require 'active_support'
 require 'active_support/core_ext'
 require 'httpclient'
@@ -10,7 +10,7 @@
 module SWD
   VERSION = ::File.read(
     ::File.join(::File.dirname(__FILE__), '../VERSION')
-  )
+  ).strip
 
   def self.cache=(cache)
     @@cache = cache
@@ -76,4 +76,4 @@
 require 'swd/response'
 require 'swd/debugger'
 
-SWD.cache = SWD::Cache.new
\ No newline at end of file
+SWD.cache = SWD::Cache.new
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata        2016-01-26 06:30:00.000000000 +0100
+++ new/metadata        2017-12-20 00:27:55.000000000 +0100
@@ -1,30 +1,16 @@
 --- !ruby/object:Gem::Specification
 name: swd
 version: !ruby/object:Gem::Version
-  version: 1.0.1
+  version: 1.1.2
 platform: ruby
 authors:
 - nov matake
 autorequire: 
 bindir: bin
 cert_chain: []
-date: 2016-01-26 00:00:00.000000000 Z
+date: 2017-12-19 00:00:00.000000000 Z
 dependencies:
 - !ruby/object:Gem::Dependency
-  name: json
-  requirement: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: 1.4.3
-  type: :runtime
-  prerelease: false
-  version_requirements: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: 1.4.3
-- !ruby/object:Gem::Dependency
   name: httpclient
   requirement: !ruby/object:Gem::Requirement
     requirements:
@@ -53,20 +39,6 @@
       - !ruby/object:Gem::Version
         version: '3'
 - !ruby/object:Gem::Dependency
-  name: i18n
-  requirement: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: '0'
-  type: :runtime
-  prerelease: false
-  version_requirements: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: '0'
-- !ruby/object:Gem::Dependency
   name: attr_required
   requirement: !ruby/object:Gem::Requirement
     requirements:
@@ -203,7 +175,7 @@
       version: '0'
 requirements: []
 rubyforge_project: 
-rubygems_version: 2.5.1
+rubygems_version: 2.6.11
 signing_key: 
 specification_version: 4
 summary: SWD (Simple Web Discovery) Client Library
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/swd.gemspec new/swd.gemspec
--- old/swd.gemspec     2016-01-26 06:30:00.000000000 +0100
+++ new/swd.gemspec     2017-12-20 00:27:55.000000000 +0100
@@ -1,23 +1,21 @@
 Gem::Specification.new do |s|
-  s.name        = "swd"
-  s.version     = File.read("VERSION")
-  s.authors     = ["nov matake"]
-  s.email       = ["n...@matake.jp"]
-  s.homepage    = "https://github.com/nov/swd";
+  s.name        = 'swd'
+  s.version     = File.read('VERSION')
+  s.authors     = ['nov matake']
+  s.email       = ['n...@matake.jp']
+  s.homepage    = 'https://github.com/nov/swd'
   s.summary     = %q{SWD (Simple Web Discovery) Client Library}
   s.description = %q{SWD (Simple Web Discovery) Client Library}
   s.files         = `git ls-files`.split("\n")
   s.test_files    = `git ls-files -- {test,spec,features}/*`.split("\n")
   s.executables   = `git ls-files -- bin/*`.split("\n").map{ |f| 
File.basename(f) }
-  s.require_paths = ["lib"]
-  s.add_runtime_dependency "json", ">= 1.4.3"
-  s.add_runtime_dependency "httpclient", ">= 2.4"
-  s.add_runtime_dependency "activesupport", ">= 3"
-  s.add_runtime_dependency "i18n"
-  s.add_runtime_dependency "attr_required", ">= 0.0.5"
-  s.add_development_dependency "rake"
-  s.add_development_dependency "rspec"
+  s.require_paths = ['lib']
+  s.add_runtime_dependency 'httpclient', '>= 2.4'
+  s.add_runtime_dependency 'activesupport', '>= 3'
+  s.add_runtime_dependency 'attr_required', '>= 0.0.5'
+  s.add_development_dependency 'rake'
+  s.add_development_dependency 'rspec'
   s.add_development_dependency 'rspec-its'
-  s.add_development_dependency "webmock"
+  s.add_development_dependency 'webmock'
   s.add_development_dependency 'simplecov'
-end
\ No newline at end of file
+end


Reply via email to