Hello community,

here is the log from the commit of package rubygem-webfinger for 
openSUSE:Factory checked in at 2018-03-06 10:46:30
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-webfinger (Old)
 and      /work/SRC/openSUSE:Factory/.rubygem-webfinger.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-webfinger"

Tue Mar  6 10:46:30 2018 rev:2 rq:581514 version:1.1.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-webfinger/rubygem-webfinger.changes      
2018-01-10 23:31:39.285915135 +0100
+++ /work/SRC/openSUSE:Factory/.rubygem-webfinger.new/rubygem-webfinger.changes 
2018-03-06 10:46:30.857961011 +0100
@@ -1,0 +2,6 @@
+Tue Feb 27 05:40:16 UTC 2018 - factory-a...@kulow.org
+
+- updated to version 1.1.0
+  no changelog found
+
+-------------------------------------------------------------------

Old:
----
  webfinger-1.0.2.gem

New:
----
  gem2rpm.yml
  webfinger-1.1.0.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-webfinger.spec ++++++
--- /var/tmp/diff_new_pack.Mm3tt7/_old  2018-03-06 10:46:31.481938470 +0100
+++ /var/tmp/diff_new_pack.Mm3tt7/_new  2018-03-06 10:46:31.481938470 +0100
@@ -1,7 +1,7 @@
 #
 # spec file for package rubygem-webfinger
 #
-# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
+# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -15,17 +15,26 @@
 # Please submit bugfixes or comments via http://bugs.opensuse.org/
 #
 
+
+#
+# This file was generated with a gem2rpm.yml and not just plain gem2rpm.
+# All sections marked as MANUAL, license headers, summaries and descriptions
+# can be maintained in that file. Please consult this file before editing any
+# of those fields
+#
+
 Name:           rubygem-webfinger
-Version:        1.0.2
+Version:        1.1.0
 Release:        0
 %define mod_name webfinger
 %define mod_full_name %{mod_name}-%{version}
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  ruby-macros >= 5
-BuildRequires:  %{ruby}
 BuildRequires:  %{rubygem gem2rpm}
+BuildRequires:  %{ruby}
+BuildRequires:  ruby-macros >= 5
 Url:            https://github.com/nov/webfinger
 Source:         https://rubygems.org/gems/%{mod_full_name}.gem
+Source1:        gem2rpm.yml
 Summary:        Ruby WebFinger client library, following IETF WebFinger WG spec
 License:        MIT
 Group:          Development/Languages/Ruby

++++++ gem2rpm.yml ++++++
# ---
# ## used by gem2rpm
# :summary: this is a custom summary
# ## used by gem2rpm
# :description: |-
#   this is a custom description
#
#   it can be multiline
# ## used by gem2rpm
# :license: MIT or Ruby
# ## used by gem2rpm and gem_packages
# :version_suffix: -x_y
# ## used by gem2rpm and gem_packages
# :disable_docs: true
# ## used by gem2rpm
# :disable_automatic_rdoc_dep: true
# ## used by gem2rpm
# :preamble: |-
#   BuildRequires: foobar
#   Requires: foobar
# ## used by gem2rpm
# :patches:
#   foo.patch: -p1
#   bar.patch:
# :post_patch:
#   if you need to fiddle with the source dir before rebuilding the gem
# ## used by gem2rpm
:sources:
# - foo.desktop
# - bar.desktop
# :gem_install_args: '....'
# ## used by gem2rpm
# :pre_install: |-
#   %if 0%{?use_system_libev}
#   export USE_VENDORED_LIBEV="no"
#   %endif
# ## used by gem2rpm
# :post_install: |-
#   # delete custom files here or do other fancy stuff
#   install -D -m 0644 %{S:1} %{buildroot}%{_bindir}/gem2rpm-opensuse
# ## used by gem2rpm
# :testsuite_command: |-
#   (pushd %{buildroot}%{gem_base}/gems/%{mod_full_name} && rake test)
# ## used by gem2rpm
# :filelist: |-
#   /usr/bin/gem2rpm-opensuse
# ## used by gem2rpm
# :scripts:
#   :post: |-
#     /bin/echo foo
# ## used by gem_packages
# :main:
#   :preamble: |-
#     Requires: util-linux
#     Recommends: pwgen
#   :filelist: |-
#     /usr/bin/gem2rpm-opensuse
# ## used by gem_packages
# :custom_pkgs:
#   apache:
#     :preamble: |-
#       Requires: .....
#     :filelist: |-
#       /etc/apache2/conf.d/passenger.conf
#     :summary: Custom summary is optional
#     :description: |-
#       Custom description is optional
#
#       bar
#     :post: |-
#       /bin/echo foo
#
++++++ webfinger-1.0.2.gem -> webfinger-1.1.0.gem ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/.travis.yml new/.travis.yml
--- old/.travis.yml     2016-01-26 06:16:34.000000000 +0100
+++ new/.travis.yml     2017-12-11 10:12:42.000000000 +0100
@@ -2,7 +2,5 @@
   - gem install bundler
 
 rvm:
-  - 2.0
-  - 2.1
-  - 2.2
-  - 2.3.0
\ No newline at end of file
+  - 2.3.5
+  - 2.4.2
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/VERSION new/VERSION
--- old/VERSION 2016-01-26 06:16:34.000000000 +0100
+++ new/VERSION 2017-12-11 10:12:42.000000000 +0100
@@ -1 +1 @@
-1.0.2
\ No newline at end of file
+1.1.0
Binary files old/checksums.yaml.gz and new/checksums.yaml.gz differ
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/webfinger/request.rb new/lib/webfinger/request.rb
--- old/lib/webfinger/request.rb        2016-01-26 06:16:34.000000000 +0100
+++ new/lib/webfinger/request.rb        2017-12-11 10:12:42.000000000 +0100
@@ -51,7 +51,7 @@
 
     def handle_response
       raw_response = yield
-      jrd = MultiJson.load(raw_response).with_indifferent_access
+      jrd = JSON.parse(raw_response).with_indifferent_access
       Response.new jrd
     rescue HTTPClient::BadResponseError => e
       case e.res.try(:status)
@@ -70,4 +70,4 @@
       end
     end
   end
-end
\ No newline at end of file
+end
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/lib/webfinger.rb new/lib/webfinger.rb
--- old/lib/webfinger.rb        2016-01-26 06:16:34.000000000 +0100
+++ new/lib/webfinger.rb        2017-12-11 10:12:42.000000000 +0100
@@ -1,5 +1,5 @@
+require 'json'
 require 'httpclient'
-require 'multi_json'
 require 'active_support'
 require 'active_support/core_ext'
 
@@ -57,4 +57,4 @@
 require 'webfinger/debugger'
 require 'webfinger/exception'
 require 'webfinger/request'
-require 'webfinger/response'
\ No newline at end of file
+require 'webfinger/response'
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/metadata new/metadata
--- old/metadata        2016-01-26 06:16:34.000000000 +0100
+++ new/metadata        2017-12-11 10:12:42.000000000 +0100
@@ -1,14 +1,14 @@
 --- !ruby/object:Gem::Specification
 name: webfinger
 version: !ruby/object:Gem::Version
-  version: 1.0.2
+  version: 1.1.0
 platform: ruby
 authors:
 - nov matake
 autorequire: 
 bindir: bin
 cert_chain: []
-date: 2016-01-26 00:00:00.000000000 Z
+date: 2017-12-11 00:00:00.000000000 Z
 dependencies:
 - !ruby/object:Gem::Dependency
   name: httpclient
@@ -25,20 +25,6 @@
       - !ruby/object:Gem::Version
         version: '2.4'
 - !ruby/object:Gem::Dependency
-  name: multi_json
-  requirement: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: '0'
-  type: :runtime
-  prerelease: false
-  version_requirements: !ruby/object:Gem::Requirement
-    requirements:
-    - - ">="
-      - !ruby/object:Gem::Version
-        version: '0'
-- !ruby/object:Gem::Dependency
   name: activesupport
   requirement: !ruby/object:Gem::Requirement
     requirements:
@@ -172,7 +158,7 @@
       version: '0'
 requirements: []
 rubyforge_project: 
-rubygems_version: 2.5.1
+rubygems_version: 2.6.11
 signing_key: 
 specification_version: 4
 summary: Ruby WebFinger client library, following IETF WebFinger WG spec 
updates.
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/webfinger.gemspec new/webfinger.gemspec
--- old/webfinger.gemspec       2016-01-26 06:16:34.000000000 +0100
+++ new/webfinger.gemspec       2017-12-11 10:12:42.000000000 +0100
@@ -1,23 +1,22 @@
 Gem::Specification.new do |gem|
-  gem.name          = "webfinger"
-  gem.version       = File.read("VERSION").delete("\n\r")
-  gem.authors       = ["nov matake"]
-  gem.email         = ["n...@matake.jp"]
+  gem.name          = 'webfinger'
+  gem.version       = File.read('VERSION').delete("\n\r")
+  gem.authors       = ['nov matake']
+  gem.email         = ['n...@matake.jp']
   gem.description   = %q{Ruby WebFinger client library}
   gem.summary       = %q{Ruby WebFinger client library, following IETF 
WebFinger WG spec updates.}
-  gem.homepage      = "https://github.com/nov/webfinger";
+  gem.homepage      = 'https://github.com/nov/webfinger'
   gem.license       = 'MIT'
 
   gem.files         = `git ls-files`.split($/)
   gem.executables   = gem.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
   gem.test_files    = gem.files.grep(%r{^(test|spec|features)/})
-  gem.require_paths = ["lib"]
-  gem.add_runtime_dependency "httpclient", ">= 2.4"
-  gem.add_runtime_dependency "multi_json"
-  gem.add_runtime_dependency "activesupport"
-  gem.add_development_dependency "rake"
-  gem.add_development_dependency "rspec"
+  gem.require_paths = ['lib']
+  gem.add_runtime_dependency 'httpclient', '>= 2.4'
+  gem.add_runtime_dependency 'activesupport'
+  gem.add_development_dependency 'rake'
+  gem.add_development_dependency 'rspec'
   gem.add_development_dependency 'rspec-its'
-  gem.add_development_dependency "simplecov"
-  gem.add_development_dependency "webmock", ">= 1.6.2"
+  gem.add_development_dependency 'simplecov'
+  gem.add_development_dependency 'webmock', '>= 1.6.2'
 end


Reply via email to