Hello community,

here is the log from the commit of package gimp for openSUSE:Factory checked in 
at 2018-03-12 12:02:35
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/gimp (Old)
 and      /work/SRC/openSUSE:Factory/.gimp.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "gimp"

Mon Mar 12 12:02:35 2018 rev:101 rq:585013 version:2.8.22

Changes:
--------
--- /work/SRC/openSUSE:Factory/gimp/gimp.changes        2018-01-16 
09:26:38.001874433 +0100
+++ /work/SRC/openSUSE:Factory/.gimp.new/gimp.changes   2018-03-12 
12:02:41.330878763 +0100
@@ -1,0 +2,9 @@
+Thu Mar  8 01:16:27 UTC 2018 - bjorn....@gmail.com
+
+- Add gimp-gegl03-buildfix.patch: Port to gegl-03, patch taken from
+  debian.
+- Following the above port, replace pkgconfig(gegl-0.2) with
+  pkgconfig(gegl-0.3) BuildRequires and add libtool BuildRequires:
+  and pass autoreconf as the above patch touches the buildsystem.
+
+-------------------------------------------------------------------

New:
----
  gimp-gegl03-buildfix.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ gimp.spec ++++++
--- /var/tmp/diff_new_pack.LaJ5vc/_old  2018-03-12 12:02:42.498836907 +0100
+++ /var/tmp/diff_new_pack.LaJ5vc/_new  2018-03-12 12:02:42.502836763 +0100
@@ -31,6 +31,8 @@
 # openSUSE palette file
 Source2:        openSUSE.gpl
 Source99:       baselibs.conf
+# PATCH-FIX-UPSTREAM gimp-gegl03-buildfix.patch bjorn....@gmail.com -- Port to 
gegl-03, patch taken from debian
+Patch0:         gimp-gegl03-buildfix.patch
 
 BuildRequires:  aalib-devel
 BuildRequires:  alsa-devel >= 1.0.0
@@ -48,6 +50,7 @@
 BuildRequires:  libmng-devel
 BuildRequires:  librsvg-devel >= 2.36.0
 BuildRequires:  libtiff-devel
+BuildRequires:  libtool
 BuildRequires:  libwmf-devel >= 0.2.8
 BuildRequires:  libxslt-tools
 BuildRequires:  pkgconfig
@@ -60,7 +63,7 @@
 BuildRequires:  pkgconfig(cairo-pdf) >= 1.10.2
 BuildRequires:  pkgconfig(dbus-glib-1) >= 0.70
 BuildRequires:  pkgconfig(gdk-pixbuf-2.0) >= 2.24.1
-BuildRequires:  pkgconfig(gegl-0.2) >= 0.2.0
+BuildRequires:  pkgconfig(gegl-0.3)
 BuildRequires:  pkgconfig(glib-2.0) >= 2.30.2
 BuildRequires:  pkgconfig(gtk+-2.0) >= 2.24.10
 BuildRequires:  pkgconfig(gudev-1.0) >= 167
@@ -171,6 +174,7 @@
 
 %prep
 %setup -q
+%patch0 -p1
 
 translation-update-upstream
 translation-update-upstream po-libgimp gimp20-libgimp
@@ -195,6 +199,7 @@
 
 %build
 export CFLAGS="%{optflags} -fno-strict-aliasing"
+autoreconf -fiv
 %configure \
        --disable-static\
 %if 0%{?suse_version} >= 1330

++++++ gimp-gegl03-buildfix.patch ++++++
--- ./app/core/gimpparamspecs-duplicate.c       2016-07-04 10:33:22.449542700 
+0200
+++ ./app/core/gimpparamspecs-duplicate.c       2016-07-04 10:34:54.505304400 
+0200
@@ -67,7 +67,7 @@
                                      spec->default_value,
                                      pspec->flags);
 
-          if (GEGL_IS_PARAM_SPEC_MULTILINE (pspec))
+          if (gegl_param_spec_get_property_key(pspec, "multiline"))
             {
               g_param_spec_set_qdata (new, multiline_quark,
                                       GINT_TO_POINTER (TRUE));

diff --git a/app/sanity.c b/app/sanity.c
index febddfb..85fea55 100644
--- a/app/sanity.c
+++ b/app/sanity.c
@@ -351,7 +351,7 @@ sanity_check_babl (void)
 
 #define BABL_REQUIRED_MAJOR 0
 #define BABL_REQUIRED_MINOR 1
-#define BABL_REQUIRED_MICRO 10
+#define BABL_REQUIRED_MICRO 12
 
   babl_get_version (&babl_major_version,
                     &babl_minor_version,
@@ -388,7 +388,7 @@ sanity_check_gegl (void)
   gint gegl_micro_version;
 
 #define GEGL_REQUIRED_MAJOR 0
-#define GEGL_REQUIRED_MINOR 2
+#define GEGL_REQUIRED_MINOR 3
 #define GEGL_REQUIRED_MICRO 0
 
   gegl_get_version (&gegl_major_version,
diff --git a/configure.ac b/configure.ac
index 26812b6..4252fe9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,8 +40,8 @@ m4_define([gimp_stable],
 m4_define([gimp_full_name], [GNU Image Manipulation Program])
 
 # required versions of other packages
-m4_define([babl_required_version], [0.1.10])
-m4_define([gegl_required_version], [0.2.0])
+m4_define([babl_required_version], [0.1.12])
+m4_define([gegl_required_version], [0.3.0])
 m4_define([glib_required_version], [2.30.2])
 m4_define([atk_required_version], [2.2.0])
 m4_define([gtk_required_version], [2.24.10])
@@ -519,7 +519,7 @@ AC_SUBST(ISO_CODES_LOCALEDIR)
 ###############################
 
 PKG_CHECK_MODULES(BABL, babl >= babl_required_version)
-PKG_CHECK_MODULES(GEGL, gegl-0.2 >= gegl_required_version)
+PKG_CHECK_MODULES(GEGL, gegl-0.3 >= gegl_required_version)
 PKG_CHECK_MODULES(ATK, atk >= atk_required_version)
 
 AM_PATH_GLIB_2_0(glib_required_version, :,


Reply via email to