Hello community,

here is the log from the commit of package libqt5-qtbase for openSUSE:Factory 
checked in at 2018-03-12 12:03:16
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libqt5-qtbase (Old)
 and      /work/SRC/openSUSE:Factory/.libqt5-qtbase.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libqt5-qtbase"

Mon Mar 12 12:03:16 2018 rev:78 rq:585167 version:5.10.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/libqt5-qtbase/libqt5-qtbase.changes      
2018-03-04 11:54:51.033291000 +0100
+++ /work/SRC/openSUSE:Factory/.libqt5-qtbase.new/libqt5-qtbase.changes 
2018-03-12 12:03:17.717574767 +0100
@@ -1,0 +2,17 @@
+Fri Mar  9 15:15:25 UTC 2018 - crrodrig...@opensuse.org
+
+- Further review of build dependencies:
+  * pcre-devel is not required, only pcre2-devel, Remove
+    from buildrequires
+  * add explicit buildrequires on pkgconfig(libdrm) and 
+    pkgconfig(pango)
+  * sources do not use libtiff-devel at all, remove from
+    buildrequires
+
+-------------------------------------------------------------------
+Thu Mar  8 17:09:23 UTC 2018 - crrodrig...@opensuse.org
+
+- Replace xorg-x11-devel for a long list of individual
+  pkgconfig() buildrequires
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libqt5-qtbase.spec ++++++
--- /var/tmp/diff_new_pack.hRvAz0/_old  2018-03-12 12:03:21.489439593 +0100
+++ /var/tmp/diff_new_pack.hRvAz0/_new  2018-03-12 12:03:21.497439307 +0100
@@ -111,9 +111,7 @@
 BuildRequires:  libpng-devel
 BuildRequires:  libproxy-devel
 BuildRequires:  lksctp-tools-devel
-BuildRequires:  libtiff-devel
 BuildRequires:  openssl-devel
-BuildRequires:  pcre-devel
 BuildRequires:  pcre2-devel
 BuildRequires:  pkgconfig
 BuildRequires:  pkgconfig(mtdev)
@@ -140,11 +138,27 @@
 %if %{vulkan}
 BuildRequires:  vulkan-devel
 %endif
-BuildRequires:  xcb-util-image-devel
-BuildRequires:  xcb-util-keysyms-devel
-BuildRequires:  xcb-util-renderutil-devel
-BuildRequires:  xcb-util-wm-devel
-BuildRequires:  xorg-x11-devel
+
+BuildRequires:  pkgconfig(pango)
+BuildRequires:  pkgconfig(libdrm)
+BuildRequires:  pkgconfig(xcb-randr)
+BuildRequires:  pkgconfig(xcb-renderutil)
+BuildRequires:  pkgconfig(xcb-render)
+BuildRequires:  pkgconfig(xcb-shape)
+BuildRequires:  pkgconfig(xcb-shm)
+BuildRequires:  pkgconfig(xcb-sync)
+BuildRequires:  pkgconfig(xcb-xfixes)
+BuildRequires:  pkgconfig(xcb-xinerama)
+BuildRequires:  pkgconfig(xcb-xkb)
+BuildRequires:  pkgconfig(xcb)
+BuildRequires:  pkgconfig(xcb-glx)
+BuildRequires:  pkgconfig(xcb-image)
+BuildRequires:  pkgconfig(xcb-icccm)
+BuildRequires:  pkgconfig(xcb-keysyms)
+BuildRequires:  pkgconfig(x11)
+BuildRequires:  pkgconfig(xrender)
+BuildRequires:  pkgconfig(xi)
+BuildRequires:  pkgconfig(x11-xcb)
 BuildRequires:  xz
 BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(gtk+-3.0)
@@ -155,6 +169,7 @@
 BuildRequires:  pkgconfig(sm)
 BuildRequires:  pkgconfig(xkbcommon) >= 0.4.1
 BuildRequires:  pkgconfig(xkbcommon-x11) >= 0.4.1
+BuildRequires:  pkgconfig(zlib)
 %if %journald
 BuildRequires:  pkgconfig(libsystemd)
 %endif


Reply via email to