Hello community,

here is the log from the commit of package ptpd for openSUSE:Factory checked in 
at 2018-11-22 13:26:49
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/ptpd (Old)
 and      /work/SRC/openSUSE:Factory/.ptpd.new.19453 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "ptpd"

Thu Nov 22 13:26:49 2018 rev:25 rq:650724 version:2.3.1

Changes:
--------
--- /work/SRC/openSUSE:Factory/ptpd/ptpd.changes        2018-03-09 
10:46:26.111025713 +0100
+++ /work/SRC/openSUSE:Factory/.ptpd.new.19453/ptpd.changes     2018-11-22 
13:27:00.389907147 +0100
@@ -1,0 +2,11 @@
+Wed Nov 21 14:31:06 UTC 2018 - iul...@suse.com
+
+- Fix name conflict with openssl variable 
+  * ptpd-evp-md-ctx.patch
+ 
+-------------------------------------------------------------------
+Fri Nov  9 07:50:17 UTC 2018 - Martin Pluskal <mplus...@suse.com>
+
+- Enable experimental features
+
+-------------------------------------------------------------------

New:
----
  ptpd-evp-md-ctx.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ ptpd.spec ++++++
--- /var/tmp/diff_new_pack.Dg45am/_old  2018-11-22 13:27:01.197906302 +0100
+++ /var/tmp/diff_new_pack.Dg45am/_new  2018-11-22 13:27:01.201906298 +0100
@@ -16,22 +16,20 @@
 #
 
 
-#Compat macro for new _fillupdir macro introduced in Nov 2017
-%if ! %{defined _fillupdir}
-  %define _fillupdir %{_localstatedir}/adm/fillup-templates
-%endif
 Name:           ptpd
 Version:        2.3.1
 Release:        0
 Summary:        Implements the Precision Time protocol as defined by IEEE 1588 
standard
 License:        BSD-3-Clause
 Group:          System/Daemons
-URL:            https://github.com/ptpd/ptpd
+Url:            https://github.com/ptpd/ptpd
 Source0:        https://github.com/ptpd/ptpd/archive/ptpd-%{version}.tar.gz
 Source1:        ptpd2.service
 Source3:        conf.sysconfig.ptpd
 # PATCH-FIX-UPSTREAM ptpd2-net-snmp_U64.patch gh#ptpd/ptpd#25
 Patch0:         ptpd2-net-snmp_U64.patch
+# PATCH-FIX-UPSTREAM resolve EVP_MD_CTX name conflict
+Patch1:         ptpd-evp-md-ctx.patch
 BuildRequires:  autoconf
 BuildRequires:  automake
 BuildRequires:  libpcap-devel
@@ -64,11 +62,14 @@
 %prep
 %setup -q -n %{name}-%{name}-%{version}
 %patch0
+%patch1 -p1
 
 %build
 autoreconf -fiv
 %configure \
-  --enable-statistics
+  --enable-statistics \
+  --enable-experimental-options
+make %{?_smp_mflags}
 
 %install
 %make_install
@@ -103,8 +104,8 @@
 %config(noreplace) %{_sysconfdir}/%{name}2.conf
 %{_sbindir}/ptpd2
 %{_sbindir}/rcptpd2
-%{_mandir}/man5/ptpd2.conf.5%{ext_man}
-%{_mandir}/man8/ptpd2.8%{ext_man}
+%{_mandir}/man5/ptpd2.conf.5%{?ext_man}
+%{_mandir}/man8/ptpd2.8%{?ext_man}
 %{_datadir}/ptpd
 %{_libexecdir}/systemd/system/ptpd2.service
 %{_fillupdir}/*

++++++ ptpd-evp-md-ctx.patch ++++++
>From 838b985510c360e651d18134e64f258f2f4c6e7c Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.bene...@micronovasrl.com>
Date: Fri, 31 Aug 2018 18:46:56 +0200
Subject: [PATCH] ntp_isc_md5: rename EVP_MD_CTX into PTPD_EVP_MD_CTX

EVP_MD_CTX can conflict with openssl that defines a completely different
typedef with same name.

Since this typedef is used only twice in the entire ptpd,
substitute EVP_MD_CTX with PTPD_EVP_MD_CTX.

Signed-off-by: Giulio Benetti <giulio.bene...@micronovasrl.com>
---
 src/dep/ntpengine/ntp_isc_md5.c | 2 +-
 src/dep/ntpengine/ntp_isc_md5.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Index: ptpd-ptpd-2.3.1/src/dep/ntpengine/ntp_isc_md5.c
===================================================================
--- ptpd-ptpd-2.3.1.orig/src/dep/ntpengine/ntp_isc_md5.c
+++ ptpd-ptpd-2.3.1/src/dep/ntpengine/ntp_isc_md5.c
@@ -262,7 +262,7 @@ MD5authencrypt(
 {
        u_char  digest[64];
        u_int   len;
-       EVP_MD_CTX ctx;
+       PTPD_EVP_MD_CTX ctx;
         pkt[length / 4] = htonl(keyid); 
        EVP_DigestInit(&ctx);
        EVP_DigestUpdate(&ctx, (u_char *)key, (u_int)strlen(key));
Index: ptpd-ptpd-2.3.1/src/dep/ntpengine/ntp_isc_md5.h
===================================================================
--- ptpd-ptpd-2.3.1.orig/src/dep/ntpengine/ntp_isc_md5.h
+++ ptpd-ptpd-2.3.1/src/dep/ntpengine/ntp_isc_md5.h
@@ -80,7 +80,7 @@ isc_md5_final(isc_md5_t *ctx, unsigned c
 # define MD5Init(c)             isc_md5_init(c)
 # define MD5Update(c, p, s)     isc_md5_update(c, p, s)
 # define MD5Final(d, c)         isc_md5_final((c), (d)) /* swapped */
-  typedef MD5_CTX                       EVP_MD_CTX;
+  typedef MD5_CTX                       PTPD_EVP_MD_CTX;
 # define EVP_DigestInit(c)              MD5Init(c)
 # define EVP_DigestUpdate(c, p, s)      MD5Update(c, p, s)
 # define EVP_DigestFinal(c, d, pdl)     \

Reply via email to