Hello community,

here is the log from the commit of package libvmime for openSUSE:Factory 
checked in at 2019-07-12 11:59:44
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/libvmime (Old)
 and      /work/SRC/openSUSE:Factory/.libvmime.new.4615 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "libvmime"

Fri Jul 12 11:59:44 2019 rev:22 rq:706373 version:0.9.2.85

Changes:
--------
--- /work/SRC/openSUSE:Factory/libvmime/libvmime.changes        2018-07-06 
10:48:51.502764362 +0200
+++ /work/SRC/openSUSE:Factory/.libvmime.new.4615/libvmime.changes      
2019-07-12 11:59:45.544171806 +0200
@@ -1,0 +2,6 @@
+Tue May 28 10:38:46 UTC 2019 - Jan Engelhardt <[email protected]>
+
+- Update to Kopano branch of vmime, 0.9.2k2
+  * Unbreak own hostname qualification on POSIX systems
+
+-------------------------------------------------------------------

Old:
----
  vmime-0.9.2.50.tar.xz

New:
----
  vmime-0.9.2.85.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ libvmime.spec ++++++
--- /var/tmp/diff_new_pack.Pyh5JT/_old  2019-07-12 11:59:47.728171872 +0200
+++ /var/tmp/diff_new_pack.Pyh5JT/_new  2019-07-12 11:59:47.732171872 +0200
@@ -17,11 +17,11 @@
 
 
 Name:           libvmime
-%define lname  libvmime1
-Summary:        Library for working with RFC 2822, MIME messages and 
IMAP/POP/SMTP
+%define lname  libvmime-kopano2
+Summary:        Library for working with RFC 5322, MIME messages and 
IMAP/POP/SMTP
 License:        GPL-3.0-or-later
 Group:          Development/Libraries/C and C++
-Version:        0.9.2.50
+Version:        0.9.2.85
 Release:        0
 Url:            http://vmime.org/
 
@@ -59,7 +59,7 @@
 BuildRequires:  xz
 
 %description
-VMime is a C++ class library for working with RFC2822 and
+VMime is a C++ class library for working with RFC5322 and
 MIME-conforming messages (RFC2045–2049), as well as Internet
 messaging services like IMAP, POP or SMTP.
 
@@ -72,7 +72,7 @@
 Group:          System/Libraries
 
 %description -n %lname
-VMime is a C++ class library for working with RFC2822 and
+VMime is a C++ class library for working with RFC5322 and
 MIME-conforming messages (RFC2045–2049), as well as Internet
 messaging services like IMAP, POP or SMTP.
 
@@ -86,7 +86,7 @@
 Requires:       %lname = %version
 
 %description devel
-VMime is a C++ class library for working with RFC2822 and
+VMime is a C++ class library for working with RFC5322 and
 MIME-conforming messages (RFC2045–2049), as well as Internet
 messaging services like IMAP, POP or SMTP.
 
@@ -105,6 +105,12 @@
 
 cf="%optflags -DVMIME_ALWAYS_GENERATE_7BIT_PARAMETER=1"
 %cmake \
+        -DCMAKE_INSTALL_PREFIX:PATH="%_prefix" \
+        -DINCLUDE_INSTALL_DIR:PATH="%_includedir" \
+        -DLIB_INSTALL_DIR:PATH="%_libdir" \
+        -DSYSCONF_INSTALL_DIR:PATH="%_sysconfdir" \
+        -DSHARE_INSTALL_PREFIX:PATH="%_datadir" \
+        -DCMAKE_INSTALL_LIBDIR:PATH="%_libdir" \
        -DVMIME_SENDMAIL_PATH:STRING="%_sbindir/sendmail" \
        -DVMIME_BUILD_SAMPLES:BOOL=OFF \
 %if 0%{?sle_version}
@@ -126,12 +132,9 @@
 cp -a doc/book/book.pdf "$b/%_docdir/%name/"
 %endif
 %cmake_install
-
-# https://github.com/kisli/vmime/issues/200
-mv "$b/usr/%_libdir" "$b/usr/"
-mv "$b/usr/cmake" "$b/%_datadir/"
-
 find "$b" -type f -name "*.la" -delete
+mkdir -p "$b/%_datadir"
+mv "$b/%_prefix/cmake" "$b/%_datadir/"
 
 %post   -n %lname -p /sbin/ldconfig
 %postun -n %lname -p /sbin/ldconfig
@@ -139,12 +142,13 @@
 %files -n %lname
 %defattr(-,root,root)
 %doc COPYING
-%_libdir/%name.so.1*
+%_libdir/libvmime-kopano.so.2*
 
 %files devel
 %defattr(-,root,root)
 %_includedir/vmime
 %_libdir/libvmime.so
+%_libdir/libvmime-kopano.so
 %_libdir/pkgconfig/*.pc
 %_datadir/cmake/
 %if 0%{?with_pdf}

++++++ _service ++++++
--- /var/tmp/diff_new_pack.Pyh5JT/_old  2019-07-12 11:59:47.760171873 +0200
+++ /var/tmp/diff_new_pack.Pyh5JT/_new  2019-07-12 11:59:47.764171874 +0200
@@ -1,8 +1,8 @@
 <services>
        <service name="tar_scm" mode="disabled">
                <param name="scm">git</param>
-               <param name="url">https://github.com/kisli/vmime</param>
-               <param 
name="revision">a9b822140bf8926620fd21b880893d4c214dd8c0</param>
+               <param name="url">https://github.com/kopano-dev/vmime</param>
+               <param name="revision">v0.9.2k2</param>
                <param name="parent-tag">v0.9.2</param>
                <param name="versionformat">0.9.2.@TAG_OFFSET@</param>
        </service>

++++++ vmime-0.9.2.50.tar.xz -> vmime-0.9.2.85.tar.xz ++++++
++++ 92662 lines of diff (skipped)


Reply via email to