Hello community,

here is the log from the commit of package kded for openSUSE:Factory checked in 
at 2020-02-14 16:32:06
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kded (Old)
 and      /work/SRC/openSUSE:Factory/.kded.new.26092 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kded"

Fri Feb 14 16:32:06 2020 rev:77 rq:773250 version:5.67.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/kded/kded.changes        2020-01-14 
21:04:11.638677067 +0100
+++ /work/SRC/openSUSE:Factory/.kded.new.26092/kded.changes     2020-02-14 
16:33:14.067447303 +0100
@@ -1,0 +2,14 @@
+Sun Feb  2 18:06:51 UTC 2020 - Christophe Giboudeaux <christo...@krop.fr>
+
+- Replace %make_jobs with %cmake_build.
+
+-------------------------------------------------------------------
+Sun Feb  2 14:32:37 UTC 2020 - Christophe Giboudeaux <christo...@krop.fr>
+
+- Update to 5.67.0
+  * New feature release
+  * For more details please see:
+  * https://www.kde.org/announcements/kde-frameworks-5.67.0.php
+- No code change since 5.66.0
+
+-------------------------------------------------------------------

Old:
----
  kded-5.66.0.tar.xz
  kded-5.66.0.tar.xz.sig

New:
----
  kded-5.67.0.tar.xz
  kded-5.67.0.tar.xz.sig

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kded.spec ++++++
--- /var/tmp/diff_new_pack.kwrCu1/_old  2020-02-14 16:33:15.443448070 +0100
+++ /var/tmp/diff_new_pack.kwrCu1/_new  2020-02-14 16:33:15.443448070 +0100
@@ -16,14 +16,14 @@
 #
 
 
-%define _tar_path 5.66
+%define _tar_path 5.67
 # Full KF5 version (e.g. 5.33.0)
 %{!?_kf5_version: %global _kf5_version %{version}}
 # Last major and minor KF5 version (e.g. 5.33)
 %{!?_kf5_bugfix_version: %define _kf5_bugfix_version %(echo %{_kf5_version} | 
awk -F. '{print $1"."$2}')}
 %bcond_without lang
 Name:           kded
-Version:        5.66.0
+Version:        5.67.0
 Release:        0
 Summary:        Central daemon of KDE workspaces
 License:        LGPL-2.1-or-later
@@ -47,12 +47,12 @@
 BuildRequires:  cmake(KF5I18n) >= %{_kf5_bugfix_version}
 BuildRequires:  cmake(KF5Service) >= %{_kf5_bugfix_version}
 BuildRequires:  cmake(KF5WindowSystem) >= %{_kf5_bugfix_version}
-BuildRequires:  cmake(Qt5Core) >= 5.11.0
-BuildRequires:  cmake(Qt5DBus) >= 5.11.0
-BuildRequires:  cmake(Qt5Network) >= 5.11.0
-BuildRequires:  cmake(Qt5Test) >= 5.11.0
-BuildRequires:  cmake(Qt5Widgets) >= 5.11.0
-BuildRequires:  cmake(Qt5Xml) >= 5.11.0
+BuildRequires:  cmake(Qt5Core) >= 5.12.0
+BuildRequires:  cmake(Qt5DBus) >= 5.12.0
+BuildRequires:  cmake(Qt5Network) >= 5.12.0
+BuildRequires:  cmake(Qt5Test) >= 5.12.0
+BuildRequires:  cmake(Qt5Widgets) >= 5.12.0
+BuildRequires:  cmake(Qt5Xml) >= 5.12.0
 %if %{with lang}
 Recommends:     %{name}-lang
 %endif
@@ -79,7 +79,7 @@
 
 %build
   %cmake_kf5 -d build
-  %make_jobs
+  %cmake_build
 
 %install
   %kf5_makeinstall -C build


++++++ kded-5.66.0.tar.xz -> kded-5.67.0.tar.xz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kded-5.66.0/CMakeLists.txt 
new/kded-5.67.0/CMakeLists.txt
--- old/kded-5.66.0/CMakeLists.txt      2020-01-04 11:06:02.000000000 +0100
+++ new/kded-5.67.0/CMakeLists.txt      2020-02-02 13:46:22.000000000 +0100
@@ -1,11 +1,11 @@
 cmake_minimum_required(VERSION 3.5)
 
-set(KF5_VERSION "5.66.0") # handled by release scripts
-set(KF5_DEP_VERSION "5.66.0") # handled by release scripts
+set(KF5_VERSION "5.67.0") # handled by release scripts
+set(KF5_DEP_VERSION "5.67.0") # handled by release scripts
 project(KDED VERSION ${KF5_VERSION})
 
 include(FeatureSummary)
-find_package(ECM 5.66.0  NO_MODULE)
+find_package(ECM 5.67.0  NO_MODULE)
 set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake 
Modules." URL "https://commits.kde.org/extra-cmake-modules";)
 feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND 
FATAL_ON_MISSING_REQUIRED_PACKAGES)
 
@@ -40,7 +40,7 @@
 # We don't install kded_version.h, it's only useful internally
 # (given that this framework produces no library)
 add_definitions(-DQT_DISABLE_DEPRECATED_BEFORE=0x050d00)
-add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054100)
+add_definitions(-DKF_DISABLE_DEPRECATED_BEFORE_AND_AT=0x054200)
 add_definitions(-DQT_NO_FOREACH)
 if (KF5DocTools_FOUND)
     if (IS_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/po")


Reply via email to