Hello community,

here is the log from the commit of package kitemviews for openSUSE:Factory 
checked in at 2020-02-14 16:33:16
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/kitemviews (Old)
 and      /work/SRC/openSUSE:Factory/.kitemviews.new.26092 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "kitemviews"

Fri Feb 14 16:33:16 2020 rev:75 rq:773271 version:5.67.0

Changes:
--------
--- /work/SRC/openSUSE:Factory/kitemviews/kitemviews.changes    2020-01-14 
21:05:08.898703573 +0100
+++ /work/SRC/openSUSE:Factory/.kitemviews.new.26092/kitemviews.changes 
2020-02-14 16:33:59.111472406 +0100
@@ -1,0 +2,14 @@
+Sun Feb  2 18:07:02 UTC 2020 - Christophe Giboudeaux <christo...@krop.fr>
+
+- Replace %make_jobs with %cmake_build.
+
+-------------------------------------------------------------------
+Sun Feb  2 14:32:50 UTC 2020 - Christophe Giboudeaux <christo...@krop.fr>
+
+- Update to 5.67.0
+  * New feature release
+  * For more details please see:
+  * https://www.kde.org/announcements/kde-frameworks-5.67.0.php
+- No code change since 5.66.0
+
+-------------------------------------------------------------------

Old:
----
  kitemviews-5.66.0.tar.xz
  kitemviews-5.66.0.tar.xz.sig

New:
----
  kitemviews-5.67.0.tar.xz
  kitemviews-5.67.0.tar.xz.sig

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ kitemviews.spec ++++++
--- /var/tmp/diff_new_pack.LLR7fh/_old  2020-02-14 16:34:00.515473189 +0100
+++ /var/tmp/diff_new_pack.LLR7fh/_new  2020-02-14 16:34:00.543473205 +0100
@@ -17,14 +17,14 @@
 
 
 %define lname   libKF5ItemViews5
-%define _tar_path 5.66
+%define _tar_path 5.67
 # Full KF5 version (e.g. 5.33.0)
 %{!?_kf5_version: %global _kf5_version %{version}}
 # Last major and minor KF5 version (e.g. 5.33)
 %{!?_kf5_bugfix_version: %define _kf5_bugfix_version %(echo %{_kf5_version} | 
awk -F. '{print $1"."$2}')}
 %bcond_without lang
 Name:           kitemviews
-Version:        5.66.0
+Version:        5.67.0
 Release:        0
 Summary:        Set of item views extending the Qt model-view framework
 License:        LGPL-2.1-or-later AND GPL-2.0-or-later
@@ -40,11 +40,11 @@
 BuildRequires:  extra-cmake-modules >= %{_kf5_bugfix_version}
 BuildRequires:  fdupes
 BuildRequires:  kf5-filesystem
-BuildRequires:  cmake(Qt5Test) >= 5.11.0
-BuildRequires:  cmake(Qt5UiPlugin) >= 5.11.0
-BuildRequires:  cmake(Qt5Widgets) >= 5.11.0
+BuildRequires:  cmake(Qt5Test) >= 5.12.0
+BuildRequires:  cmake(Qt5UiPlugin) >= 5.12.0
+BuildRequires:  cmake(Qt5Widgets) >= 5.12.0
 %if %{with lang}
-BuildRequires:  cmake(Qt5LinguistTools) >= 5.11.0
+BuildRequires:  cmake(Qt5LinguistTools) >= 5.12.0
 %endif
 
 %description
@@ -70,7 +70,7 @@
 Group:          Development/Libraries/KDE
 Requires:       %{lname} = %{version}
 Requires:       extra-cmake-modules
-Requires:       cmake(Qt5Widgets) >= 5.11.0
+Requires:       cmake(Qt5Widgets) >= 5.12.0
 
 %description devel
 KItemViews includes a set of views, which can be used with item models. It
@@ -84,7 +84,7 @@
 
 %build
   %cmake_kf5 -d build -- -Dlconvert_executable=%{_kf5_libdir}/qt5/bin/lconvert
-  %make_jobs
+  %cmake_build
 
 %install
   %kf5_makeinstall -C build


++++++ kitemviews-5.66.0.tar.xz -> kitemviews-5.67.0.tar.xz ++++++
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kitemviews-5.66.0/CMakeLists.txt 
new/kitemviews-5.67.0/CMakeLists.txt
--- old/kitemviews-5.66.0/CMakeLists.txt        2020-01-04 11:10:13.000000000 
+0100
+++ new/kitemviews-5.67.0/CMakeLists.txt        2020-02-02 13:50:53.000000000 
+0100
@@ -1,10 +1,10 @@
 cmake_minimum_required(VERSION 3.5)
 
-set(KF5_VERSION "5.66.0") # handled by release scripts
+set(KF5_VERSION "5.67.0") # handled by release scripts
 project(KItemViews VERSION ${KF5_VERSION})
 
 include(FeatureSummary)
-find_package(ECM 5.66.0  NO_MODULE)
+find_package(ECM 5.67.0  NO_MODULE)
 set_package_properties(ECM PROPERTIES TYPE REQUIRED DESCRIPTION "Extra CMake 
Modules." URL "https://commits.kde.org/extra-cmake-modules";)
 feature_summary(WHAT REQUIRED_PACKAGES_NOT_FOUND 
FATAL_ON_MISSING_REQUIRED_PACKAGES)
 
diff -urN '--exclude=CVS' '--exclude=.cvsignore' '--exclude=.svn' 
'--exclude=.svnignore' old/kitemviews-5.66.0/po/zh_CN/kitemviews5_qt.po 
new/kitemviews-5.67.0/po/zh_CN/kitemviews5_qt.po
--- old/kitemviews-5.66.0/po/zh_CN/kitemviews5_qt.po    2020-01-04 
11:10:13.000000000 +0100
+++ new/kitemviews-5.67.0/po/zh_CN/kitemviews5_qt.po    2020-02-02 
13:50:53.000000000 +0100
@@ -13,8 +13,7 @@
 msgid ""
 msgstr ""
 "Project-Id-Version: kdeorg\n"
-"PO-Revision-Date: 2019-11-19 23:01\n"
-"Last-Translator: Guo Yunhe (guoyunhe)\n"
+"PO-Revision-Date: 2020-01-20 21:49\n"
 "Language-Team: Chinese Simplified\n"
 "Language: zh_CN\n"
 "MIME-Version: 1.0\n"
@@ -22,7 +21,6 @@
 "Content-Transfer-Encoding: 8bit\n"
 "X-Qt-Contexts: true\n"
 "Plural-Forms: nplurals=1; plural=0;\n"
-"X-Generator: crowdin.com\n"
 "X-Crowdin-Project: kdeorg\n"
 "X-Crowdin-Language: zh-CN\n"
 "X-Crowdin-File: /kf5-trunk/messages/frameworks/kitemviews5_qt.pot\n"


Reply via email to