Hello community,

here is the log from the commit of package docker for openSUSE:Factory checked 
in at 2020-06-30 23:02:49
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/docker (Old)
 and      /work/SRC/openSUSE:Factory/.docker.new.3060 (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "docker"

Tue Jun 30 23:02:49 2020 rev:103 rq: version:19.03.12_ce

Changes:
--------
--- /work/SRC/openSUSE:Factory/docker/docker.changes    2020-06-29 
21:15:19.885220745 +0200
+++ /work/SRC/openSUSE:Factory/.docker.new.3060/docker.changes  2020-06-30 
23:02:49.618626363 +0200
@@ -1,0 +2,6 @@
+Tue Jun 30 23:00:00 UTC 2020 - Dominique Leuenberger <dims...@opensuse.org>
+
+- Emergency fix: %requires_eq does not work with provide symbols,
+  only effective package names. Convert back to regular Requires.
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ docker.spec ++++++
--- /var/tmp/diff_new_pack.hnkXvM/_old  2020-06-30 23:02:50.454628803 +0200
+++ /var/tmp/diff_new_pack.hnkXvM/_new  2020-06-30 23:02:50.458628814 +0200
@@ -105,16 +105,16 @@
 # for some old packaging issues (where rpm would delete a binary that was
 # installed by docker-libnetwork). See bsc#1057743 for more details.
 BuildRequires:  docker-libnetwork%{name_suffix}-git = %{required_libnetwork}
-%requires_eq    docker-libnetwork%{name_suffix}-git
+Requires:       docker-libnetwork%{name_suffix}-git = %{required_libnetwork}
 Requires:       fix_bsc_1057743
 # Containerd and runC are required as they are the only currently supported
 # execdrivers of Docker. NOTE: The version pinning here matches upstream's
 # vendor.conf to ensure that we don't use a slightly incompatible version of
 # runC or containerd (which would be bad).
 BuildRequires:  containerd%{name_suffix}-git  = %{required_containerd}
-%requires_eq    containerd%{name_suffix}-git
+Requires:       containerd%{name_suffix}-git = %{required_containerd}
 BuildRequires:  docker-runc%{name_suffix}-git = %{required_dockerrunc}
-%requires_eq    docker-runc%{name_suffix}-git
+Requires:       docker-runc%{name_suffix}-git = %{required_dockerrunc}
 # Needed for --init support. We don't use "tini", we use our own implementation
 # which handles edge-cases better.
 Requires:       catatonit


Reply via email to