Hello community,

here is the log from the commit of package rubygem-amqp for openSUSE:Factory 
checked in at 2012-11-18 20:26:34
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/rubygem-amqp (Old)
 and      /work/SRC/openSUSE:Factory/.rubygem-amqp.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "rubygem-amqp", Maintainer is "cth...@suse.com"

Changes:
--------
--- /work/SRC/openSUSE:Factory/rubygem-amqp/rubygem-amqp.changes        
2012-07-16 09:38:33.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.rubygem-amqp.new/rubygem-amqp.changes   
2012-11-18 20:26:38.000000000 +0100
@@ -1,0 +2,13 @@
+Wed Nov  7 08:27:14 UTC 2012 - cfarr...@suse.com
+
+- license update: BSD-2-Clause or Ruby
+  Package claims to be under the same license as Ruby and even points to
+  the URL for the Ruby license. In the past couple of months the license of
+  Ruby changed from GPL-2.0 or Ruby to BSD-2-Clause or Ruby
+
+-------------------------------------------------------------------
+Sun Oct 28 05:52:28 UTC 2012 - co...@suse.com
+
+- updated to version 0.9.8, basically rewritten - see CHANGELOG
+
+-------------------------------------------------------------------

Old:
----
  amqp-0.6.7.gem

New:
----
  amqp-0.9.8.gem

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ rubygem-amqp.spec ++++++
--- /var/tmp/diff_new_pack.kmEgOW/_old  2012-11-18 20:26:39.000000000 +0100
+++ /var/tmp/diff_new_pack.kmEgOW/_new  2012-11-18 20:26:39.000000000 +0100
@@ -17,41 +17,64 @@
 
 
 Name:           rubygem-amqp
-Version:        0.6.7
+Version:        0.9.8
 Release:        0
 %define mod_name amqp
-#
-#
-Provides:       rubygem-%{mod_name}-0_6 = %{version}
+%define mod_full_name %{mod_name}-%{version}
+
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
-BuildRequires:  rubygems_with_buildroot_patch
-%rubygems_requires
-BuildRequires:  rubygem-eventmachine >= 0.12.4
-Requires:       rubygem-eventmachine >= 0.12.4
-#
-Url:            http://amqp.rubyforge.org/
-Source:         %{mod_name}-%{version}.gem
-#
-Summary:        AMQP client implementation in Ruby/EventMachine
-License:        GPL-2.0+ or Ruby
+BuildRequires:  ruby-macros >= 1
+BuildRequires:  rubygem(rdoc) > 3.10
+Url:            http://github.com/ruby-amqp/amqp
+Source:         %{mod_full_name}.gem
+Summary:        Widely used, feature-rich asynchronous AMQP 0.9.1 client with
+License:        BSD-2-Clause or Ruby
 Group:          Development/Languages/Ruby
 
 %description
-An implementation of the AMQP protocol in Ruby/EventMachine for writing 
clients to the RabbitMQ message broker
+Widely used, feature-rich asynchronous AMQP 0.9.1 client with batteries
+included.
+
+%package doc
+Summary:        RDoc documentation for %{mod_name}
+Group:          Development/Languages/Ruby
+Requires:       %{name} = %{version}
+
+%description doc
+Documentation generated at gem installation time.
+Usually in RDoc and RI formats.
+
+%package testsuite
+Summary:        Test suite for %{mod_name}
+Group:          Development/Languages/Ruby
+Requires:       %{name} = %{version}
+
+%description testsuite
+Test::Unit or RSpec files, useful for developers.
 
 %prep
+#gem_unpack
+#if you need patches, apply them here and replace the # with a % sign in the 
surrounding lines
+#gem_build
+
 %build
-%install
-%gem_install %{S:0}
 
-%clean
-%{__rm} -rf %{buildroot}
+%install
+%gem_install -f
 
 %files
 %defattr(-,root,root,-)
-%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_name}-%{version}.gem
-%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_name}-%{version}/
-%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_name}-%{version}.gemspec
-%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_name}-%{version}/
+%{_libdir}/ruby/gems/%{rb_ver}/cache/%{mod_full_name}.gem
+%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/
+%exclude %{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/spec
+%{_libdir}/ruby/gems/%{rb_ver}/specifications/%{mod_full_name}.gemspec
+
+%files doc
+%defattr(-,root,root,-)
+%doc %{_libdir}/ruby/gems/%{rb_ver}/doc/%{mod_full_name}/
+
+%files testsuite
+%defattr(-,root,root,-)
+%{_libdir}/ruby/gems/%{rb_ver}/gems/%{mod_full_name}/spec
 
 %changelog

-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org

Reply via email to