Hello community,

here is the log from the commit of package PackageKit for openSUSE:Factory 
checked in at 2012-11-19 07:07:07
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/PackageKit (Old)
 and      /work/SRC/openSUSE:Factory/.PackageKit.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "PackageKit", Maintainer is "gnome-maintain...@suse.de"

Changes:
--------
--- /work/SRC/openSUSE:Factory/PackageKit/PackageKit.changes    2012-10-04 
18:41:22.000000000 +0200
+++ /work/SRC/openSUSE:Factory/.PackageKit.new/PackageKit.changes       
2012-11-19 07:07:09.000000000 +0100
@@ -1,0 +2,6 @@
+Fri Nov 16 23:33:08 UTC 2012 - dims...@opensuse.org
+
+- Add PackageKit-no-polkit-backend-1.patch: Do not look for no
+  longer existing polkit-backend-1. Fixes build with polkit >= 106.
+
+-------------------------------------------------------------------

New:
----
  PackageKit-no-polkit-backend-1.patch

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ PackageKit.spec ++++++
--- /var/tmp/diff_new_pack.31f5m0/_old  2012-11-19 07:07:10.000000000 +0100
+++ /var/tmp/diff_new_pack.31f5m0/_new  2012-11-19 07:07:10.000000000 +0100
@@ -76,6 +76,8 @@
 Patch11:        PackageKit-bnc780058-zypp-backend-match-patches.patch
 # PATCH-FIX-UPSTREAM PackageKit-gstreamer-1.0.patch dims...@opensuse.org -- 
Support GStreamer 1.0, taken from upstream git.
 Patch12:        PackageKit-gstreamer-1.0.patch
+# PATCH-FIX-UPSTREAM PackageKit-no-polkit-backend-1.patch dims...@opensuse.org 
-- Drop unused polkit-backend-1 dependency.
+Patch13:        PackageKit-no-polkit-backend-1.patch
 BuildRequires:  NetworkManager-devel
 BuildRequires:  automake
 BuildRequires:  docbook-utils
@@ -335,9 +337,10 @@
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+%patch13 -p1
 
 %build
-# Needed due to patch 3
+# Needed due to patch3 and patch13
 autoreconf -fi
 %configure \
        --disable-static \


++++++ PackageKit-no-polkit-backend-1.patch ++++++
>From 1ae66042cb0ded1455617aba4b82fe8053794ca1 Mon Sep 17 00:00:00 2001
From: Richard Hughes <rich...@hughsie.com>
Date: Fri, 8 Jun 2012 12:22:17 +0100
Subject: [PATCH] Drop the unused polkit-backend-1 check from configure as
 it's gone upstream

---
 configure.ac | 1 -
 1 file changed, 1 deletion(-)

diff --git a/configure.ac b/configure.ac
index 93af2d7..734681d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -584,7 +584,6 @@ AC_SUBST(security_framework, "$with_security_framework")
 
 if test x$with_security_framework = xpolkit; then
        PKG_CHECK_MODULES(POLKIT, \
-                         polkit-backend-1 \
                          polkit-gobject-1 >= $POLKIT_GOBJECT_REQUIRED)
        AC_DEFINE(USE_SECURITY_POLKIT, 1, [if we should use PolicyKit])
 elif test x$with_security_framework = xdummy; then
-- 
1.8.0


-- 
To unsubscribe, e-mail: opensuse-commit+unsubscr...@opensuse.org
For additional commands, e-mail: opensuse-commit+h...@opensuse.org

Reply via email to