Hello community,

here is the log from the commit of package courier-authlib for openSUSE:Factory 
checked in at 2015-08-05 19:14:28
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/courier-authlib (Old)
 and      /work/SRC/openSUSE:Factory/.courier-authlib.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "courier-authlib"

Changes:
--------
--- /work/SRC/openSUSE:Factory/courier-authlib/courier-authlib.changes  
2014-11-26 10:33:52.000000000 +0100
+++ /work/SRC/openSUSE:Factory/.courier-authlib.new/courier-authlib.changes     
2015-08-05 19:14:29.000000000 +0200
@@ -1,0 +2,18 @@
+Wed Aug  5 00:33:31 UTC 2015 - ch...@computersalat.de
+
+- update to 0.66.3
+        * authdaemon.c: auth_callback_default_autocreate, default callback
+        used by clients that autocreates a home directory, if one does not
+        exist already.
+- update to 0.66.2
+        * Update to courier-unicode 1.2.
+        * liblock, couriertls: fix compilation for OpenBSD -- based on a
+        patch from Giovanni Bechis <giova...@paclan.it>.
+        * checkpassword.c (safe_strcmp): Fix bug introduced in 2014-04-27.
+        * courier.spec.in: Update to use systemd macros.
+        * Check for NULL return value from crypt().
+        * Factored out the unicode library into a separate package.
+- add BuildRequires courier-unicode-devel
+- fix deps (SLE_11_SP4) to build againts pgsql >= 9.1
+
+-------------------------------------------------------------------

Old:
----
  courier-authlib-0.66.1.tar.bz2
  courier-authlib-0.66.1.tar.bz2.sig

New:
----
  courier-authlib-0.66.3.tar.bz2
  courier-authlib-0.66.3.tar.bz2.sig

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ courier-authlib.spec ++++++
--- /var/tmp/diff_new_pack.4yWR0n/_old  2015-08-05 19:14:30.000000000 +0200
+++ /var/tmp/diff_new_pack.4yWR0n/_new  2015-08-05 19:14:30.000000000 +0200
@@ -1,7 +1,7 @@
 #
 # spec file for package courier-authlib
 #
-# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
+# Copyright (c) 2015 SUSE LINUX Products GmbH, Nuernberg, Germany.
 #
 # All modifications and additions to the file contributed by third parties
 # remain the property of their copyright owners, unless otherwise agreed
@@ -20,7 +20,7 @@
 Summary:        Courier authentication library
 License:        SUSE-GPL-3.0-with-openssl-exception
 Group:          Productivity/Networking/Email/Servers
-Version:        0.66.1
+Version:        0.66.3
 Release:        0
 Url:            http://www.courier-mta.org/imap/
 Source0:        %{name}-%{version}.tar.bz2
@@ -32,6 +32,7 @@
 Patch0:         %{name}-authdaemonrc.patch
 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
 PreReq:         coreutils
+BuildRequires:  courier-unicode-devel
 BuildRequires:  expect
 BuildRequires:  gcc-c++
 BuildRequires:  gdbm-devel
@@ -40,7 +41,7 @@
 BuildRequires:  openldap2-devel
 BuildRequires:  pam-devel
 BuildRequires:  pkg-config
-BuildRequires:  postgresql-devel
+BuildRequires:  postgresql-devel >= 9.1
 BuildRequires:  procps
 BuildRequires:  sqlite3-devel
 Requires:       expect

++++++ courier-authlib-0.66.1.tar.bz2 -> courier-authlib-0.66.3.tar.bz2 ++++++
++++ 72973 lines of diff (skipped)


Reply via email to