Hello community,

here is the log from the commit of package NetworkManager-vpnc for 
openSUSE:Factory checked in at 2016-09-21 18:27:16
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/NetworkManager-vpnc (Old)
 and      /work/SRC/openSUSE:Factory/.NetworkManager-vpnc.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "NetworkManager-vpnc"

Changes:
--------
--- /work/SRC/openSUSE:Factory/NetworkManager-vpnc/NetworkManager-vpnc.changes  
2016-08-17 12:01:42.000000000 +0200
+++ 
/work/SRC/openSUSE:Factory/.NetworkManager-vpnc.new/NetworkManager-vpnc.changes 
    2016-09-21 18:27:17.000000000 +0200
@@ -1,0 +2,42 @@
+Sat May 14 22:19:38 UTC 2016 - zai...@opensuse.org
+
+- Update to version 1.2.2:
+  + Use a proper name for the AppStream metadata.
+  + Updated translations.
+- Stop passing --disable-more-warnings to configure, no longer
+  needed.
+
+-------------------------------------------------------------------
+Tue May 10 14:33:28 UTC 2016 - dims...@opensuse.org
+
+- Update to version 1.2.0:
+  + build: don't include the full path to a plugin by default.
+  + Updated translations.
+
+-------------------------------------------------------------------
+Tue May 10 14:33:27 UTC 2016 - dims...@opensuse.org
+
+- Update to version 1.1.93 (1.2-rc1):
+  + No changes.
+- Changes from version 1.1.92:
+  + plugin: avoid calling GetAll on service object.
+  + Updated translations.
+
+-------------------------------------------------------------------
+Tue May 10 14:33:26 UTC 2016 - dims...@opensuse.org
+
+- Update to version 1.1.91:
+  + Updated translations.
+
+-------------------------------------------------------------------
+Tue May 10 14:33:25 UTC 2016 - dims...@opensuse.org
+
+- Update to version 1.1.90:
+  + Ported to libnm, libnma and GDBus.
+- Add pkgconfig(libnm) and pkgconfig(libnma) BuildRequires: new
+  dependencies.
+- Drop nm-vpnc-desktop.patch: no longer needed.
+- Drop icon sources: as there is no .desktop file, we also do not
+  need an icon for it.
+
+-------------------------------------------------------------------
@@ -5 +47 @@
-  frontend package
+  frontend package (boo#997343).

Old:
----
  NetworkManager-vpnc-1.0.8.tar.xz
  NetworkManager-vpnc-nm-vpnc.png
  nm-vpnc-desktop.patch

New:
----
  NetworkManager-vpnc-1.2.2.tar.xz

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ NetworkManager-vpnc.spec ++++++
--- /var/tmp/diff_new_pack.SDlYgo/_old  2016-09-21 18:27:18.000000000 +0200
+++ /var/tmp/diff_new_pack.SDlYgo/_new  2016-09-21 18:27:18.000000000 +0200
@@ -20,24 +20,21 @@
 Summary:        NetworkManager VPN Support for vpnc
 License:        GPL-2.0+
 Group:          Productivity/Networking/System
-Version:        1.0.8
+Version:        1.2.2
 Release:        0
-# FIXME .desktop icon is currently disabled (on purpose) in the NM tarballs. 
They will re-appear later on (when nmce supports --import)
-# FIXME: --disable-more-warnings should be dropped from configure when 
possible. Added with 0.9.2.0 for Gtk+ 3.3 build.
 Url:            http://www.gnome.org/projects/NetworkManager
-Source0:        
http://download.gnome.org/sources/NetworkManager-vpnc/1.0/%{name}-%{version}.tar.xz
-Source1:        NetworkManager-vpnc-nm-vpnc.png
-Patch0:         nm-vpnc-desktop.patch
+Source0:        
http://download.gnome.org/sources/NetworkManager-vpnc/1.2/%{name}-%{version}.tar.xz
 BuildRequires:  intltool
 BuildRequires:  translation-update-upstream
 BuildRequires:  update-desktop-files
-BuildRequires:  pkgconfig(NetworkManager) >= 0.9.10
+BuildRequires:  pkgconfig(NetworkManager) >= 0.9.6
 BuildRequires:  pkgconfig(dbus-glib-1)
 BuildRequires:  pkgconfig(gtk+-3.0)
-BuildRequires:  pkgconfig(libnm-glib) >= 0.9.10
-BuildRequires:  pkgconfig(libnm-glib-vpn) >= 0.9.10
-BuildRequires:  pkgconfig(libnm-gtk) >= 1.0.5
-BuildRequires:  pkgconfig(libnm-util) >= 0.9.10
+BuildRequires:  pkgconfig(libnm-glib) >= 0.9.6
+BuildRequires:  pkgconfig(libnm-glib-vpn) >= 0.9.6
+BuildRequires:  pkgconfig(libnm-gtk) >= 0.9.9.0
+BuildRequires:  pkgconfig(libnm-util) >= 0.9.6
+BuildRequires:  pkgconfig(libnma) >= 1.1.0
 BuildRequires:  pkgconfig(libsecret-unstable)
 Requires:       %{name}-frontend
 Requires:       NetworkManager >= 0.9.10
@@ -64,27 +61,16 @@
 %prep
 %setup -q
 translation-update-upstream
-%patch0 -p1
-cp -a %{S:1} nm-vpnc-settings.png
 
 %build
 %configure\
-       --disable-static \
-        --disable-more-warnings
+       --disable-static
 %__make %{?_smp_mflags}
 
 %install
 %makeinstall
 %find_lang %{name} %{?no_lang_C}
 find %{buildroot}%{_libdir} -name '*.la' -delete -print
-# FIXME: There is no MIME type definition for application/x-openvpn-settings 
in %{_datadir}/mime/packages.
-# Without it, MIME icon has no effect.
-mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/mimetypes
-mv 
$RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/gnome-mime-application-x-cisco-vpn-settings.png
 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/mimetypes/
-cp nm-vpnc-settings.png $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/
-# FIXME .desktop icon is currently disabled (on purpose) in the NM tarballs. 
They will re-appear later on (when nmce supports --import)
-# %%suse_update_desktop_file nm-vpnc GNOME Network Monitor Applet
-%suse_update_desktop_file nm-vpnc-auth-dialog
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -97,19 +83,20 @@
 
 %files
 %defattr(-,root,root,0755)
+%{_libdir}/NetworkManager/libnm-vpn-plugin-vpnc.so
 %{_libexecdir}/nm-vpnc-service
 %{_libexecdir}/nm-vpnc-service-vpnc-helper
+%dir %{_libexecdir}/NetworkManager
+%dir %{_libexecdir}/NetworkManager/VPN
+%{_libexecdir}/NetworkManager/VPN/nm-vpnc-service.name
 %config %{_sysconfdir}/NetworkManager/VPN/nm-vpnc-service.name
 %config %{_sysconfdir}/dbus-1/system.d/nm-vpnc-service.conf
 
 %files gnome
 %defattr(-,root,root,0755)
-# FIXME .desktop icons are currently disabled (on purpose) in the NM tarballs. 
They will re-appear later on (when nmce supports --import)
-#%{_datadir}/applications/nm-vpnc.desktop
-%{_datadir}/applications/nm-vpnc-auth-dialog.desktop
+%{_datadir}/appdata/network-manager-vpnc.metainfo.xml
 # FIXME: Owned also by NetworkManager-openvpn. Probably move to 
NetworkManager-gnome:
 %{_datadir}/gnome-vpn-properties/
-%{_datadir}/icons/hicolor/*/*/*.png
 %{_libdir}/NetworkManager/libnm-vpnc-properties.so*
 %{_libexecdir}/nm-vpnc-auth-dialog
 

++++++ NetworkManager-vpnc-1.0.8.tar.xz -> NetworkManager-vpnc-1.2.2.tar.xz 
++++++
++++ 12952 lines of diff (skipped)


Reply via email to