Hello community,

here is the log from the commit of package vlc for openSUSE:Factory checked in 
at 2016-09-21 18:31:03
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Comparing /work/SRC/openSUSE:Factory/vlc (Old)
 and      /work/SRC/openSUSE:Factory/.vlc.new (New)
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Package is "vlc"

Changes:
--------
--- /work/SRC/openSUSE:Factory/vlc/vlc.changes  2016-09-20 13:23:24.000000000 
+0200
+++ /work/SRC/openSUSE:Factory/.vlc.new/vlc.changes     2016-09-21 
18:31:04.000000000 +0200
@@ -1,0 +2,12 @@
+Tue Sep 20 17:32:50 UTC 2016 - jeng...@inai.de
+
+- Drop VLC from summaries (rpmlint: name-repeated-in-summary).
+  Improve summaries and descriptions.
+
+-------------------------------------------------------------------
+Tue Sep 20 17:08:50 UTC 2016 - dims...@opensuse.org
+
+- Update summaries: 'VLC' is sufficiently known by now - and nobody
+  really remembers the name 'Video Lan Client'.
+
+-------------------------------------------------------------------

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Other differences:
------------------
++++++ vlc.spec ++++++
--- /var/tmp/diff_new_pack.RRuOgP/_old  2016-09-21 18:31:06.000000000 +0200
+++ /var/tmp/diff_new_pack.RRuOgP/_new  2016-09-21 18:31:06.000000000 +0200
@@ -39,7 +39,7 @@
 Name:           vlc
 Version:        2.2.4
 Release:        0
-Summary:        Video Lan Client multimedia player
+Summary:        Graphical media player
 License:        GPL-2.0+ and LGPL-2.1+
 Group:          Productivity/Multimedia/Video/Players
 Url:            http://www.videolan.org
@@ -224,36 +224,41 @@
 Obsoletes:      %{name}-gnome <= %{version}
 
 %description
-VLC media player is a highly portable multimedia player for various
-audio and video formats (MPEG-1, MPEG-2, MPEG-4, DivX, mp3, ogg, ...)
+VLC media player is a multimedia player for many
+audio and video files and formats (such as MPEG, DivX, mp3, ogg, ...)
 as well as DVDs, VCDs, and various streaming protocols.
 It can also be used as a server to stream in unicast or multicast
 in IPv4 or IPv6 on a high-bandwidth network.
 
+%if 0%{?BUILD_ORIG}
+Note that the actual support is provided through ffmpeg and gstreamer
+libraries, which may not have all codecs enabled that were just named.
+%endif
+
 %package devel
-Summary:        Video Lan Client Development system
+Summary:        Development files for the VLC media player system
 Group:          Development/Libraries/C and C++
 Requires:       %{name} = %{version}
 
 %description devel
-Those development headers are required if you plan on coding against VLC
+These development headers are required if you plan on coding against VLC.
 
 %package -n libvlc%{libvlc}
-Summary:        Shared library libvlc
+Summary:        Shared code for the VLC media player program
 Group:          System/Libraries
 
 %description -n libvlc%{libvlc}
-Shared library libvlc. To be installed by system dependencies
+This subpackage contains libraries that are part of VLC.
 
 %package -n libvlccore%{libvlccore}
-Summary:        Shared library libvlc
+Summary:        Shared code for the VLC media player program
 Group:          System/Libraries
 
 %description -n libvlccore%{libvlccore}
-Shared library libvlc. To be installed by system dependencies
+This subpackage contains libraries that are part of VLC.
 
 %package noX
-Summary:        VLC: VideoLAN Client - without X dependencies
+Summary:        VLC without X dependencies
 Group:          Productivity/Multimedia/Video/Players
 Requires:       libvlc%{libvlc} = %{version}-%{release}
 Requires:       libvlccore%{libvlccore} = %{version}-%{release}
@@ -261,7 +266,7 @@
 Recommends:     %{name}-lang
 Recommends:     %{name}-codecs
 Recommends:     libdvdcss
-# Tha lang-package was renamed to vlc-lang to assist AppStream building
+# The lang-package was renamed to vlc-lang to assist AppStream building
 Obsoletes:      %{name}-noX-lang
 # This is a hack only due to libbluray not having versioned symbols as well as
 # having a strange ABI/API break between 0.3 and 0.7
@@ -269,9 +274,9 @@
 Conflicts:      %{conflicts}-noX
 
 %description noX
-This Package of VLC contains the bare requirements you need to install.
-Here is no graphical User Interface included, thus it's also perfectly
-suitable for server installations (Streaming Server for example)
+This package of VLC contains the bare requirements you need to install.
+There is no graphical user interface included, thus it is also perfectly
+suitable for server installations, for example, to run a streaming server.
 
 Should you decide to install the GUI modules, %{name}-noX will stay
 installed as a dependency.
@@ -279,30 +284,29 @@
 %lang_package
 
 %package codec-gstreamer
-Summary:        VLC: VideoLAN Client - Decode using GStreamer
+Summary:        GStreamer integration for the VLC media player
 Group:          Productivity/Multimedia/Video/Players
 Requires:       %{name}-noX = %{version}
 Supplements:    packageand(%{name}-noX:%(rpm --qf "%%{name}" -qf $(readlink -f 
%{_libdir}/libgstapp-1.0.so)))
 
 %description codec-gstreamer
-This package enhances the functionality of the VLC VideoLAN Client by
-using GStreamer as backend to decode videos (incl. GStreamers available
-modules).
+This package enhances the functionality of the VLC media player by
+using GStreamer and its submodules as a backend to decode streams.
 
 %if 0%{?BUILD_ORIG}
 %package codecs
-Summary:        VLC: VideoLAN Client - Codec extension
+Summary:        Additional codecs for the VLC media player
 Group:          Productivity/Multimedia/Video/Players
 Requires:       %{name}-noX = %{version}
 Supplements:    %{name}-noX
 
 %description codecs
-This Package enhances the functionality of the VLC VideoLAN Client with
-Codecs that are not available in a stock openSUSE distribution.
+This package enhances the functionality of the VLC media player by
+codecs that are not available in the stock openSUSE distribution.
 %endif
 
 %package qt
-Summary:        VLC: VideoLAN Client - Qt interface
+Summary:        Qt interface for the VLC media player
 Group:          Productivity/Multimedia/Video/Players
 Requires:       %{name}-noX = %{version}-%{release}
 %if 0%{?suse_version} >= 1310
@@ -313,7 +317,8 @@
 Conflicts:      %{conflicts}-qt
 
 %description qt
-The all new Qt interface for the VLC VideoLAN Client.
+This subpackage provides a Qt interface for VLC and selects it by
+default when `vlc` is invoked from an X session.
 
 %prep
 echo '********* ENTERED PREP PHASE ********'


Reply via email to